Download it now!
Bug 94264 - UI: Cell Input Help is not removed when another cell is selected
Summary: UI: Cell Input Help is not removed when another cell is selected
Status: RESOLVED DUPLICATE of bug 93922
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.2.1 rc
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2015-09-16 10:07 UTC by sergio.callegari
Modified: 2015-12-17 10:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing the leftover help text (14.18 KB, image/png)
2015-09-24 06:58 UTC, sergio.callegari
Details
Test case to reproduce issue (7.75 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2015-09-24 10:49 UTC, sergio.callegari
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2015-09-16 10:07:05 UTC
To reproduce:

1) Open an empty spreadsheet
2) Select a cell
3) Use the DATA->Validity->Input Help function to associate an input help to the cell, tick the show input help when the cell is selected
4) Select the cell and see the help window
5) Select another cell and see (hopefully) the help window disappear
6) Repeat from 2)

At a certain point, you will see that some help windows are left over
Comment 1 sergio.callegari 2015-09-16 10:08:10 UTC
In fact, the left overs will probably appear when you click on a cell with a help text and then on another cell that also has an help text
Comment 2 Buovjaga 2015-09-20 15:48:34 UTC
No repro on Win.

Win 7 Pro 64-bit, Version: 5.0.1.2 (32-bit)
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: fi-FI (fi_FI)

Version: 5.1.0.0.alpha1+ (x64)
Build ID: 9ce08dcc2e32c5554ddf71b79173f8854e0568ad
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-09-17_21:43:51
Locale: en-US (fi_FI)
Comment 3 sergio.callegari 2015-09-24 06:56:20 UTC
Might be Linux specific, then.

Seen also on 5.0.2.2.

Finding a 100% sure strategy to reproduce the leftover help texts seems hard. Basically, help texts appear to be left over at random. Sometimes they are left over even when you switch between different sheets.

Unfortunately, help texts that remain are not just graphical glitches, but logical ones. Namely, when you click with the mouse, the cells below the help text are not clickable and if you select them with the cursor, they get selected below the help text without being redrawn on top of it.

With this, help texts are completely unusable with LibO 5 calc in Linux.

The attached screenshot gives you an example.
Comment 4 sergio.callegari 2015-09-24 06:58:03 UTC
Created attachment 118985 [details]
Screenshot showing the leftover help text

In the figure, you see a screenshot of calc.

One is working on a sheet, and still has an help text left over that is from another sheet!

The leftover help text covers the spreadsheet making it totally unusable. the only solution is to save and reload the spreadsheet.
Comment 5 Buovjaga 2015-09-24 07:32:24 UTC
No repro after vigorous testing.

Kubuntu 15.04 64-bit KDE Plasma 5.4
Version: 5.0.1.2
Build ID: 00m0(Build:2)
Locale: en-US (en_US.UTF-8)

Version: 5.1.0.0.alpha1+
Build ID: 69e670bee91c1c24cef184da4135d0dece33ecf6
TinderBox: Linux-rpm_deb-x86_64@70-TDF-dbg, Branch:master, Time: 2015-09-24_02:56:28
Locale: en-US (en_US.UTF-8)
Comment 6 sergio.callegari 2015-09-24 10:48:25 UTC
Some more notes:

- Issue was introduced with LibO 5. Not present in 4.4.

- To reproduce, try attached file

1) Open file.
2) On sheet 1, click on cell B1
3) Click on sheet 2
4) See the empty sheet 2 with the leftover help text from sheet 1
Comment 7 sergio.callegari 2015-09-24 10:49:21 UTC
Created attachment 118990 [details]
Test case to reproduce issue

Open sheet
Click on Cell B1 in sheet 1
See help text
Click on sheet 2
See that help text remains on screen
Comment 8 Buovjaga 2015-09-24 16:55:10 UTC
Ok, I forgot to test while switching from sheet to sheet.
Now I could repro.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)
Comment 9 sergio.callegari 2015-09-25 10:37:24 UTC
Now realizing that it might be a duplicate of 93922
Comment 10 Buovjaga 2015-09-26 17:58:30 UTC
Oh dear, you are right :)

*** This bug has been marked as a duplicate of bug 93922 ***
Comment 11 Robinson Tryon (qubit) 2015-12-17 10:32:47 UTC
Migrating Whiteboard tags to Keywords: (bibisectRequest)
[NinjaEdit]