Download it now!
Bug 94266 - Formatting:columns
Summary: Formatting:columns
Status: RESOLVED DUPLICATE of bug 91475
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2015-09-16 10:24 UTC by robertw
Modified: 2015-12-15 11:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description robertw 2015-09-16 10:24:16 UTC
Win 7. Set column widths. Save as Microsoft Excel 2007-2013 xlsx file. Reopen and column widths have changed. Correct widths and save again. Reopen again process still gives changed widths.
Comment 1 raal 2015-09-16 19:21:28 UTC
Reproducible with Version: 5.1.0.0.alpha1+
Build ID: a60db559d409514fb93af0167c543ad2f852b499
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-09-16_01:09:20

column width 4 cm is 3,94 cm after reopen.

works correct with Version: 4.4.0.0.alpha2+
Build ID: 3f94c9e9ddfd807b449f3bb9b232cf2041fa12d2, regression
Comment 2 MM 2015-09-17 23:12:33 UTC
Duplicate of bug 94255 or bug 94257 ??? Or else from bug 92753
Comment 3 raal 2015-11-30 14:47:17 UTC
Bibisected, and problematic commit is the same as in bug 91475. Setting as duplicate.

bec7b2530255008c4e07cfb40b8779a4e74d7a16 is the first bad commit
commit bec7b2530255008c4e07cfb40b8779a4e74d7a16
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Jun 5 10:17:16 2015 -0500

    source sha:bcdd3a403ca1d0ac05dd2382cf7e8fdfd3281322
    source sha:bcdd3a403ca1d0ac05dd2382cf7e8fdfd3281322
    source sha:16726a1b37df8bdcae02b3c7699df814977222bd

    author    Markus Mohrhard <markus.mohrhard@googlemail.com>    2015-05-20 02:06:46 (GMT)
committer    Markus Mohrhard <markus.mohrhard@googlemail.com>    2015-05-20 02:07:17 (GMT)
commit    bcdd3a403ca1d0ac05dd2382cf7e8fdfd3281322 (patch)
forgot to include that part

author    Markus Mohrhard <markus.mohrhard@googlemail.com>    2015-05-20 01:59:49 (GMT)
committer    Markus Mohrhard <markus.mohrhard@googlemail.com>    2015-05-20 02:04:13 (GMT)
commit    16726a1b37df8bdcae02b3c7699df814977222bd (patch)
better algorithm for OOXML column width import, tdf#91267

*** This bug has been marked as a duplicate of bug 91475 ***
Comment 4 Robinson Tryon (qubit) 2015-12-15 11:03:38 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]