Download it now!
Bug 94279 - paragraph padding not allowed without border
Summary: paragraph padding not allowed without border
Status: RESOLVED DUPLICATE of bug 41542
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-16 13:32 UTC by Andras Timar
Modified: 2016-10-28 18:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
bugdoc (ODT) (2.03 KB, application/vnd.oasis.opendocument.text)
2015-09-16 13:32 UTC, Andras Timar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andras Timar 2015-09-16 13:32:23 UTC
Created attachment 118773 [details]
bugdoc (ODT)

In the attached bugdoc, which is artificial, but valid ODF, the paragraph padding was set to 1 inch. When opened in LibreOffice, the padding is ignored. 

In Format - Paragraph - Borders - Spacing to contents there are the 1 inch padding values but they are greyed out. It seems that LibreOffice handles padding only when there is an actual border. However, setting border style to none resets the paddings to 0 again.
Comment 1 Buovjaga 2015-09-20 15:43:57 UTC
Yep.

Win 7 Pro 64-bit, Version: 5.0.1.2 (32-bit)
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: fi-FI (fi_FI)

Version: 5.1.0.0.alpha1+ (x64)
Build ID: 9ce08dcc2e32c5554ddf71b79173f8854e0568ad
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-09-17_21:43:51
Locale: en-US (fi_FI)
Comment 2 Oliver Specht (CIB) 2016-04-29 09:43:38 UTC
This issue is more about handling of padding without border than about loading the attribute. Changed title accordingly. (was: ODF import: paragraph padding ignored)

In the dialog Format/Paragraph/Border the "Spacing to Contents" area is disabled as long as no border is applied. The same applies to paragraph styles.
Workaround: Apply a border with background color
Comment 3 Justin L 2016-10-28 18:06:24 UTC
Look for this in to be resolved in LO5.4

*** This bug has been marked as a duplicate of bug 41542 ***