Download it now!
Bug 94311 - Writer doesn't remember window layout
Summary: Writer doesn't remember window layout
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks: Sidebar-Accessibility
  Show dependency treegraph
 
Reported: 2015-09-17 14:53 UTC by bf
Modified: 2017-12-02 17:40 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bf 2015-09-17 14:53:18 UTC
Writer does not remember the window layout. I like to have my Stylist docked on the left, but it doesn't stay there after a re-start.

Steps to reproduce:
1. rename profile (to make sure the problem is there)
2. start Writer
3. Writer starts without any docked bars or windows
4. Press F11, shows Stylist
5. Dock stylist on left side of window.
6. Close Writer
7. Re-start Writer
8. Stylist is gone, and "Properties" window is docked on right side of window.

Expectation:
8. Stylist is docked on the left.
Comment 1 bf 2015-09-17 14:53:54 UTC
Just notice a type. Step 1 should be:

1. rename profile (to make sure the problem ISN'T there)
Comment 2 tommy27 2015-09-18 11:57:42 UTC
I confirm issue under Win8.1 x64 using LibO 5.0.1.2
Comment 3 QA Administrators 2016-09-20 10:32:44 UTC Comment hidden (obsolete)
Comment 4 Telesto 2016-11-30 13:17:49 UTC
Confirming with
Version: 5.4.0.0.alpha0+
Build ID: 4130c8def811d1dcc87eacaa8ae48ba02738a790
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-11-29_01:03:18
Locale: nl-NL (nl_NL); Calc: CL
Comment 5 QA Administrators 2017-12-02 16:26:19 UTC Comment hidden (obsolete)
Comment 6 V Stuart Foote 2017-12-02 17:40:20 UTC
Placement of the Sidebar Deck--holding the Stylelist (F11)--Docked Right (default), Undocked (floating), Docked Left--has retained its state in the GUI for some time.

Additional work on bug 67770 [1] has now implemented LastActiveDeck function, so all modules now reopen to the correct Sidebar Deck (i.e. StyleList, or Properties, or Navigator, etc.).

The functions correctly now...available at 6.0.0

=-ref-=
[1] http://cgit.freedesktop.org/libreoffice/core/commit/?id=23467fa5cfa2feffbeba2177c0d393f8ebe1a0a3