Download it now!
Bug 94336 - FILESAVE XLSX Chart lines switch from dashed to solid
Summary: FILESAVE XLSX Chart lines switch from dashed to solid
Status: RESOLVED DUPLICATE of bug 108064
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks:
 
Reported: 2015-09-18 10:02 UTC by robertw
Modified: 2018-10-11 09:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Charts:Lines and legends (20.56 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-09-25 10:31 UTC, robertw
Details

Note You need to log in before you can comment on or make changes to this bug.
Description robertw 2015-09-18 10:02:37 UTC
A 2 line chart was created with one line styled as "dashed" whilst the other was a continuous line [default state]. Saved as Microsoft Excel 2007-13 xlsx. When file reopened dashed line reverts to the default state i.e.continuous. Problem similar to Bug 94267.
Comment 1 raal 2015-09-20 10:05:22 UTC
I can confirm with Version: 5.1.0.0.alpha1+
Build ID: a60db559d409514fb93af0167c543ad2f852b499
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-09-16_01:09:20
Comment 2 Markus Mohrhard 2015-09-25 04:52:58 UTC
Please attach a ods file that can be export to show the problem.
Comment 3 robertw 2015-09-25 10:31:48 UTC
Created attachment 119019 [details]
Charts:Lines and legends

Copy of file sent by raal but with two lines changed to dashed. If you move the legend to the top and set as 2col by 2row and save file in Microsoft Excel 2007-13 xlsx format. Then reopen and you will find lines no longer dashed and legend now 1col by 4rows as in original ods file but in top position.
Comment 4 QA Administrators 2016-11-08 10:28:52 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2018-06-13 17:03:25 UTC
Repro.

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 98db90e2ccd7cefaa5094c2d1d2af8cb10b4a867
CPU threads: 8; OS: Linux 4.16; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on June 13th 2018

Arch Linux 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 6 Gabor Kelemen 2018-10-11 09:14:45 UTC
We just checked and this is fixed in master due to the changes in bug #108064

*** This bug has been marked as a duplicate of bug 108064 ***