Bug 94368 - DOCX has extra indent for numbering
Summary: DOCX has extra indent for numbering
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.2.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-20 01:45 UTC by Andrew Kornilov
Modified: 2017-10-22 09:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Document to play with (156.41 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-09-20 01:45 UTC, Andrew Kornilov
Details
How DOC looks in LO5 (500.83 KB, image/png)
2015-09-20 01:46 UTC, Andrew Kornilov
Details
How DOCX looks in LO5 (492.77 KB, image/png)
2015-09-20 01:46 UTC, Andrew Kornilov
Details
How DOCX looks in LO4 (444.34 KB, image/png)
2015-09-20 01:46 UTC, Andrew Kornilov
Details
Original DOC file (384.00 KB, application/msword)
2015-09-20 22:05 UTC, Andrew Kornilov
Details
How DOC looks in all LO4/LO5 (72.28 KB, image/png)
2015-10-20 21:55 UTC, Andrew Kornilov
Details
How DOCX looks in all LO5 (85.08 KB, image/png)
2015-10-20 21:55 UTC, Andrew Kornilov
Details
How DOCX looks in LO4 (77.16 KB, image/png)
2015-10-20 21:56 UTC, Andrew Kornilov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Kornilov 2015-09-20 01:45:22 UTC
Created attachment 118859 [details]
Document to play with

Hi,

1. I have a correct DOC file, everything is OK in both LO4 and LO5.
2. I export it to DOCX, using LO5.
3. Open that DOCX in LO5 and get extra indent for text (and some other problems with tabulation below)
4. Open _the same_ DOCX in LO4 and do not have that extra indent.

See the attached screenshot and text file.

Thank you.
Comment 1 Andrew Kornilov 2015-09-20 01:46:05 UTC
Created attachment 118860 [details]
How DOC looks in LO5
Comment 2 Andrew Kornilov 2015-09-20 01:46:21 UTC
Created attachment 118861 [details]
How DOCX looks in LO5
Comment 3 Andrew Kornilov 2015-09-20 01:46:37 UTC
Created attachment 118862 [details]
How DOCX looks in LO4
Comment 4 tommy27 2015-09-20 07:17:22 UTC
you should upload the original .doc file so we can exactly replicate the issue
Comment 5 Andrew Kornilov 2015-09-20 22:05:22 UTC
Oops, sorry, missed that.

Here is the original DOC.
Comment 6 Andrew Kornilov 2015-09-20 22:05:41 UTC
Created attachment 118885 [details]
Original DOC file
Comment 7 steve -_- 2015-09-21 06:55:39 UTC
OSX 10.10.5
LO Version: 5.1.0.0.alpha1+
Build ID: 5aa58e499a1fbd4e54692233d1b7f8c6237ad8e2
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2015-09-09_03:16:30
Locale: de-DE (de.UTF-8)

Confirmed → NEW

saving doc file as docx causes indent to rise +1 it seems.
Comment 8 steve -_- 2015-09-22 08:39:56 UTC
Might be related or a dupe of https://bugs.documentfoundation.org//show_bug.cgi?id=92454

Let's wait for a new nightly build and retest with that.
Comment 9 tommy27 2015-09-23 19:11:26 UTC
sorry but bug is still there in LibO 5.1.0.0.alpha1+
Build ID: 0ca9a3523cb2ccf97d7d13fdf4616af0dbe173d9
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-09-23_05:16:23
Locale: it-IT (it_IT)
Comment 10 Andrew Kornilov 2015-09-29 14:48:46 UTC
Hi,

Any news? Shall i rest that on any nightly build?

Thanks.
Comment 11 Andras Timar 2015-09-30 14:30:42 UTC
It looks to be fixed in today's master.
Comment 12 Andrew Kornilov 2015-10-01 02:36:35 UTC
That's good news. However, i can't see new builds since Sep 28 here: http://dev-builds.libreoffice.org/daily/libreoffice-5-0/
Comment 13 Andrew Kornilov 2015-10-01 02:37:00 UTC
Ah, i might be wrong and should use http://dev-builds.libreoffice.org/daily/master/
Comment 14 Timur 2015-10-06 11:06:59 UTC
Looks like a duplicate of Bug 93919 so fixed, anyway WorksForMe.
Comment 15 Timur 2015-10-06 11:19:05 UTC
(In reply to Andras Timar from comment #11)
> It looks to be fixed in today's master.

WorksForMe is related to master. It will be in 5.0.3.
Comment 16 Andrew Kornilov 2015-10-13 16:09:31 UTC
Just checked LO5-5.0.3.1 (ru-ru) and the bug still exists.
Should i wait for the release?
Comment 17 Andrew Kornilov 2015-10-20 21:54:47 UTC
Hi,

Just tested on the latest 5.1 alpha. The problem with extra indent has gone.
But i've got a new one: exported to DOCX document has wrong bold font for the second level numbering.

The same happens with LO5.0.3.

LO4 doesn't display it with bold text, but it has another font for numbering, looks like Sans Serif (Arial?), while it was Serif in DOC.

I'm attaching three screenshots:

1. How the DOC file looks in all LO4/LO5.
2. How it looks as DOCX in LO5
3. How it looks as DOCX in LO4
Comment 18 Andrew Kornilov 2015-10-20 21:55:27 UTC
Created attachment 119807 [details]
How DOC looks in all LO4/LO5
Comment 19 Andrew Kornilov 2015-10-20 21:55:48 UTC
Created attachment 119808 [details]
How DOCX looks in all LO5
Comment 20 Andrew Kornilov 2015-10-20 21:56:08 UTC
Created attachment 119809 [details]
How DOCX looks in LO4
Comment 21 tommy27 2015-10-21 03:56:32 UTC
@Andrew
thanks for your new report.
however, please do not reopen bugs that were related to another issue (the extra indent whoch you confirmed is gone).

I created a new bug report about the new problem here at:
Bug 95213 - second level numbering turns bold in .DOCX export

so I'm closing again the current one.
let's continue discussion in the new one.