Bug 94384 - Icons appearing with black backgrounds when "use OpenGL for Rendering" is enabled
Summary: Icons appearing with black backgrounds when "use OpenGL for Rendering" is ena...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:5.0.3 target:5.0.4
Keywords:
: 94741 (view as bug list)
Depends on:
Blocks: VCL-OpenGL OpenGL
  Show dependency treegraph
 
Reported: 2015-09-20 17:41 UTC by Carlo
Modified: 2016-10-25 19:21 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Sifr Calc (21.56 KB, image/png)
2015-09-20 17:41 UTC, Carlo
Details
Sifr Impress (Bezier) (45.73 KB, image/png)
2015-09-20 17:42 UTC, Carlo
Details
Icons Breeze size big (157.43 KB, image/jpeg)
2015-09-28 09:21 UTC, Ingo Belka
Details
Icons Breeze size small (75.33 KB, image/jpeg)
2015-09-28 09:21 UTC, Ingo Belka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carlo 2015-09-20 17:41:08 UTC
Created attachment 118879 [details]
Sifr Calc

Sifr icon set has some problems in x86 build: many icons have an ugly
black background in Calc and Impress.
No problems with previous RC1 build.
Tested on Windows 10 with italian localization.
Comment 1 Carlo 2015-09-20 17:42:43 UTC
Created attachment 118880 [details]
Sifr Impress (Bezier)
Comment 2 Yousuf Philips (jay) (retired) 2015-09-22 11:16:22 UTC
Hi Carlo,

The image shown is from the breeze icon theme and is shown there because the icon doesnt appear in the sifr icon theme.
Comment 3 Buovjaga 2015-09-22 12:02:05 UTC
I have no problem with either Sifr or Breeze regarding the Headers & footers icon.

Win 7 Pro 64-bit, Version: 5.0.1.2 (32-bit)
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: fi-FI (fi_FI)
Comment 4 Carlo 2015-09-22 12:31:01 UTC
(In reply to Beluga from comment #3)
> I have no problem with either Sifr or Breeze regarding the Headers & footers
> icon.
> 
> Win 7 Pro 64-bit, Version: 5.0.1.2 (32-bit)
> Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
> Locale: fi-FI (fi_FI)
Previous versions were OK for me too.
The problem has appeared in 5.0.2.2 (32-bit)
Comment 5 Buovjaga 2015-09-24 16:57:27 UTC
Still no problem.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)
Comment 6 Ingo Belka 2015-09-28 09:21:14 UTC
Created attachment 119089 [details]
Icons Breeze size big
Comment 7 Ingo Belka 2015-09-28 09:21:51 UTC
Created attachment 119090 [details]
Icons Breeze size small
Comment 8 Ingo Belka 2015-09-28 09:24:08 UTC
Hi, the same issue here:

Windows 7 64 bit
Version: 5.0.2.2 (x64)
Build-ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe-GL
Gebietsschema: de-DE (de_DE)

with a difference between small and big icons in Breeze-Icon-Set (see images above).
Comment 9 Ingo Belka 2015-09-28 09:31:06 UTC
But no problems with Options->LibreOffice->View->"use OpenGL for Rendering"  unchecked.
Comment 10 Yousuf Philips (jay) (retired) 2015-09-28 10:53:35 UTC
(In reply to Ingo Belka from comment #9)
> But no problems with Options->LibreOffice->View->"use OpenGL for Rendering" 
> unchecked.

So with this unchecked, the problem is fixed? Does this same issue happen with any other icon themes like tango or galaxy? Can you let us know more details about your graphics card? Are you running the driver version of your graphics card?
Comment 11 Carlo 2015-09-28 21:15:18 UTC
(In reply to Yousuf (Jay) Philips from comment #10)
> (In reply to Ingo Belka from comment #9)
> > But no problems with Options->LibreOffice->View->"use OpenGL for Rendering" 
> > unchecked.
> 
> So with this unchecked, the problem is fixed? 
I can confirm that if "use OpenGL for Rendering" option is unchecked, all Sifr icons look good again.

> Does this same issue happen with any other icon themes like tango or galaxy? 
Breeze and Tango themes have the same problem but no issues with Galaxy theme.

> Can you let us know more details about your graphics card?
> Are you running the driver version of your graphics card?
My graphic card is: AMD Radeon HD 7500M/7600M.
Driver version: 15.200.1062.1004
Comment 12 andreas_k 2015-09-28 21:26:02 UTC
> > Does this same issue happen with any other icon themes like tango or galaxy? 
> Breeze and Tango themes have the same problem but no issues with Galaxy
> theme.


I think it is something with the png file cause when I say png for rgb than it works but when there are only selected colors (1-2 colors) than you get this problem.
Comment 13 Yousuf Philips (jay) (retired) 2015-09-29 11:04:32 UTC
Beluga stated he has an intel HD3000 with "use OpenGL for Rendering" enabled and the issue doesnt arise. Might be something limited to AMD graphics cards.
Comment 14 Michael Meeks 2015-09-29 13:53:58 UTC
Can reproduce here; open a calc window with sifr enabled and bingo ... I -imagine- that this is an artifact of the png compression schemes used and something specific to these icons: presumably we're using a very unusual bit-depth / palette in there somehow and this is confusing things.

Tomaz - can you reproduce ? and/or fix =)
Comment 15 Ingo Belka 2015-09-30 04:58:54 UTC
I do have NVIDIA GeForce GT 640 with native NVIDIA driver version 10.18.13.5382 / 07.08.2015.
Comment 16 Carlo 2015-10-05 19:38:42 UTC
(In reply to Carlo from comment #11)
> > Can you let us know more details about your graphics card?
> > Are you running the driver version of your graphics card?
> My graphic card is: AMD Radeon HD 7500M/7600M.
> Driver version: 15.200.1062.1004
Renderer: AMD Radeon HD 7500M/7600M Series
Vendor: ATI Technologies Inc.
Memory: 2048 MB
Version: 4.4.13399 Core Profile Forward-Compatible Context 15.200.1062.1004
Shading language version: 4.40
Comment 17 Commit Notification 2015-10-12 09:40:21 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c97ca26f2d5790d46b712813c15bb6731f0232b0

tdf#94384 fix black icons with OpenGL enabled on Windows

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2015-10-14 08:03:45 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=15195fb801b354a2f2356aa3cea0a06b9eb1e066&h=libreoffice-5-0

tdf#94384 fix black icons with OpenGL enabled on Windows

It will be available in 5.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Michael Meeks 2015-10-15 13:35:53 UTC
So marking fixed; thanks Tomaz !
Comment 20 Michael Meeks 2015-10-15 17:37:08 UTC
*** Bug 94741 has been marked as a duplicate of this bug. ***
Comment 21 Commit Notification 2015-10-20 06:19:28 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-5-0-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bcbf852f8cb7ebde5f506d53fdcc837d439be475&h=libreoffice-5-0-3

tdf#94384 fix black icons with OpenGL enabled on Windows

It will be available in 5.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2015-10-22 15:55:18 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6b7ae3f8dd917d4c3a77c8adda502ca98f86c683&h=libreoffice-5-0

tdf#94384 change the black icons fix for LO 5.0

It will be available in 5.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Ingo Belka 2015-11-04 14:54:35 UTC
My fresh installed version

Version: 5.0.3.2 (x64)
Build-ID: e5f16313668ac592c1bfb310f4390624e3dbfb75-GL
Gebietsschema: de-DE (de_DE)

and the problem is disappeared. Thank you!