Download it now!
Bug 94408 - Tree expanders missing from "Options" when using Oxygen windeco+widgets
Summary: Tree expanders missing from "Options" when using Oxygen windeco+widgets
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-21 12:49 UTC by Paul
Modified: 2015-10-30 14:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Options setting showing missing expanders on left panel. (18.70 KB, image/png)
2015-09-21 12:49 UTC, Paul
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul 2015-09-21 12:49:53 UTC
Created attachment 118898 [details]
Options setting showing missing expanders on left panel.

Using:
Libreoffice Version: 5.0.1.2.0+ Build ID: 00m0(Build:2)

openSUSE Tumbleweed: 20150909
KDE Plasma Version: 5.4.0
Window decoration: Oxygen 5.4.0
Widget style: Oxygen 5.4.0


Tree expanders are missing from the left panel of the Options settings. The only way to expand a category is by double clicking. (Expanders are present when using Breeze).

Attached screen-shot showing missing expanders.
Comment 1 Paul 2015-09-22 09:31:36 UTC
Should also have added...

Libreoffice Icon size and style: Small / Oxygen
libreoffice-icon-theme-oxygen: 5.0.1.2-1.1
Comment 2 Buovjaga 2015-09-23 08:10:10 UTC
Could not reproduce.

I changed everything I could to Oxygen, but for the life of me I could not change the Window decorations!
Installed kde-style-oxygen-qt4, plasma-theme-oxygen, oxygen-cursor-theme, but look and feel did not show Oxygen.

Are the expanders missing for you even though your Window decorations are not Oxygen?

Kubuntu 15.04 64-bit Plasma 5.4
Version: 5.0.1.2
Build ID: 00m0(Build:2)
Locale: en-US (en_US.UTF-8)
Comment 3 Paul 2015-09-23 10:55:35 UTC
I had made quite a few changes so started fresh with a new (KDE) user profile and new LO profile.

It seems that this is an issue with the LO Oxygen icon theme - not the desktop theme or window decoration, as I at first thought.

As I initially, stated I'm using:
Libreoffice Icon size and style: Small / Oxygen
libreoffice-icon-theme-oxygen: 5.0.1.2-1.1

With this the expanders _are_ missing.

If I change this to:
Libreoffice Icon size and style: Small / Breeze
libreoffice-icon-theme-breeze: 5.0.1.2-1.1

The expanders are correctly shown.

I decided to try other LO icon themes - the ones currently installed were:
libreoffice-icon-theme-breeze
libreoffice-icon-theme-hicontrast
libreoffice-icon-theme-oxygen

Using hicontrast the expanders are correctly shown.



I then installed Tango
libreoffice-icon-theme-tango: 5.0.1.2-1.1

The expanders are correctly shown.

At this point I switched back to:
Libreoffice Icon size and style: Small / Oxygen

The expanders _are now_ correctly shown when using LO Oxygen icons

I then un-installed 
libreoffice-icon-theme-tango: 5.0.1.2-1.1

The expanders are now again missing when using LO Oxygen icons.


Now I'm guessing that what is happening is that the expander icon is actually missing from the (LO) Oxygen icon theme, and it falls back to, or inherits Tango.

For the moment I will simply install, but not 'use' the Tango theme.


If you remove any libreoffice-icon-themes other than:
libreoffice-icon-theme-breeze
libreoffice-icon-theme-hicontrast
libreoffice-icon-theme-oxygen

then I expect you will be able to duplicate this bug.

Whether it's worth pursuing is debatable :)

Many thanks.
Comment 4 Buovjaga 2015-09-24 10:00:05 UTC
Nope, I didn't have Tango icon theme to begin with.
Comment 5 Paul 2015-09-24 10:31:25 UTC
OK... Don't understand this then... weird :)

Using "Libreoffice Icon size and style: Small / Oxygen" without "libreoffice-icon-theme-tango" present the expanders are missing. With "libreoffice-icon-theme-tango" and the expanders are shown.

As it 'works for you' and I have a 'fix' I guess we'll leave it at that. Thanks for your time in looking at this.
Comment 6 Buovjaga 2015-09-24 12:51:10 UTC
I will poke the design team about this on IRC.
Comment 7 Yousuf Philips (jay) (retired) 2015-09-27 11:52:26 UTC
Hi Paul,

Icon themes are depended on more complete icon themes, so if the dependency icon themes arent installed, icons will show up missing in dependent icon themes. This issue has to be fix by package maintainers by setting the necessary dependency packages for icon themes packages.