Bug 94454 - No Help for Template Manager Available
Summary: No Help for Template Manager Available
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
5.0.1.2 release
Hardware: Other All
: medium normal
Assignee: Cat Vance
QA Contact:
URL:
Whiteboard: target:5.4.0
Keywords:
: 94133 (view as bug list)
Depends on:
Blocks: HelpGaps 107229
  Show dependency treegraph
 
Reported: 2015-09-22 21:43 UTC by Harald Koester
Modified: 2017-04-18 02:50 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Draft of Help File for Template Manager using beginner's template (17.16 KB, application/vnd.oasis.opendocument.text)
2017-03-25 09:59 UTC, Cat Vance
Details
Updated draft of Help file for the Template Manager (17.74 KB, application/vnd.oasis.opendocument.text)
2017-04-01 05:57 UTC, Cat Vance
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2015-09-22 21:43:28 UTC
I did not find any Help for the Template Manager. I would expect the following possibilities to open a help about the Template Manager:
(a) Open LibreOffice Help > Contents > Common Help topics > Template Manager
(b) Open LibreOffice Help > LibreOffice Writer, Calc, Impress or Draw > Index > Template Manager
(c) With F1 when the Template Manager dialogue is displayed.
(d) With a Help button inside the Template Manager itself.
Comment 1 Buovjaga 2015-09-27 15:03:06 UTC
Sure -> NEW.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)

Version: 5.1.0.0.alpha1+ (x64)
Build ID: 8d16834a9820fb8c983753c3e2a05922885060b9
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-09-22_21:29:32
Locale: en-US (fi_FI)
Comment 2 Samuel Mehrbrodt (CIB) 2016-09-08 14:01:41 UTC
This blog entry has some good information about the redesigned template manager which will hopefully help to write help: https://akkidevblog.wordpress.com/2016/07/23/redesigning-the-template-manager/
Comment 3 Harald Koester 2016-09-13 13:39:41 UTC
Checked again with version 5.2.1. A help page exists, but it's not up-to-date:

https://help.libreoffice.org/Common/Templates_Manager
Comment 4 Gabor Kelemen 2016-10-13 11:56:40 UTC
*** Bug 94133 has been marked as a duplicate of this bug. ***
Comment 5 Cat Vance 2017-03-25 09:59:03 UTC
Created attachment 132139 [details]
Draft of Help File for Template Manager using beginner's template

After discussion on the LibreOffice Documentation mailing list with Olivier Hallot, I agreed to take this bug. I am a beginner and this is my first attempt at Open Source documentation. Please advise how this documentation can be improved.
Comment 6 Olivier Hallot 2017-03-27 19:29:55 UTC
Thanks for the document. Very good start.

Please note that you have another instance of the template manager in the start center.

The start center shows when LibreOffice is open without any document or when no other document is left open in LibreOffice. When the start center is visible, a button on the left pane shows Template and a list of categories. It is important to write about and explain the difference with the TM dialog.
Comment 7 Cat Vance 2017-03-29 20:20:21 UTC
Thanks Olivier, I will look into that in the next few days
Comment 8 Cat Vance 2017-04-01 05:57:07 UTC
Created attachment 132302 [details]
Updated draft of Help file for the Template Manager

Included information about the Template Manager in Start Center, and added missing information about context menu available when right-clicking on templates in the main window.
Comment 9 Commit Notification 2017-04-17 11:33:16 UTC
Catherine Vance committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=475e4baff99a7643a2b5dcf171c5415b1309a5bf

tdf#94454 Help page for new template manager