Bug Hunting Session
Bug 94477 - missing "Format > Character" item in the customize keyboard command menu
Summary: missing "Format > Character" item in the customize keyboard command menu
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:5.0.4
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2015-09-23 21:14 UTC by Emanuele Forner
Modified: 2016-10-25 19:20 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing a duplicate item and the missing one ("Carattere") (97.93 KB, image/png)
2015-09-24 16:23 UTC, Emanuele Forner
Details
Screenshot showing another duplicate item (98.26 KB, image/png)
2015-09-24 16:24 UTC, Emanuele Forner
Details
Screenshot showing another duplicate item (96.07 KB, image/png)
2015-09-24 16:25 UTC, Emanuele Forner
Details
Screenshot from LO 4.0.6 showing item "Carattere" (15.92 KB, image/png)
2015-09-25 12:18 UTC, tommy27
Details
my patch (723 bytes, application/mbox)
2015-10-04 20:16 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emanuele Forner 2015-09-23 21:14:46 UTC
I used to assign the keyboard shortcut <CTRL>+<M> to the menu command Format > Character, but now this option has disappeared from the menu command Tools > Customize > Keyboard, because instead in the Format options group there are some options duplicated and some others missing.
Best regards,
Emanuele Forner (Italy)
Comment 1 tommy27 2015-09-24 16:10:31 UTC
would you please post a screenshot showing the missing items?
Comment 2 Emanuele Forner 2015-09-24 16:23:59 UTC
Created attachment 118996 [details]
Screenshot showing a duplicate item and the missing one ("Carattere")
Comment 3 Emanuele Forner 2015-09-24 16:24:42 UTC
Created attachment 118997 [details]
Screenshot showing another duplicate item
Comment 4 Emanuele Forner 2015-09-24 16:25:10 UTC
Created attachment 118998 [details]
Screenshot showing another duplicate item
Comment 5 tommy27 2015-09-25 07:42:06 UTC
the duplicate entries issue was already reported in Bug 56811 - CONFIGURATION: Duplicate Shortcut description

regarding the missing "Carattere" item I see that in the Italian UI under LibO 4.4.5 there's "Colore riempimento carattere" and "Colore sfondo carattere" 

are those the function you miss?

did they have a different name in previous LibO release?
can you tell which was the latest LibO version where you had that "Carattere" item in the right place?

status NEEDINFO
Comment 6 Emanuele Forner 2015-09-25 07:52:22 UTC
(In reply to tommy27 from comment #5)
> the duplicate entries issue was already reported in Bug 56811 -
> CONFIGURATION: Duplicate Shortcut description
> 
> regarding the missing "Carattere" item I see that in the Italian UI under
> LibO 4.4.5 there's "Colore riempimento carattere" and "Colore sfondo
> carattere" 
> 
> are those the function you miss?
> 
> did they have a different name in previous LibO release?
> can you tell which was the latest LibO version where you had that
> "Carattere" item in the right place?
> 
> status NEEDINFO

The missing function is the command launching the Character Formatting Window, and it's always been named "Carattere".
I noticed the issue only in LibreOffice 5.0.1, because I had to reinstall the OS and could not recover all my former personal settings (anyway, in another PC I own, which didn't need any reinstallation, although the Tools > Customize window behaves the same way as reported here, LibreOffice 5.0.2 has mantained the former personal settings, in which I have assigned the shortcut <CTRL>+<M> to the Character Formatting Window launcher command.
Comment 7 tommy27 2015-09-25 08:26:55 UTC
I'll check later with older LibO releases to see which one was the latest featuring the missing "Carattere" item

stay tuned
Comment 8 tommy27 2015-09-25 12:18:32 UTC
Created attachment 119020 [details]
Screenshot from LO 4.0.6 showing item "Carattere"

I confirm the issue under Win8.1 x64 as well

the item "Format > Character" (in the Italian UI "Formato > Carattere" was available 'till LibO 4.0.6 (see screenshot) and disappeared since LibO 4.1.0

I don't know if it was intentionally removed or not...
anyway let's set status to NEW

that item is missing in recent LibO releases and in LibO Dev 5.1 alpha too
Comment 9 Yousuf Philips (jay) (retired) 2015-09-26 14:55:52 UTC
This is a one-line fix, but it would be useful to find out why it was removed before adding it back again, so lets see if the bibisect team can find it out.
Comment 10 Yousuf Philips (jay) (retired) 2015-10-04 20:16:48 UTC
Created attachment 119281 [details]
my patch

Adding my patch here so incase i'm not around, the patch will still be. :D
Comment 11 Maxim Monastirsky 2015-10-05 20:24:43 UTC
It comes from:

commit 58a825b4d047c0f99d4f9a193c97af423b23fb97
Author: Oliver-Rainer Wittmann <orw@apache.org>
Date:   Wed Apr 17 11:50:36 2013 +0000

    Resolves: #i122025# UNO commands introduced with sidebar

By comparing the commit with the details posted in the Apache Bugzilla, it's clear that it was a pure mistake.

@Jay: Please also revert the changes for AccelConfig and MenuConfig. Thanks.
Comment 12 Yousuf Philips (jay) (retired) 2015-10-06 08:48:08 UTC
(In reply to Maxim Monastirsky from comment #11)
> @Jay: Please also revert the changes for AccelConfig and MenuConfig. Thanks.

@Maxim: So i guess my patch only brought it back for the toolbar config dialog. :D

Patch is in - https://gerrit.libreoffice.org/#/c/19187/
Comment 13 Commit Notification 2015-10-06 10:26:08 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=051667ec91a3fa4175fc8ae59529ac02b95e0683

tdf#94477 Make Format > Character accessible for customization

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2015-10-13 16:58:15 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c86140fe7399328fbaa7d6b1445c68458c5c2971&h=libreoffice-5-0

tdf#94477 Make Format > Character accessible for customization

It will be available in 5.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.