Download it now!
Bug 94479 - Impossible to NOT view changes as one edits; every save of document shows changes.
Summary: Impossible to NOT view changes as one edits; every save of document shows cha...
Status: CLOSED DUPLICATE of bug 97103
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-24 07:28 UTC by Peter Lemkin
Modified: 2017-04-25 05:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Record button in LO (41.60 KB, image/jpeg)
2015-10-06 10:54 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Lemkin 2015-09-24 07:28:26 UTC
I make my living doing editing and have had no trouble before [or minor] with LIbreOffice...until LibreOffice 5. First, annoying but not critical is that one can NO LONGER tell if one has set it on track changes and/or show changes [before one could tell after one had set that to where it was set - now not! Fix this!]

However, just impossible to work with is when one sets it on 'do not show changes' [as one can NOT edit a long and complex paper seeing the changes - I can't anyway!] EVERY time the document is saved [often in my case, but that is not important] the entire MS reverts to the view of SHOWING changes. FIX THIS FAST - or the editing function is useless in my opinion.
Comment 1 Peter Lemkin 2015-09-24 07:30:56 UTC
An afterthought I haven't quite figured out. I re-installed 4.4 to work around this, but any document I had first had in 5 would NOT work at all [no buttons responded at all] in 4.4. I'm not sure why this is so and seems very odd indeed.
Comment 2 Buovjaga 2015-09-28 08:31:42 UTC
(In reply to Peter Lemkin from comment #0)
> I make my living doing editing and have had no trouble before [or minor]
> with LIbreOffice...until LibreOffice 5. First, annoying but not critical is
> that one can NO LONGER tell if one has set it on track changes and/or show
> changes [before one could tell after one had set that to where it was set -
> now not! Fix this!]

Not seeing this. The record button icon in the top toolbar gets highlighted.
 
> However, just impossible to work with is when one sets it on 'do not show
> changes' [as one can NOT edit a long and complex paper seeing the changes -
> I can't anyway!] EVERY time the document is saved [often in my case, but
> that is not important] the entire MS reverts to the view of SHOWING changes.
> FIX THIS FAST - or the editing function is useless in my opinion.

Not seeing this either. The setting remains the same after saving and reloading multiple times.

It might be you have to do this: https://wiki.documentfoundation.org/UserProfile#Resolving_corruption_in_the_user_profile

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists after profile reset. Change to RESOLVED WORKSFORME, if the problem went away.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)

Version: 5.1.0.0.alpha1+ (x64)
Build ID: 8d16834a9820fb8c983753c3e2a05922885060b9
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-09-22_21:29:32
Locale: en-US (fi_FI)
Comment 3 Peter Lemkin 2015-09-30 05:40:11 UTC
I should have added that I am using this only in Ubuntu - both Ubuntu 12.04.5 (64) and Ubuntu 14.04.3 (64). I see that you tested it on Windows 7-64, but this may not make any difference. I will attempt the profile reset and report.
Comment 4 Peter Lemkin 2015-09-30 06:13:16 UTC
OK, I went into home/.config/libreoffice and was surprised to see 3, 4, but NOT 5 listed. I know that 5 was not installed by me [as had earlier versions, but was an automatic upgrade through the update manager. Should I assume that the folder labelled 4 actually contains the programs and settings for Libreoffice 5? [it does show the date modified as today and I was working on Libreoffice today].

I renamed user to user-old and started LIbreoffice 5. It will not open any previous documents, and endlessly is in a loop tying to recover an untitled document - even when I ask it to discard the recovery data. Ideas?
Comment 5 Buovjaga 2015-09-30 06:19:43 UTC
(In reply to Peter Lemkin from comment #4)
> OK, I went into home/.config/libreoffice and was surprised to see 3, 4, but
> NOT 5 listed. I know that 5 was not installed by me [as had earlier
> versions, but was an automatic upgrade through the update manager. Should I
> assume that the folder labelled 4 actually contains the programs and
> settings for Libreoffice 5? [it does show the date modified as today and I
> was working on Libreoffice today].
> 
> I renamed user to user-old and started LIbreoffice 5. It will not open any
> previous documents, and endlessly is in a loop tying to recover an untitled
> document - even when I ask it to discard the recovery data. Ideas?

Yep, the profile name stayed as '4'.

The looping sounds strange. Have you had a crash before renaming the profile? Does the looping go away, if you rename the folder back?
Comment 6 Peter Lemkin 2015-09-30 06:29:32 UTC
I was unable to open any old documents or create a new one. Yes, when I renamed the file back, it worked as before...with the same problems. If folder 4 contains version 5, then where is the version 4.4 that I had installed, as well, be? It is not working, but is nominally installed. I'm beginning to think I need to remove everything and start all over. Will I loose any important settings or other information doing that. Alternatives?

Earlier, I had to fully working versions on this machine. Now I have to versions - one not working at all and the other not working properly.
Comment 7 Buovjaga 2015-09-30 06:36:41 UTC
(In reply to Peter Lemkin from comment #6)
> beginning to think I need to remove everything and start all over. Will I
> loose any important settings or other information doing that. Alternatives?

Only, if you have defined your own toolbar items, keyboard shortcuts or if you have added any stuff mentioned here: https://wiki.documentfoundation.org/UserProfile#User_profile_content
Comment 8 Peter Lemkin 2015-09-30 07:18:56 UTC
I'm fairly confused now. I'm looking in Synaptic Package Manager and see lots of 4.4.5.2-2 files, but only two that say 5.02~rc2-0ubuntu1~precise2. So a bit confused how I'd remove ver. 5 and start anew. The two 5.02 files are ure and uno-libs3

Are the 1:5.02~rc2-0ubuntu1-precise 2 files the ver. 5 ones?

Thanks
Comment 9 Buovjaga 2015-09-30 07:23:11 UTC
(In reply to Peter Lemkin from comment #8)
> I'm fairly confused now. I'm looking in Synaptic Package Manager and see
> lots of 4.4.5.2-2 files, but only two that say 5.02~rc2-0ubuntu1~precise2.
> So a bit confused how I'd remove ver. 5 and start anew. The two 5.02 files
> are ure and uno-libs3
> 
> Are the 1:5.02~rc2-0ubuntu1-precise 2 files the ver. 5 ones?
> 
> Thanks

I guess the best way to completely eradicate them would be to do this in the command line:

sudo apt-get remove --purge libreoffice*.*
Comment 10 Peter Lemkin 2015-09-30 07:56:14 UTC
And what would be the command line to install a new version of 5 - or download the package, and run all the .deb files?
Comment 11 Buovjaga 2015-09-30 08:04:10 UTC
(In reply to Peter Lemkin from comment #10)
> And what would be the command line to install a new version of 5 - or
> download the package, and run all the .deb files?

If you haven't used the Ubuntu LibO team ppa yet, you should first add it:

sudo add-apt-repository -y ppa:libreoffice/ppa

Then:

sudo apt-get update
sudo apt-get install libreoffice
Comment 12 Peter Lemkin 2015-09-30 08:41:05 UTC
Ok, thank for that information. However, at least on Ubuntu 12.04.5 that I'm now on, complete removal and complete re-installation give me the exact same problems. Nothing is marked as whether the document is tracking changes or showing changes and when it is on 'do not show changes' that lasts only until the next save - and then all changes are show. Installed is ver.5.0.2.2
Comment 13 Buovjaga 2015-10-02 07:28:01 UTC
No problem on Arch Linux (Antergos) 64-bit, LibO 5.0.1.
Comment 14 Peter Lemkin 2015-10-02 08:32:51 UTC
All I can say is these problems are REAL and very ANNOYING on my sustems [both Ubuntu 12.04 and 14.04 and ver. 5 has other problems I've not even mentioned. Unless there are now new changes to default settings I can't find work-arounds to, these are [as I suspect] bugs. One also can NOT select a word or phrase with the mouse [as one always could before] with a right to left selection - only with a left to right selection. This is another flaw and I suspect there are others I've not yet found...it is very buggy. There are also new rules about applying user information that is annoying..and I could go on.
Comment 15 Buovjaga 2015-10-02 08:43:38 UTC
Just to clarify, this change tracking bug appears on completely new documents as well?
Comment 16 Timur 2015-10-06 10:54:12 UTC
Created attachment 119346 [details]
Record button in LO

Peter, please read https://wiki.documentfoundation.org/QA/BugReport. How you write now is annoying, and you're waisting time of us who want to help.

(In reply to Peter Lemkin from comment #0)
> First, annoying but not critical is
> that one can NO LONGER tell if one has set it on track changes and/or show
> changes [before one could tell after one had set that to where it was set -
> now not! Fix this!]
There's record button in LO, and customizing a toolbar is basic knowledge. Not clear what's the problem.

> However, just impossible to work with is when one sets it on 'do not show
> changes' EVERY time the document is saved [often in my case, but
> that is not important] the entire MS reverts to the view of SHOWING changes.
> FIX THIS FAST - or the editing function is useless in my opinion.
Proper bug report says exactly what you do and what you get. Here, it's not clear in which format you save. If it's docx, than it's Bug 89991.
Comment 17 Buovjaga 2015-10-08 16:34:54 UTC
*** Bug 94832 has been marked as a duplicate of this bug. ***
Comment 18 Buovjaga 2015-10-08 16:36:55 UTC
I guess this has to be set to NEW because of bug 94832
Comment 19 Buovjaga 2015-10-08 17:34:00 UTC
Argh, sorry about that.. should still be needinfo while we wait for the answer to:
Here, it's not clear in which format you save. If it's docx, then it's Bug 89991.
Comment 20 Marcelo 2015-10-08 20:08:13 UTC
I've got this annoying every-save-of-document-shows-changes bug as well. Please fix that ASAP! Thank you!
Comment 21 Buovjaga 2015-10-09 05:18:57 UTC
(In reply to Marcelo from comment #20)
> I've got this annoying every-save-of-document-shows-changes bug as well.
> Please fix that ASAP! Thank you!

With what file format? Docx or odt?

For an ASAP fix you have to hire a developer: https://www.documentfoundation.org/certification/developers/
Comment 22 Peter Lemkin 2015-10-09 05:40:12 UTC
When I write my own documents, I usually save in .odt
When I'm doing an edit I'm always sent a .doc or .docx file to edit and save it in that same format. it was on these that I noted the problems. 
Bug 89991 says it is solved...how? where? is it 'solved'? I'm new to these bug reports and often find 'resolved' as listed with NO idea or CLUE how one finds the solution or if it is sent in an update of the software. [or other].
I really haven't tested enough of my own [.odt] documents to know if these problems also appear there. My feeling is they do not - or I've not yet noticed them.
What I DO KNOW is none of the reported problems happened with the older software and only appeared with the version 5.
Comment 23 Peter Lemkin 2015-10-09 05:48:34 UTC
Nice to know it is not my imagination....or my being a 'troll'.

The comment that my comments were 'annoying' or worse was NOT appreciated. I'm a sane 65 year old professor of the sciences and not wont to just write things to needle others needlessly. I do not often report problems with software, but when I do, it is because it is [or seems] real and annoying. 

The right to left highlighting is also real, but perhaps it needs to be put in a separate bug. Sorry, if that was not proper protocol. 

I have had to revert to using MS-Word to do some edits as I can't endlessly switch back to 'do not show changes' a thousand times in an edit. Again, it seems to happen with MS word documents that were imported in their Word formats.
Comment 24 Buovjaga 2015-10-09 05:58:45 UTC
Bug 89991 is not solved. It is still in the NEW state with no developer activity.

*** This bug has been marked as a duplicate of bug 89991 ***
Comment 25 Peter Lemkin 2015-10-09 06:19:26 UTC
I'm not sure it is a duplicate  of 89991. I'm not sure it is even related, but may be an inverse problem. I have only so far noted it in .doc or .docx documents saved in/as the original. I have not yet noticed this on .odt documents later saved as .doc or .docx [unless the program silently changes any Word file into a .odt file and then saves it again as a Word file - which I don't think it does, this is not a duplicate situation I'm reporting]
Comment 26 Buovjaga 2015-10-09 06:23:07 UTC
(In reply to Peter Lemkin from comment #25)
> I'm not sure it is a duplicate  of 89991. I'm not sure it is even related,
> but may be an inverse problem. I have only so far noted it in .doc or .docx
> documents saved in/as the original. I have not yet noticed this on .odt
> documents later saved as .doc or .docx [unless the program silently changes
> any Word file into a .odt file and then saves it again as a Word file -
> which I don't think it does, this is not a duplicate situation I'm reporting]

Do you mean the docx files you saved from odt preserve the 'do not show changes' setting?
Comment 27 Peter Lemkin 2015-10-13 08:54:28 UTC
I'm sure it is NOT a duplicate  of 89991.
I get my editing documents ONLY as .doc or .docx
I edit them without changing the format.
As I've said, I can not see if I'm in save changes or not - nothing changes in the drop down menu; and more importantly I always work with show changes OFF and they do not stay off....every time the file is saved [and I save VERY often], it reverts back to showing all changes. I don't see how this is a duplicate or even very similar to 89991.

I do NOT save .odt files as .doc or .docx. 
I only import .doc or .docx for editing and this is what I'm talking about.
This doesn't seem to happen in .odt files [my own files]. 

I don't know why this is not clear. I do editing for a business. The people I do business with don't even know of Libreoffice, .odt format, or open-source software for that matter. They are locked in MS-Land. I import their files and send them back the edited versions without converting them.

I don't see where this is resolved - sorry.
Comment 28 Buovjaga 2015-10-13 10:23:49 UTC
There is no difference whether you are saving from odt to docx or straight to docx from a new document or handling a docx coming from Microsoft Office. It is the same bug and it is not resolved yet. I can mark this as closed so it is clear this is not resolved.
Comment 29 Justin L 2017-04-25 05:58:20 UTC
This bug was fixed in 5.3 master (documented in bug 97103), and backported to 5.2.0.

Thanks to author Michael Stahl 2016-06-08 10:31:06 (GMT)
commit: a59c4e26abbdd0720d24d3ddc0d6a05a67a31aaf
tdf#97103 sw: fix restoring of SetRedlineMode on DOCX/RTF export

*** This bug has been marked as a duplicate of bug 97103 ***