Bug 94496 - FILEOPEN: CALC wrong calculation with more than 100 rows
Summary: FILEOPEN: CALC wrong calculation with more than 100 rows
Status: RESOLVED DUPLICATE of bug 94924
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-24 20:33 UTC by silvio
Modified: 2015-10-10 19:09 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
step by step screenshots (477.53 KB, application/pdf)
2015-09-24 20:34 UTC, silvio
Details
bug file with more than 100 rows (12.83 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-09-24 20:36 UTC, silvio
Details
no bug, less than 100 rows (12.92 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-09-24 20:37 UTC, silvio
Details
Small example sheet which exhibits miscalculation (42.34 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-10-09 15:28 UTC, Billy Charlton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description silvio 2015-09-24 20:33:19 UTC
Libre Office v5.0.2.2 on Windows 10.

Adding a simple formula for more than 100 rows results in correct display. After saving and closing the file you reopen it. The unchanged formula shows a wrong calculating.
If you want to see the wright result you delete one cell containig a formula at row 2 and copy the upper or lower cell to it. Voilà the correct result appears.

The solution of "A (Andy)" in Bug 91865  https://bugs.documentfoundation.org/show_bug.cgi?id=91865 is not resolving the bug.

See attached PDF file with step by step screenshots and two calc files:
- "bug v5.0.2.2.ods"      -> bug file with more than 100 rows.
- "bug v5.0.2.2 - OK.ods" -> no bug, less than 100 rows.

Regards
Silvio
Comment 1 silvio 2015-09-24 20:34:57 UTC
Created attachment 119000 [details]
step by step screenshots
Comment 2 silvio 2015-09-24 20:36:56 UTC
Created attachment 119001 [details]
bug file with more than 100 rows
Comment 3 silvio 2015-09-24 20:37:37 UTC
Created attachment 119002 [details]
no bug, less than 100 rows
Comment 4 MM 2015-09-25 15:12:17 UTC
Duplicate of bug 94271 ?
Comment 5 silvio 2015-09-27 14:46:36 UTC
(In reply to MM from comment #4)
> Duplicate of bug 94271 ?

No, it's not a duplicate.
I have always the same wrong result and not always other wrong results.
See my formula: it's a very simple addition of "cell n + 1".
Comment 6 Buovjaga 2015-09-28 16:06:29 UTC
Not reproduced from scratch and not confirmed with attachment 119001 [details]. I don't get the phenomenon of 2,2,2,2... in column A etc.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)
Comment 7 Billy Charlton 2015-10-09 15:27:51 UTC
I am also seeing this bug. On my machine I can reproduce this every time with the steps below on this very small file (attached -- testcase.ods)

Steps to reproduce
---------------------
1) Open file testcase.ods
2) Change cell C35 (highlighted in yellow) to any other value; try zero.
3) All calculations in red rows in column E turn to zero.
4) Those cells in column E should not be zero - they are simple additions of two nonzero cells in the sheet.

My system
-----------
Libreoffice 5.0.2.2, installed directly from LibreOffice website link
Windows 7, 64bit -- all security patches applied
Comment 8 Billy Charlton 2015-10-09 15:28:34 UTC
Created attachment 119462 [details]
Small example sheet which exhibits miscalculation
Comment 9 Buovjaga 2015-10-09 16:23:08 UTC
(In reply to Billy Charlton from comment #7)
> Steps to reproduce
> ---------------------
> 1) Open file testcase.ods
> 2) Change cell C35 (highlighted in yellow) to any other value; try zero.
> 3) All calculations in red rows in column E turn to zero.
> 4) Those cells in column E should not be zero - they are simple additions of
> two nonzero cells in the sheet.

I tried it, but only E35 turned zero.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)
Comment 10 Billy Charlton 2015-10-09 16:54:33 UTC
Huh. I tried the same file on a different Windows 7 machine and cannot reproduce. No idea what's different. I'll keep experimenting and report back if I can get it to repro on this 2nd Windows machine.
Comment 11 Joel Madero 2015-10-10 16:55:03 UTC
Please try with a new profile: https://wiki.documentfoundation.org/UserProfile

If it's only happening on a single machine then it's likely a corrupt profile.
Comment 12 Joel Madero 2015-10-10 17:05:25 UTC
File opens fine for me:
Ubuntu 15.04 x64
LibreOffice 5.0.2.2

If it's an issue it's either the profile corrupted or Windows only. I don't see how this could be widespread as we almost definitely have unit tests for this kind of stuff.
Comment 13 GerardF 2015-10-10 18:23:21 UTC
Just an idea : Look if OpenCl is enabled.
see https://bugs.documentfoundation.org/show_bug.cgi?id=94924
Comment 14 Billy Charlton 2015-10-10 18:49:18 UTC
YES! Disabling OpenCL and then recalculating completely eliminates the problem. So this does appear to be a dupe of https://bugs.documentfoundation.org//show_bug.cgi?id=94924

Note, the machine exhibiting this problem with OpenCL has an Nvidia GTX 970 with the latest drivers. The second test machine I tried has a basic motherboard graphic (I think Intel-based).
Comment 15 Joel Madero 2015-10-10 19:09:51 UTC

*** This bug has been marked as a duplicate of bug 94924 ***