Bug Hunting Session
Bug 94498 - UI: Ctrl+Shift+F does not repeat search in Basic IDE
Summary: UI: Ctrl+Shift+F does not repeat search in Basic IDE
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:6.1.0
Keywords:
: 49464 (view as bug list)
Depends on:
Blocks: Find-Search
  Show dependency treegraph
 
Reported: 2015-09-24 23:50 UTC by Cor Nouws
Modified: 2018-05-03 12:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2015-09-24 23:50:33 UTC
in writer it does...
Comment 1 Commit Notification 2015-09-25 10:15:48 UTC
Cor Nouws committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e3aa3e4ac57d61126a30c2fdfd1fca5bd8489888

tdf#94498  UI: Ctrl+Shift+F does not repeat search in Basic IDE

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 2 Cor Nouws 2015-12-03 14:28:44 UTC
*** Bug 49464 has been marked as a duplicate of this bug. ***
Comment 3 Xisco Faulí 2016-09-15 22:23:47 UTC
Hello,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 4 Cor Nouws 2016-09-19 18:11:24 UTC
nope - patch is not sufficient..
Comment 5 Xisco Faulí 2017-07-13 10:56:31 UTC
Setting Assignee back to default. Please assign it back to yourself if you're
still working on this issue
Comment 6 tagezi 2018-04-01 09:32:13 UTC
Now we have three shortcut for repeat search when cursor is placed in the Find toolbar: Enter, Ctrl+G, F3, which we cannot customize.
So, Title this bug report ether should be renamed to "to do customize shortcut for repeat search in IDE" or should be closed as Fix because Ctrl+Shift+F is set.

I take this bug like a customize shortcut for repeat search because I see code and want to try solve this issue.
If a bug report of customize shortcut for repeat search exists, add me CC, please there.
Comment 7 Commit Notification 2018-04-21 06:12:52 UTC
tagezi committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3322661414a558d29146c40c0cd5e9db0a7b21dd

tdf#94498 add repeat search in Basic IDE by shortcut

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Cor Nouws 2018-05-03 12:33:31 UTC
works OK in Version: 6.1.0.0.alpha1+
Build ID: 8a2745e1beee722c8c9691c397e493cc1160bedf
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-04-30_23:34:23
Locale: nl-NL (nl_NL.UTF-8); Calc: group

thanks lera!