Bug 94614 - crash on page style organizer tab, on the default template and russian localisation
Summary: crash on page style organizer tab, on the default template and russian locali...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: Other Windows (All)
: medium critical
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords: regression
: 95020 95036 95058 95088 95602 96334 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-09-29 13:14 UTC by er
Modified: 2016-02-08 16:15 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments
error screenshot (106.79 KB, image/jpeg)
2015-09-29 13:14 UTC, er
Details
backtrace 1 (35.80 KB, text/plain)
2015-10-06 13:07 UTC, er
Details
backtrace 2 (35.38 KB, text/plain)
2015-10-06 13:08 UTC, er
Details

Note You need to log in before you can comment on or make changes to this bug.
Description er 2015-09-29 13:14:58 UTC
Created attachment 119118 [details]
error screenshot

conditions of occurrence:
clean install Windows (w7x64,w81x32,w81x64)
clean install LO 5.0.2.2 (x32, x64) in Russian user interface(in English no this error)
steps in calc - menu > format(Формат) > page(Страница)
Window "Page style:Default"(Стиль страницы: Базовый) by default opening tab - Organiser(Управление).  	
here an error occurs.
On other tabs no error, and if disable footer or header - no error.
Not fatal for the experienced user, but inconvenient. but if the user is a neophyte and a lot of them.
 		
a vicious circle: 	
In order to remove the error, you need to disable the header or footer. To do this, need go to edit style settings or try to create a copy, but when you try it, opening a page style tab by default :)

Thanks.
Comment 1 er 2015-09-30 10:33:42 UTC
in 4.4.5.2 no error
in 5.0.1.2 no error
It means fresh error in 5.0.2.2
Comment 2 er 2015-09-30 14:36:47 UTC
in 4.4.5.2 no error
in 5.0.1.2 no error
It means fresh error in 5.0.2.2
Comment 3 er 2015-10-05 08:12:09 UTC
I am sorry to trouble, but I wrote the invisible fatal error message? Maybe I did something wrong? Or there are some deadlines to respond? Thank you again. :(
Comment 4 raal 2015-10-05 11:07:08 UTC
I can not confirm with LO 5.0.2.2, win7
Comment 5 er 2015-10-05 11:19:42 UTC
(In reply to raal from comment #4)
> I can not confirm with LO 5.0.2.2, win7


you have these settings set - config clear and default not updated any version: 
- header and foother is on
- default tab page setup - organizer
- you LO lang interface russian
?
Comment 6 er 2015-10-05 12:17:27 UTC
(In reply to er from comment #5)
> (In reply to raal from comment #4)
> > I can not confirm with LO 5.0.2.2, win7
> 
> 
> you have these settings set - config clear and default not updated any
> version: 
> - header and foother is on
> - default tab page setup - organizer
> - you LO lang interface russian
> ?


three more people confirm the problem

http://forum.ru-board.com/topic.cgi?forum=5&topic=30414&start=3140#4
Comment 7 er 2015-10-05 12:58:52 UTC
In the presence of 9 computers - w8.1 SL RUS x32, w8.1 SL RUS x64, w7 PRO RUS x64.
On all computers newly installed windows and a newly installed LO 5.0.2.2 x32 and x64 with the russian language interface.
I have 100% repeatability error.
That is all the new russian-speaking users on windows and LO with the russian language in the interface will have this bug.
In my opinion it is very affect many decisions on acceptance into operation with LO. :(
Comment 8 tagezi 2015-10-05 20:56:43 UTC
I confirm it Bug.

Today I and kompilainne discussed this problem in chat. It is specific for the Russian localization and is not confirmed in English.

Chat logs can be viewed here: http://irclog.whitequark.org/libreoffice-ru/2015-10-05#14215509;

I include on the CC list kompilainenn
Comment 9 er 2015-10-05 21:15:05 UTC
(In reply to Lera from comment #8)
> I confirm it Bug.
> 

"the ice has started breacking up, gentelmen..."

Thanks :)
Comment 10 tagezi 2015-10-05 22:01:12 UTC
Too early to rejoice. This is just a confirmation of the bug.
Now we do not have a tool for Windows to find out when the bug appeared. I do not see an explicit candidate from correction is made in 5.0.2. The Russian developers is very few, so the testing will be too difficult.
All it makes this bug is difficult for fixing.

However, there is a way to help developers:
https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg
Comment 11 er 2015-10-05 22:09:42 UTC
(In reply to Lera from comment #10)
> Too early to rejoice. 
I see, this is only the beginning :)
Maybe it helps: in version 5.0.1.2 error does not occur.
And debugger will try to see tomorrow, it's time to sleep now :)
Comment 12 er 2015-10-06 13:07:23 UTC
Created attachment 119353 [details]
backtrace 1

backtrace 1 process
Comment 13 er 2015-10-06 13:08:05 UTC
Created attachment 119354 [details]
backtrace 2

backtrace 2 dump :)
Comment 14 tagezi 2015-10-06 13:14:38 UTC
(In reply to er from comment #13)
> Created attachment 119354 [details]
> backtrace 2
> 
> backtrace 2 dump :)

Thank you for your efforts. Let's hope that the bug will be fixed in the near future.
Comment 15 er 2015-10-06 13:31:49 UTC
hope "dies" last. thanks, will wait :)
Comment 16 Maxim Monastirsky 2015-10-14 08:00:35 UTC
*** Bug 95036 has been marked as a duplicate of this bug. ***
Comment 17 tagezi 2015-10-14 16:11:20 UTC
*** Bug 95058 has been marked as a duplicate of this bug. ***
Comment 18 er 2015-10-14 18:27:23 UTC
для русского языка, пока исправляют, ошибку можно обходить так:
- переключиться на английский язык интерфейса LO, перезапустить LO
- зайти в calc, формат > страница
- выключить верхний или нижний колонтитул (или оба)
- сохранить файл как шаблон.
- установить шаблоном по умолчанию.
- переключиться обратно на русский язык в интерфейсе.
дальше все как удобно, но не включать оба колонтитула одновременно, иначе опять будет падать.
Comment 19 tagezi 2015-10-14 18:30:58 UTC
install 4.4 - It is also an option
Comment 20 er 2015-10-14 18:52:34 UTC
(In reply to Lera from comment #19)
> install 4.4 - It is also an option

in 5.0.1.2 no this error too, but downgrade ;)
Comment 21 Maxim Monastirsky 2015-10-15 18:20:50 UTC
*** Bug 95088 has been marked as a duplicate of this bug. ***
Comment 22 Maxim Monastirsky 2015-10-15 18:22:12 UTC
*** Bug 95020 has been marked as a duplicate of this bug. ***
Comment 23 Maxim Monastirsky 2015-11-05 12:57:30 UTC
*** Bug 95602 has been marked as a duplicate of this bug. ***
Comment 24 kompilainenn 2015-11-09 19:12:02 UTC
Версия: 5.1.0.0.alpha1+ (x64)
ID сборки: 04783fd91832fa01a5b096f395edd7ad4f9c0f6b-GL
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-11-07_21:35:01
Локаль: ru-RU (ru_RU)

bug is not reproduced
Comment 25 Yan Pas 2015-11-27 18:09:59 UTC
There is no crash at 32 bit version of Windows
Comment 26 VictorVG 2015-12-03 21:48:52 UTC
OS Win7 SP1 x64, Libre Office v5.0.4.1 x64 local copy updated in to v5.0.3.2 x64 up to v5.0.4.1 x64, rapid test - run Calc which New document, menu Format -> Page, change any options in the dialogs - not crash.
Comment 27 VictorVG 2015-12-03 21:54:10 UTC
Additional information:

This bug exist and confirmed on version 5.0.2.2 - 5.0.3.2 and possible resolved on v5.0.4.1.
Comment 28 Maxim Monastirsky 2015-12-08 10:46:16 UTC
*** Bug 96334 has been marked as a duplicate of this bug. ***
Comment 29 raal 2016-02-07 20:50:23 UTC
(In reply to VictorVG from comment #27)
> Additional information:
> 
> This bug exist and confirmed on version 5.0.2.2 - 5.0.3.2 and possible
> resolved on v5.0.4.1.

Hello er,
could you test with version 5.0.4? Thanks
Comment 30 kompilainenn 2016-02-07 21:13:39 UTC
(In reply to raal from comment #29)
> (In reply to VictorVG from comment #27)
> > Additional information:
> > 
> > This bug exist and confirmed on version 5.0.2.2 - 5.0.3.2 and possible
> > resolved on v5.0.4.1.
> 
> Hello er,
> could you test with version 5.0.4? Thanks

in 5.0.4 bug is fixed.
Comment 31 raal 2016-02-08 16:15:22 UTC
(In reply to kompilainenn from comment #30)
> (In reply to raal from comment #29)
> > (In reply to VictorVG from comment #27)
> > > Additional information:
> > > 
> > > This bug exist and confirmed on version 5.0.2.2 - 5.0.3.2 and possible
> > > resolved on v5.0.4.1.
> > 
> > Hello er,
> > could you test with version 5.0.4? Thanks
> 
> in 5.0.4 bug is fixed.

Thanks, closing