Bug 94625 - FORMATTING: rotated drawing do not anchored to cell
Summary: FORMATTING: rotated drawing do not anchored to cell
Status: RESOLVED DUPLICATE of bug 119191
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2015-09-29 20:34 UTC by Nicklas W Bjurman
Modified: 2020-01-21 09:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of translation (7.64 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-10-02 09:18 UTC, Nicklas W Bjurman
Details
Screenshot (146.23 KB, image/png)
2015-10-02 09:22 UTC, Nicklas W Bjurman
Details
Screenshot 2 (165.23 KB, image/png)
2015-10-02 09:22 UTC, Nicklas W Bjurman
Details
Screenshot 3 (151.26 KB, image/png)
2015-10-02 09:22 UTC, Nicklas W Bjurman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicklas W Bjurman 2015-09-29 20:34:31 UTC
I added an arrow and rotated it, anchored it to the cell and then added an extra column a few columns to the left of the cells which the arrow covered.

The arrow jumped up about 10 rows up. Unrotated arrows did work as expected and simply translated with the extra column.
Comment 1 Buovjaga 2015-10-02 09:08:04 UTC
Not reproduced.

Maybe attach an example document.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)

Version: 5.1.0.0.alpha1+
Build ID: 25de5cfa43b2b1cb7d7214470acc7719839e13fe
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-01_08:49:54
Locale: en-US (fi_FI)
Comment 2 Nicklas W Bjurman 2015-10-02 09:18:24 UTC
Created attachment 119191 [details]
Example of translation

Add a column to the right of the drawing to reproduce the translation of a rotated drawing.
Comment 3 Nicklas W Bjurman 2015-10-02 09:22:11 UTC
Created attachment 119192 [details]
Screenshot
Comment 4 Nicklas W Bjurman 2015-10-02 09:22:31 UTC
Created attachment 119193 [details]
Screenshot 2
Comment 5 Nicklas W Bjurman 2015-10-02 09:22:46 UTC
Created attachment 119194 [details]
Screenshot 3
Comment 6 Buovjaga 2015-10-02 13:09:52 UTC
(In reply to Nicklas W Bjurman from comment #2)
> Created attachment 119191 [details]
> Example of translation
> 
> Add a column to the right of the drawing to reproduce the translation of a
> rotated drawing.

Repro with document. Left or right, no matter.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)

Version: 5.1.0.0.alpha1+
Build ID: 25de5cfa43b2b1cb7d7214470acc7719839e13fe
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-01_08:49:54
Locale: en-US (fi_FI)
Comment 7 raal 2015-10-22 14:14:11 UTC
regression, works correct with LibreOffice 3.5.0 
Build ID: d6cde02, linux
Reproduced with Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 8 raal 2015-12-12 14:23:55 UTC
reproducible Version: 4.2.0.0.alpha1+
Comment 9 Xisco Faulí 2016-09-12 12:13:33 UTC
Adding keyword 'bibisectRequest'.
Comment 11 raal 2016-11-21 07:03:45 UTC
bisect not possible
d34912b1eb89f5b0fde219ea57902f3a7d05cb7a is the first bad commit
commit d34912b1eb89f5b0fde219ea57902f3a7d05cb7a
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Fri Sep 18 10:34:06 2015 +0800

    source-hash-2b1aa949539d2fcbb3d349be3c279996630d83fc
    
    Bibisect: This commit covers the following source commit(s) which failed to build
    43682489c18c707bc0d5701f7f6a2df2511eeb0c
    88ed6d1348b5d3d517afcbe5fa1257d55625f39b
    fe8bcfa422c654e35ec22b5e3b1a512ae438b565
    5de206a7fbe74a7022bb3b20f190e6a3e6f1e3ae
    fb455e5013ab014058ad5f92238ef6fc91b2afcf
    a4c80756ca429ac3654455b5e6a6b6a700361b9a
    3a3254a900a6a8aad8d3321bf8b10d1770555cf5
    cac113602c8f60b7eaea8709f6670b00b0925447
    f8a75e4b225d3a998174f47066b9a72472546767
    1dace0c3e0972c2bde8db177433b7d095025bcca
    742515639168cd35a0c2036a5bf6c46b2a3a554e
    e70defefd80c44646a742ff581bca9b467b8e713
    396eb4f5cf8b37cd2a9f14d85764e03761ade19f
    f37df270f1a984f0a6138f4f22fc79a50e71dcc2
    349e9248f801d23735478abafe5328f79dfe4378
    bf46dfdb45b1d6cd99a5c729ee98df89db363225
    b8da61acb2bb887a7335a5db82b8b5ae1e0fab69
    a062799bd6902061895e19cace0099fadf696bb4
    95e6a0885e65cc57b11719cc0658be9d8b78fba9
    138e5a051805ca8a3b7e9626742cc475e3577cc4
    826cb27cc80ae843927d68e0337ad2caffa9f023
    bee8ed6772f420f9eefc57fee01da29ff466a8e9
    3998d1abb291309ddbbc2c9869736ebb1ea608f0
    a09f11715be53587ee2b0368e19f45cc85fb6cf1
    ef1d096ddc311a2fd821d4076421c4a8f8d63abf
    55dda63b297a287c9abc6ba2f19946817e8744e7
    5bdd1e9ee8f3ca9dc647998a8ec7b9415add01fe
    0db079cd5a09b3f24b0dd3563f100c77561ccfde
    eea3634b2bd85e7f290e0504da1b8906c7d33ca4
    49db90342f193f31500b2717cc27bdf2f25e2d95
    bcaa4cd4f3be07f9211b51da4d258b61423f1e28
    9e7f056bd08b18d084497b0846c7c8f31b82f58a
    f49b4581a0a5056a51712bcabcc66483a87a07c8
    0d05957cf0c38abab45030ba172025e4ef318f43
    
    commit 2b1aa949539d2fcbb3d349be3c279996630d83fc
    Author:     Noel Power <noel.power@suse.com>
    AuthorDate: Tue Feb 19 17:29:32 2013 +0000
    Commit:     Noel Power <noel.power@suse.com>
    CommitDate: Tue Feb 19 18:09:24 2013 +0000
    
        fdo#56276 - resize/reposition rotated shapes in a sensible way
    
        Change-Id: Ifa4f848da21838591daa1f57fb42dfd3f4fa8044
Comment 12 QA Administrators 2017-11-22 15:40:56 UTC Comment hidden (obsolete)
Comment 13 Regina Henschel 2019-11-18 15:15:54 UTC
The problem still exists in Version: 6.5.0.0.alpha0+ (x64)
Build ID: 3a8d16ba8ca7ef7349e893f2bf1c7e12d9a8d7ae
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: de-DE (en_US); UI-Language: en-US
Calc: CL
Comment 14 Xisco Faulí 2020-01-21 09:14:20 UTC
This issue has been fixed by commit https://cgit.freedesktop.org/libreoffice/core/commit/?id=f44140bebb9c493d97ba5aef26c9692c53a6b93f
Closing as a duplicate of bug 119191

*** This bug has been marked as a duplicate of bug 119191 ***