Download it now!
Bug 94738 - UI: Mismatching "Styles and Formatting" icon at toolbar and sidebar (Galaxy theme)
Summary: UI: Mismatching "Styles and Formatting" icon at toolbar and sidebar (Galaxy t...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.1.2 release
Hardware: Other All
: medium normal
Assignee: Yousuf Philips (jay) (retired)
URL:
Whiteboard: target:5.2.0 target:5.1.2 target:5.0.6
Keywords: regression
Depends on:
Blocks: Icon-Theme-Galaxy
  Show dependency treegraph
 
Reported: 2015-10-03 21:40 UTC by Vitaliy Lotorev
Modified: 2017-07-31 23:43 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Mismatching "Styles and Formatting" icon at toolbar and sidebar (76.99 KB, image/png)
2015-10-03 21:40 UTC, Vitaliy Lotorev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vitaliy Lotorev 2015-10-03 21:40:39 UTC
Created attachment 119251 [details]
Mismatching "Styles and Formatting" icon at toolbar and sidebar

Different icons are used for the same "Styles and Formatting" at toolbar and sidebar.

See attached PNG file.
Comment 1 tommy27 2015-10-04 07:44:55 UTC
I confirm bug in LibO 5.0.2.1 and recent LibO 5.1.0.0 alpha builds

the issue affects just the Galaxy theme
other themes have matching icons.

in LibO 4.4.5.1 the Galaxy theme icons were the same in toolbar and sidebar.


I add Jay to CC list. Is this something you and the design team can easy hack?
Comment 2 Yousuf Philips (jay) (retired) 2015-10-04 11:59:04 UTC
The current sidebar icon goes better with the other icons in the sidebar than the one from the toolbar, but if others prefer to use the icon from the toolbar in the sidebar, that can easily be fixed.

Not sure what happened in 4.3 and 4.4, as 4.1 and 4.2 had the current sidebar icon for galaxy.
Comment 3 tommy27 2015-10-04 12:14:05 UTC
just let the UX team decide which one of the 2 icons has to be used in galaxy

what about bibisecting to understand what caused the mismatch?
Comment 4 Vitaliy Lotorev 2015-10-04 19:36:30 UTC
There are also following mismatches:
1) Icon for menu "Edit->Track Changes->Manage Changes" is also different from "Manage changes" at sidebar.

2) Icon for "navigator" at toolbar is different from that at sidebar.

3) Icon for "Clip Art Gallery" at toolbar is different from that at sidebar.

Actually it appears that most icons at sidebar are different from those at menu/toolbar.
Comment 5 Yousuf Philips (jay) (retired) 2015-10-11 10:14:00 UTC
(In reply to tommy27 from comment #3)
> what about bibisecting to understand what caused the mismatch?

No need to bibisect as the icon system was changed in 5.0 and wouldnt be reverted.

(In reply to Vitaliy Lotorev from comment #4)
> There are also following mismatches:
> 1) Icon for menu "Edit->Track Changes->Manage Changes" is also different
> from "Manage changes" at sidebar.

Yes the icon in the sidebar is from tango and is used in Galaxy.

> 2) Icon for "navigator" at toolbar is different from that at sidebar.
> 
> 3) Icon for "Clip Art Gallery" at toolbar is different from that at sidebar.

Those two icons are using the same look as the properties and styles and formatting icons.

> Actually it appears that most icons at sidebar are different from those at
> menu/toolbar.

All these sidebar icons are taken from IBM Symphony's sidebar ( http://zoomexe.net/uploads/posts/2014-04/1396424626_ibm_lotus_symphony.png ) which didnt use the galaxy theme.
Comment 6 Vitaliy Lotorev 2016-02-11 21:49:12 UTC
As of 5.1.0.3 the icons for Styles, Navigator and Gallery at sidebar and toolbar are still different.
Comment 7 Yousuf Philips (jay) (retired) 2016-02-22 19:00:28 UTC
As none of the Styles, Navigator and Gallery icons are currently used in the toolbar, there isnt a need to modify them in the sidebar. Also we dont have a suitable Galaxy properties icon, which would make it in a different design style, so i'd say this is WFM.

@Regina: Any thoughts?
Comment 8 Regina Henschel 2016-02-22 21:48:56 UTC
The icons appear in the menu and in the Customize dialog and users can still use them in toolbars.

The icons in toolbar/menu/Customize dialog and in the sidebar are actually the same for icon-themes Breeze, Tango, and Sifr. Therefore I would make them identical in Galaxy too.
Comment 9 Regina Henschel 2016-02-22 22:00:31 UTC
But there is a problem with the icon for "Design". It should be different from "Styles and Formatting" because the panels have different content. But it is the same in Sifr and Tango. In Breeze it is worse, the icon in the toolbar opens the "Style and Formatting" panel, but the same icon in the sidebar opens the "Design" panel and the "Style and Formatting" in the sidebar has a slightly different icon.

I would say, there is some inconsistency and improvement is possible.
Comment 10 Yousuf Philips (jay) (retired) 2016-02-22 23:15:25 UTC
(In reply to Regina Henschel from comment #8)
> The icons in toolbar/menu/Customize dialog and in the sidebar are actually
> the same for icon-themes Breeze, Tango, and Sifr. Therefore I would make
> them identical in Galaxy too.

Done, though not having a full set of icons for all the sidebar icons make them feel non-uniform.

(In reply to Regina Henschel from comment #9)
> But there is a problem with the icon for "Design".

Yes its a known thing while Tomaz is working on the experimental sidebar (bug 91511), but a new icon would be needed to be designed for Galaxy to take its place.
Comment 11 Yousuf Philips (jay) (retired) 2016-02-22 23:16:04 UTC
Patch is in. - https://gerrit.libreoffice.org/22627
Comment 12 Commit Notification 2016-02-27 21:30:41 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ecc95bfab89cafa44309aea7bdb9ad05d7def55d

tdf#94738 Replace symphony icons with galaxy in the sidebar

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2016-02-29 09:44:06 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f227de3bed73e4f9b81d93d339188f333a92bf05&h=libreoffice-5-1

tdf#94738 Replace symphony icons with galaxy in the sidebar

It will be available in 5.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Vitaliy Lotorev 2016-02-29 19:14:04 UTC
@Yousuf Philips,
Is it possible to backport it to next 5.0.x branch. Originally the issue was reported against 5.0.2 (or 5.0.1) release. Probably it is still there.
Comment 15 Yousuf Philips (jay) (retired) 2016-03-01 07:38:33 UTC
@Vitaliy: Backport has been done and awaits approval.
Comment 16 Commit Notification 2016-03-01 11:39:15 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=61213fc0487d0d9e0f637f2e3101612ef11e412a&h=libreoffice-5-0

tdf#94738 Replace symphony icons with galaxy in the sidebar

It will be available in 5.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Vitaliy Lotorev 2016-03-06 22:14:56 UTC
@Yousuf Philips,
Thanks a lot for fixing this.
Comment 18 Yousuf Philips (jay) (retired) 2016-03-06 22:47:03 UTC
@Vitaliy: Glad to help. :D