Bug 94754 - Have submenu for split buttons when in toolbar chevron submenu
Summary: Have submenu for split buttons when in toolbar chevron submenu
Status: RESOLVED DUPLICATE of bug 42029
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval, topicUI
Depends on:
Blocks:
 
Reported: 2015-10-04 13:51 UTC by Yousuf Philips (jay) (retired)
Modified: 2015-12-16 05:30 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
screenshot (53.35 KB, image/png)
2015-10-04 13:51 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-10-04 13:51:14 UTC
Created attachment 119264 [details]
screenshot

When a toolbar's contents are larger than the available screen space, the toolbar shows a chevron (ยป) button which is clickable to show a context menu for the hidden buttons. This works well with simple buttons, but doesnt work well with split buttons which have additional buttons that are accessible through them. So it would be beneficial to convert a split button into a submenu, so that the additional buttons are still accessible.

Heiko had suggested this in bug 90090 comment 37 and i think it is a good solution for split buttons that open up toolbar with buttons.

The screenshot shows how the 'basic shapes' split button looks in and outside of the chevron submenu.
Comment 1 Adolfo Jayme 2015-10-05 14:46:59 UTC

*** This bug has been marked as a duplicate of bug 42029 ***
Comment 2 Robinson Tryon (qubit) 2015-12-16 05:30:51 UTC
Migrating Whiteboard tags to Keywords: (needsDevEval, topicUI)
[NinjaEdit]