Download it now!
Bug 94762 - "Design" button is gone after viewing "Print Preview" (sidebar)
Summary: "Design" button is gone after viewing "Print Preview" (sidebar)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2015-10-04 19:44 UTC by Vitaliy Lotorev
Modified: 2020-09-29 13:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
design button in the sidebar (7.13 KB, image/png)
2015-10-08 10:18 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vitaliy Lotorev 2015-10-04 19:44:00 UTC
* Open new Writer document.
* Open sidebar, make sure there is a "Design" button at sidebar.
* Click "Print Preview" button at toolbar - watch previewing empty document, close preview.
* Look at sidebar, there is no "Design" button anymore.
Comment 1 Buovjaga 2015-10-08 07:22:14 UTC
(In reply to Vitaliy Lotorev from comment #0)
> * Open sidebar, make sure there is a "Design" button at sidebar.

How can I do this? Where should the Design button be?
Comment 2 raal 2015-10-08 10:17:11 UTC
I can confirm with LO 5.0.2.2, win 7.

@Reporter - would be nice to find out if this is a regression or not by testing older versions: http://downloadarchive.documentfoundation.org/libreoffice/old/
Thanks
Comment 3 raal 2015-10-08 10:18:55 UTC
Created attachment 119410 [details]
design button in the sidebar
Comment 4 Buovjaga 2015-10-08 10:47:49 UTC
(In reply to raal from comment #3)
> Created attachment 119410 [details]
> design button in the sidebar

Duplicate of Styles? I have no such thing in any version.
Comment 5 Maxim Monastirsky 2015-10-08 10:54:04 UTC
(In reply to Beluga from comment #4)
> I have no such thing in any version.
You should turn on experimental features.
Comment 6 Buovjaga 2015-10-08 10:56:46 UTC
(In reply to Maxim Monastirsky from comment #5)
> (In reply to Beluga from comment #4)
> > I have no such thing in any version.
> You should turn on experimental features.

Thanks, I could repro.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)
Comment 7 Vitaliy Lotorev 2015-11-06 20:39:05 UTC
(In reply to raal from comment #2)
> I can confirm with LO 5.0.2.2, win 7.
> 
> @Reporter - would be nice to find out if this is a regression or not by
> testing older versions:
> http://downloadarchive.documentfoundation.org/libreoffice/old/
> Thanks

Could you please specify when "design" was introduced: 4.3, 4.4, 5.0?

I have limited bandwidth, so bibisecting will take some time.
Comment 8 QA Administrators 2016-11-08 12:07:26 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2019-12-03 14:48:42 UTC Comment hidden (obsolete)
Comment 10 Sascha Z 2020-09-29 07:07:41 UTC
Can't reproduce in Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU threads: 8; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Comment 11 Buovjaga 2020-09-29 13:53:50 UTC
Yep, no problem

Version: 7.1.0.0.alpha0+ (x64)
Build ID: dba1a27be2438b5dbd1f8d253acb3850c9c044da
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: default; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded