Bug 94815 - Selecting enable macros freezes application with syntax error
Summary: Selecting enable macros freezes application with syntax error
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Macro-VBA
  Show dependency treegraph
 
Reported: 2015-10-06 09:12 UTC by bignas_
Modified: 2020-06-03 13:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Spreadsheet analysis tool. (2.63 MB, application/vnd.ms-excel)
2015-10-06 09:14 UTC, bignas_
Details
bt with debug symbols (22.19 KB, text/plain)
2015-10-06 22:03 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bignas_ 2015-10-06 09:12:14 UTC
User-Agent:       Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build Identifier: LibreOffice 5.0.2.2

Once the spreadsheet is open its asks if you need to enable or disable macros.I select enable as that is what is required, and I get the error "BASIC syntax error.Syntax error." Then another window opens automatically stating in the bar "You are editing  a VBA macro. Changes can only be saved only in OenDocument Format." I am unable to close this window as a dialogue box informs me "The window cannot be closed while BASIC is running." It can only be closed by the use of XKILL in a terminal.This spreadsheet without any issues in MS Office.I have experienced the same problem during the past few version upgrades.

Reproducible: Always




[Information automatically included from LibreOffice]
Locale: en-GB
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
The spreadsheet is from the UK s Health and Safety Executive - Management Standards analysis tool


Reset User Profile?No
Comment 1 bignas_ 2015-10-06 09:14:19 UTC
Created attachment 119334 [details]
Spreadsheet analysis tool.
Comment 2 Julien Nabet 2015-10-06 22:03:50 UTC
Created attachment 119374 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I had a crash (I suppose it's related since I enable with enable-dbgutil)
Comment 3 Buovjaga 2015-10-08 16:56:11 UTC
Didn't crash and no closing problem, but got several syntax errors.
In the basic editor, MAX_PATH was highlighted in this:
Dim Result As Boolean, Path As String * MAX_PATH

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)

Version: 5.1.0.0.alpha1+
Build ID: f830600ece806ec365a4839e79afabe183c5e36d
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-06_22:49:09
Locale: en-US (fi_FI)
Comment 4 QA Administrators 2016-11-08 11:33:43 UTC Comment hidden (obsolete)
Comment 5 Julien Nabet 2017-05-14 07:31:13 UTC
With master sources updated yesterday, I don't reproduce the crash but had several syntax errors.
Let's put this one to WFM.
bignas: don't hesitate to reopen this tracker if you still reproduce the problem with a recent LO version (5.3.3 is last stable version)
Comment 6 Julien Nabet 2017-05-14 07:34:48 UTC
Argh, I hadn't tested until the end.
I can't close this file since it always says macro running and can't stop it.
I noticed on console this log repeated:
warn:legacy.osl:8692:1:basctl/source/basicide/doceventnotifier.cxx:127: DocumentEventNotifier::Impl::notifyEvent: illegal source document!
Comment 7 QA Administrators 2018-07-19 02:42:57 UTC Comment hidden (obsolete)
Comment 8 Julien Nabet 2020-01-26 18:35:20 UTC
On pc Debian x86-64 with LO Debian package 6.3.4, I don't reproduce this.
I got all the error messages + I could close the script editor + file.

bignas: don't hesitate to reopen this tracker if you still reproduce the problem with a recent LO version (6.3.4 is last stable version)
Comment 9 ovile9080 2020-06-03 12:49:41 UTC Comment hidden (spam)