Bug Hunting Session
Bug 94818 - FILEOPEN Table layout jumbled for .doc
Summary: FILEOPEN Table layout jumbled for .doc
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:5.0.4
Keywords: bibisected, bisected, regression
: 92856 94463 94525 95404 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-10-06 09:51 UTC by j.cottier
Modified: 2018-08-30 13:42 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
original .doc and pdf version to refer to (419.17 KB, application/zip)
2015-10-06 09:51 UTC, j.cottier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description j.cottier 2015-10-06 09:51:03 UTC
Created attachment 119341 [details]
original .doc and pdf version to refer to

The whole page layout is messed up. Please refer to the pdf to see how it should look.
Comment 1 Buovjaga 2015-10-08 12:21:19 UTC
Confirmed.

In 4.3.0.1 it looks much better, almost perfect.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)

Version: 5.1.0.0.alpha1+
Build ID: f830600ece806ec365a4839e79afabe183c5e36d
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-06_22:49:09
Locale: en-US (fi_FI)
Comment 2 raal 2015-10-09 05:38:46 UTC
This seems to have begun at the below commit.
Adding Cc: to caolanm@redhat.com; Could you possibly take a look at this
one? Thanks

bibisect-win32-5.0:
514498c10e1419dcd5ab496d19fdc9d4211ba657 is the first bad commit
commit 514498c10e1419dcd5ab496d19fdc9d4211ba657
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sun May 31 02:24:01 2015 -0500

    source sha:b7fff04ad728369a09a5e1a5cfbe494cf388317b

    source sha:b7fff04ad728369a09a5e1a5cfbe494cf388317b

:040000 040000 0277f2f7fabdb1fb3046702bd94c5a24e5da1276 0bd6eae4bf4c3e3b90c8545e07d6ac5640c55287 M      instdir

author	Caolán McNamara <caolanm@redhat.com>	2015-04-07 13:57:39 (GMT)
committer	Caolán McNamara <caolanm@redhat.com>	2015-04-07 20:09:05 (GMT)
commit	b7fff04ad728369a09a5e1a5cfbe494cf388317b (patch)
Resolves: tdf#90504 0x7 chars in .doc are not always cell/row ends
Comment 3 Caolán McNamara 2015-10-12 19:57:49 UTC
the trick is to get this to work while keeping bug 90504 working too in order to avoid the crash on load attachment 2 of bug 65094
Comment 4 Commit Notification 2015-10-12 20:41:36 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=959ac511dbebeb3983da92052ced837b39b74ed9

fix tdf#94818 while retaining the tdf#90504 fix

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2015-10-14 09:27:00 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=00316aa39b558869544bdb08d2f5d9d63eb6718e&h=libreoffice-5-0

fix tdf#94818 while retaining the tdf#90504 fix

It will be available in 5.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Timur 2015-10-21 11:29:49 UTC
*** Bug 92856 has been marked as a duplicate of this bug. ***
Comment 7 Jacques Guilleron 2015-10-29 10:08:19 UTC
*** Bug 95404 has been marked as a duplicate of this bug. ***
Comment 8 Andras Timar 2015-11-08 21:09:08 UTC
*** Bug 94463 has been marked as a duplicate of this bug. ***
Comment 9 Commit Notification 2015-11-09 14:12:29 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dad32b63f852716af94cf995696b62b6e60724bd

Revert "fix tdf#94818 while retaining the tdf#90504 fix"

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2015-11-09 14:36:15 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a8c1ed47fb9dc2e878ad5f2cf26b967cf8e09d34

Revert "Revert "fix tdf#94818 while retaining the tdf#90504 fix""

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Caolán McNamara 2015-11-11 12:37:16 UTC
*** Bug 94525 has been marked as a duplicate of this bug. ***
Comment 12 Robinson Tryon (qubit) 2015-12-17 10:34:00 UTC Comment hidden (obsolete)