Download it now!
Bug 94832 - Show Changes OFF switches back ON after Save document
Summary: Show Changes OFF switches back ON after Save document
Status: RESOLVED DUPLICATE of bug 97103
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-06 18:01 UTC by mike.linux
Modified: 2017-04-25 05:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mike.linux 2015-10-06 18:01:33 UTC
When editing an existing document with Record Changes ON and Show Changes OFF, when I save the document the Show Changes automatically switches back ON by itself. 
I would like Show Changes to remain OFF after saving the document.

This is confirmed for LibreOffice 5.0.2.2 on both Windows 7 and Ubuntu 15.04.
Thank you.
Comment 1 Cor Nouws 2015-10-06 19:06:49 UTC
Hi Mike,

I would like that behavior, but for me in 5.0.2.2 on 32 Bits Ubuntu, it doesn't work that way ..
So I can't confirm.
Comment 2 Buovjaga 2015-10-08 16:34:54 UTC

*** This bug has been marked as a duplicate of bug 94479 ***
Comment 3 Timur 2015-10-08 17:21:00 UTC
It's not clear in which format you save. If it's docx, than it's a duplicate of Bug 89991.
If it's odt, do you mean you get Show Changes ON immediately, without closing and reopening the file?
It's also not clear in bug 94479.
Comment 4 Timur 2015-10-08 17:21:52 UTC
If it's odt, please attach the file.
Comment 5 mike.linux 2015-10-09 10:23:16 UTC
Yes, It is for DOXC format only. This features works correctly for ODT format.
OK for duplicate of Bug 89991 (I did not see this.) Thanks for your help.
Comment 6 Timur 2015-10-12 06:40:42 UTC

*** This bug has been marked as a duplicate of bug 89991 ***
Comment 7 Timur 2016-11-23 16:58:41 UTC
I can reproduce this issue in 5.1.6 but not in 5.2.0 beta, so I'll mark this as WFM, because we don't know the exact commit.
Comment 8 Justin L 2017-04-25 05:58:34 UTC
This bug was fixed in 5.3 master (documented in bug 97103), and backported to 5.2.0.

Thanks to author Michael Stahl 2016-06-08 10:31:06 (GMT)
commit: a59c4e26abbdd0720d24d3ddc0d6a05a67a31aaf
tdf#97103 sw: fix restoring of SetRedlineMode on DOCX/RTF export

*** This bug has been marked as a duplicate of bug 97103 ***