Bug 94899 - Inconsistent menu items "Clear Direct Formatting" and "Default Formatting"
Summary: Inconsistent menu items "Clear Direct Formatting" and "Default Formatting"
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-08 21:19 UTC by Stanislav Horacek
Modified: 2018-05-02 12:16 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stanislav Horacek 2015-10-08 21:19:35 UTC
In Writer, there is a menu item Format -> Clear Direct Formatting. However, Impress has Format -> Default Formatting. It seems the Impress item was forgotten when the rename [1] was performed.

Checked in current 5.1 master, supposing that this has been present since the rename in 2011.

[1] http://cgit.freedesktop.org/libreoffice/core/log/?qt=grep&q=clear+direct+formatting
Comment 1 Cor Nouws 2015-10-08 21:33:08 UTC
Thanks Stanislav. Set to New.

Cor
Comment 2 QA Administrators 2016-11-08 11:12:31 UTC Comment hidden (obsolete)
Comment 3 Stanislav Horacek 2016-11-20 21:17:44 UTC
Still the same items in 5.3.0.0.alpha1+.
Comment 4 QA Administrators 2017-11-21 15:45:30 UTC Comment hidden (obsolete)
Comment 5 Stanislav Horacek 2017-11-21 18:39:19 UTC
Still present in: Version: 6.0.0.0.alpha0+
Build ID: 141fe1c5e7fbf67a083b34e49e19b6ea78a0eb2b
Comment 6 Stanislav Horacek 2018-05-01 19:21:00 UTC
It seems that this issue has been fixed by this commit:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=c42ed19c1dcde6e2c6210e6f8cc90ba8ba654de1

Once verified, this can be marked as resolved.
Comment 7 Cor Nouws 2018-05-02 12:16:44 UTC
fixed indeed in Version: 6.1.0.0.alpha1+
Build ID: 8a2745e1beee722c8c9691c397e493cc1160bedf
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-04-30_23:34:23
Locale: nl-NL (nl_NL.UTF-8); Calc: group

thanks Andreas!