Bug 94913 - Microsoft Word Citations
Summary: Microsoft Word Citations
Status: RESOLVED DUPLICATE of bug 107784
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2015-10-09 14:56 UTC by Vladimir
Modified: 2019-09-23 16:37 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file with citations (15.95 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-10-09 14:56 UTC, Vladimir
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir 2015-10-09 14:56:54 UTC
Created attachment 119458 [details]
Example file with citations

Аfter opening the file appears strange sentence [ CITATION Pak12 \l 1033 ] instead of the quote (Pakkalaa, Presserb, & Christensenc, 2012)


1. Run LibreOffice Version: 5.0.2.2
2. Click Open File
3. Select File "Example.docx" (attached)
4. Click "Open"


AR: [ CITATION Pak12 \l 1033 ]; [ CITATION Pla11 \l 1033 ]; [ CITATION Kau10 \l 1033 ]; [CITATION Cli10 \l 1033 ]; [ CITATION Has09 \l 1033 ]; [CITATION Ken11 \p 537 \l 1033 ]
ER: (Pakkalaa, Presserb, & Christensenc, 2012); (Plaza, 2011); (Kaushik, 2010); (Clifton, 2010); (Hasan, Morris, & Probets, 2009); (Kent, Carr, Husted, & Pop, 2011, p. 537)
Comment 1 Buovjaga 2015-10-09 17:44:01 UTC
Confirmed.

4.3.0.1 is fine, so regression.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)

Version: 5.1.0.0.alpha1+
Build ID: f830600ece806ec365a4839e79afabe183c5e36d
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-06_22:49:09
Locale: en-US (fi_FI)
Comment 2 raal 2015-10-14 12:21:54 UTC
bibisect-win32-5.0, oldest version contains bug too.
git checkout oldest: Version: 4.5.0.0.alpha0+
Build ID: 57d6b92b69a31260dea0d84fcd1fc5866ada7adb
Comment 3 raal 2015-10-20 16:10:46 UTC
This seems to have begun at the below commit.
Adding Cc: to sourav.mahajan@synerzip.com ; Could you possibly take a look at this one?
Thanks

abe9c988651a75faed7dcec9ba76e1a77593809e is the first bad commit
commit abe9c988651a75faed7dcec9ba76e1a77593809e
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Sat Mar 14 22:56:24 2015 +0800

    source-hash-f021524aadfe1aa1a07f4600bcb89e7c69ccfdb0
    
    commit f021524aadfe1aa1a07f4600bcb89e7c69ccfdb0
    Author:     Sourav <sourav.mahajan@synerzip.com>
    AuthorDate: Wed Jun 25 12:32:59 2014 +0530
    Commit:     Miklos Vajna <vmiklos@collabora.co.uk>
    CommitDate: Fri Jul 11 10:12:42 2014 +0200
    
        fdo#76279 Invalid Citation on RoundTrip
    
        Reviewed on:
        	https://gerrit.libreoffice.org/9898
    
        Change-Id: Idfe39761180ae1eeb0066ae3aac13de6ac6df0b9
Comment 4 Robinson Tryon (qubit) 2015-12-13 11:14:30 UTC Comment hidden (obsolete)
Comment 5 Andrey L 2016-02-08 09:53:31 UTC
Any updates? Is it possible to accelerate bugfix for fee?
Comment 6 Buovjaga 2016-02-08 09:58:38 UTC
(In reply to Andrey L from comment #5)
> Any updates? Is it possible to accelerate bugfix for fee?

Yes. Contact some of these guys: https://www.documentfoundation.org/certification/developers/
Comment 7 Xisco Faulí 2017-09-29 08:53:21 UTC Comment hidden (obsolete)
Comment 8 Xisco Faulí 2019-09-23 16:37:57 UTC
This is another regression from https://cgit.freedesktop.org/libreoffice/core/commit/?id=06f7d1a96eef5aa69d4872ff6d96eb5085296d09, it was already wrong before f021524aadfe1aa1a07f4600bcb89e7c69ccfdb0

*** This bug has been marked as a duplicate of bug 107784 ***