Download it now!
Bug 94927 - "Autofit Text" function on text frames is on by default (bad for compatibility; cannot be set via Master page or as option)
Summary: "Autofit Text" function on text frames is on by default (bad for compatibilit...
Status: RESOLVED DUPLICATE of bug 90407
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval
: 87857 96409 (view as bug list)
Depends on:
Blocks: Textbox Master-Slide
  Show dependency treegraph
 
Reported: 2015-10-10 08:45 UTC by Ljiljan
Modified: 2019-01-25 15:41 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ljiljan 2015-10-10 08:45:55 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.101 Safari/537.36
Build Identifier: LibreOffice 5.0.2.2

Text autofit is great if you want to rely on LibreOffice only. But face it - most of the people still use Microsoft Office (even though more people are starting to use LibreOffice as well). When LibreOffice introduce text autofit, it is great if you are just using the LibreOffice. But the moment you decide to share your presentation in more popular PPT or PPTX, autofit option is not working. Therefore, this default option is causing to lose compactability with PPT and PPTX. My suggestion is to disable autofit as default option.  

Reproducible: Always

Steps to Reproduce:
Suggesstion/ improvement, so no steps to reproduce
Actual Results:  
Lost of PPT or PPTX compacatiblity

Expected Results:  
Compactability will be maintain

[Information automatically included from LibreOffice]
Locale: en-US
Module: PresentationDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


Reset User Profile?No
Comment 1 Cor Nouws 2015-10-10 16:29:02 UTC
Thanks for the idea, Ljiljan. Set as Enhancement.
Maybe as Configuration option or allow setting (that it works, it doesn't now) via master pages ?

@thorsten: easy hack, maybe?
Comment 2 Ljiljan 2015-10-11 07:39:21 UTC
I agree with your suggestions, Cor. This should be enabled (or disabled) via Master Page. And maybe somewhere in Options? (LibreOffice Impress -> General)
Comment 3 Robinson Tryon (qubit) 2015-12-10 07:26:43 UTC Comment hidden (obsolete)
Comment 4 2460acc 2015-12-11 13:33:41 UTC
Hi - I think I just duped this issue - added link above.

I definitely agree, it needs to be able to be globally disabled rather than globally on and unchangeable as the default. It breaks compatibility in exchange for a small convenience (resizing text automagitally) for a small userbase (office users who never need to share with non-LO users).
Comment 5 Cor Nouws 2015-12-11 13:58:32 UTC
*** Bug 96409 has been marked as a duplicate of this bug. ***
Comment 6 Cor Nouws 2015-12-11 13:59:14 UTC Comment hidden (obsolete)
Comment 7 Buovjaga 2017-02-17 10:58:18 UTC
*** Bug 87857 has been marked as a duplicate of this bug. ***
Comment 8 Tor Lillqvist 2017-02-17 11:07:11 UTC
Surely having Text AutoFit on by default is what people expect to happen. That the export to .pptx (and even .ppt?) doesn't handle it is another bug. I'd vote to resolve this as WONTFIX? (No, we don't actually have any voting, that was just a figure of speech.)
Comment 9 Ljiljan 2017-02-17 11:13:17 UTC
Regarding this that users are expecting autofit: 

When creating presentation, being consistent in both font type, size and general style is the most important think. Presentation that contains different fonts and text with different size is not good approach to impress someone while presenting. Therefore, users shouldn't expect autofit as default option but limit the number of lines of text on each slide.
Comment 10 Tor Lillqvist 2017-02-17 11:17:08 UTC
PowerPoint has it on by default, as far as I see. And no, I am not interested in any discussion whether following their lead is good or evil.
Comment 11 Ljiljan 2017-02-17 11:23:31 UTC
At the moment (Libre Office 5.3) changing Autofit in Master Slide is not saved as default option. Is this bug? Should we remove Autofit from Master Slide at least not to confuse users?
Comment 12 Cor Nouws 2017-02-17 17:06:24 UTC
(In reply to Ljiljan from comment #9)
> ... Therefore, users shouldn't expect autofit as
> default option but limit the number of lines of text on each slide.

Would be my subjective idea too, but...
@heiko: something for a poll, maybe?
Comment 13 Cor Nouws 2017-02-17 17:07:10 UTC
(In reply to Tor Lillqvist from comment #10)
> ...  And no, I am not
> interested in any discussion whether following their lead is good or evil.

(  So boring, working with you ;)  )
Comment 14 2460acc 2017-02-18 17:34:59 UTC
The main problem seems  to be the incompatiblity of auto-fit with other Office suites. The Microsoft one in particular displays at full size and spills outside the page that you spent hours making in LO.

Very unexpected and a bit of a disaster when you are presenting something.
Comment 15 Tor Lillqvist 2017-02-18 17:55:02 UTC
Which is exactly the bug that was fixed yesterday (bug #90407). the autofit thing was not exported to pptx.
Comment 16 Heiko Tietze 2017-02-26 11:24:14 UTC
(In reply to Cor Nouws from comment #12)
> @heiko: something for a poll, maybe?

The issue doesn't qualifies for a simple poll with either have a global option or not, or make the default on or off. Needs a lot of introduction as most users may not know the differences between LibO and PP.

But I like the idea with a global option with autofit on by default. Ideally it gets a tooltip that makes clear what this property is good for. On the other hand, if the export to PP works with the fix in bug 90407 and makes the result like PP handles things a WONTFIX is also acceptable.
Comment 17 Cor Nouws 2017-02-26 20:25:57 UTC
Thanks Heiko.
Indeed since bug 90407 is done, the real urgency of this issue is gone.

@Ljiljan, others: what if we create two enhancements?
 - global option in Tools > Options > Impress .. General
 - possibility to set the function in the master pages 

Maybe it's cleaner to create two new issues for that?

Ciao - Cor
Comment 18 Tor Lillqvist 2017-02-27 20:34:35 UTC
Cor: bug #90407 is "done" only for .pptx. presumably it is still there for .ppt
Comment 19 Buovjaga 2018-06-12 10:30:25 UTC
*** Bug 116898 has been marked as a duplicate of this bug. ***
Comment 20 Buovjaga 2018-06-12 10:54:50 UTC
To make it clear, does this report also concern "regular" (non-layout or master pages controlled) text boxes?
Comment 21 Timur 2019-01-25 15:41:35 UTC
I don't see why this is not a duplicate of Bug 90407.
As requested is wrong and wrongfully confirmed, as explained in Comment 8.

*** This bug has been marked as a duplicate of bug 90407 ***