Bug 94994 - FORMATTING When typing a numbered list, convert it to a list automatically
Summary: FORMATTING When typing a numbered list, convert it to a list automatically
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: All All
: medium normal
Assignee: Samuel Mehrbrodt (allotropia)
URL:
Whiteboard: target:5.1.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-10-12 20:28 UTC by jddcef
Modified: 2016-10-25 19:20 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jddcef 2015-10-12 20:28:49 UTC
Open a new document.

Type "1. example"

I expect this to become an automatic list that is indented after typing the space after the dot.

This is how it is on Word for example.

It's a major productivity enhancer.
Comment 1 Cor Nouws 2015-10-12 21:12:27 UTC
Hi jddcef,

Thanks for writing here and using LibreOffice.
AutoCorrect is just working nice in LibreOffice.

If you have questions around that. please see the Help or ask our community support:
 http://www.libreoffice.org/get-help/community-support/

I set this as WorksForMe
Regards,
Cor
Comment 2 jddcef 2015-10-13 15:10:06 UTC
(In reply to Cor Nouws from comment #1)
> Hi jddcef,
> 
> Thanks for writing here and using LibreOffice.
> AutoCorrect is just working nice in LibreOffice.
> 
> If you have questions around that. please see the Help or ask our community
> support:
>  http://www.libreoffice.org/get-help/community-support/
> 
> I set this as WorksForMe
> Regards,
> Cor

Can you elaborate on your reproduction steps?
Comment 3 Cor Nouws 2015-10-13 15:20:18 UTC
(In reply to jddcef from comment #2)

> Can you elaborate on your reproduction steps?

The procedure should be the other way round ;P

Check of Tools > AutoCorrection > ... is turned on. (See Help etc usw)
Comment 4 Samuel Mehrbrodt (allotropia) 2015-10-14 12:48:26 UTC
It doesn't work here either. Seems to be a regression from 3.5 to 3.6.
Comment 5 Yousuf Philips (jay) (retired) 2015-10-14 13:14:07 UTC
Hi jddcef,

In Tools > AutoCorrect Options..., click on the Options tab and enable the 'Apply numbering - symbol:' checkbox.
Comment 6 Samuel Mehrbrodt (allotropia) 2015-10-14 13:48:49 UTC
Changed here: http://cgit.freedesktop.org/libreoffice/core/commit/?id=effe82efb67a3b444c3be5f978aef82b8e709165

No rationale, no related bug report back then. Will just revert.
Comment 7 Commit Notification 2015-10-14 14:00:21 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=beb8d01d32bafac3a96f9f28bf93b58985e524dd

tdf#94994 Enable auto-numbering by default

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Cor Nouws 2015-10-14 14:25:29 UTC
Ah, fun - explaining how to turn this off will be asked more often in trainings then the other way round. I expect that the commit was made with that in mind.
But I don't care that much. So fine for me... ;)
Comment 9 Commit Notification 2015-10-15 07:02:43 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3d94dab1bd7878305923b695425cc13283a52253

Revert "tdf#94994 Enable auto-numbering by default"

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Samuel Mehrbrodt (allotropia) 2015-10-15 09:16:27 UTC
So after discussing this in the Design meeting, we came to the conclusion that this shouldn't be enabled by default unless some issues are fixed. That means, this function should be less obtrusive.
This bug should stay closed as it can easily be enabled via the autocorrect options as Jay mentioned in comment 5.