Bug Hunting Session
Bug 94999 - Crash after trying to save a document
Summary: Crash after trying to save a document
Status: RESOLVED DUPLICATE of bug 94936
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-13 03:37 UTC by sunrisingsoul
Modified: 2015-10-16 07:34 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sunrisingsoul 2015-10-13 03:37:29 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build Identifier: LibreOffice 5.0.2.2

After opening a new writer document, libreoffice writer crashes.

This h happens either if the document is newly created and there is nothing in it. Once trying to save the document, the client crashes.

Furthermore, if openning a new document and place some text within the document, the client still crashes after initiating a save of the document from either the file menu or CTRL+S.

Uncommenting the GTK stable in /etc/profile.d/libreoffice-fresh.sh does not fix the issue.

Reproducible: Always

Steps to Reproduce:
1.Open a empty document
2.Either write text or leave as empty
3.Try to save document
Actual Results:  
Libreoffice crashes.

Opening libreoffice afterwards provides the recovery dialog. 

Should you hit Start Recovery, and then finish. Saving the document after recovered, whether text or no text is within the document, still causes a crash.

Expected Results:  
Client should not crash, and allow proper saving of the document.

[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


Reset User Profile?No
Comment 1 Joel Madero 2015-10-13 04:04:29 UTC
Try turning off openCL

Tools -> LibreOffice -> OpenCL -> Allow Use of OpenCL (uncheck it). Setting to NEEDINFO - let us know if that resolves it.
Comment 2 sunrisingsoul 2015-10-15 23:05:20 UTC
Hello there,

Doing the following fixed my issue.

I uncommented the GTK variable in
/etc/profile.d/libreoffice-fresh.sh

I also did what was recommended and went to Tools > Options 
Here, under Libreoffice, I selected OpenCL and unchecked OpenClk.

Reboot, and was able to save files properly.
Comment 3 Maxim Monastirsky 2015-10-16 07:34:39 UTC

*** This bug has been marked as a duplicate of bug 94936 ***