Download it now!
Bug 95026 - Continuous section break regression in doc-file
Summary: Continuous section break regression in doc-file
Status: RESOLVED DUPLICATE of bug 87764
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.3.1.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: bibisected, bisected, filter:doc, regression
Depends on:
Blocks:
 
Reported: 2015-10-13 23:33 UTC by Matthew Holloway
Modified: 2016-09-26 16:41 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file of continuous section break (37.50 KB, application/msword)
2015-10-13 23:33 UTC, Matthew Holloway
Details
How Microsoft Office 2013 renders a continous section break (9.82 KB, image/png)
2015-10-13 23:34 UTC, Matthew Holloway
Details
How LibreOffice currently renders a continuous section break (9.09 KB, image/png)
2015-10-13 23:35 UTC, Matthew Holloway
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Holloway 2015-10-13 23:33:56 UTC
Created attachment 119567 [details]
Example file of continuous section break

LibreOffice 4.3.0.4 renders continuous section breaks like Microsoft Office 2013 but the subsequent version 4.3.1.1 doesn't. This bug still exists in 5.0.3.1.

The Microsoft Office behaviour is to keep the content on a single page, so if you see two pages in LibreOffice then you have reproduced the bug. I'll attach screenshots showing this.


Bug #86468 might be related.
Comment 1 Matthew Holloway 2015-10-13 23:34:41 UTC
Created attachment 119568 [details]
How Microsoft Office 2013 renders a continous section break
Comment 2 Matthew Holloway 2015-10-13 23:35:24 UTC
Created attachment 119569 [details]
How LibreOffice currently renders a continuous section break
Comment 3 Cor Nouws 2015-10-14 08:56:25 UTC
Thanks - confirmed.
Comment 4 raal 2015-12-11 15:30:25 UTC
This seems to have begun at the below commit.
Adding Cc: to Luboš Luňák ; Could you possibly take a look at this one?
Thanks

2eb63500efafca6bacf547876546d1bdba451590 is the first bad commit
commit 2eb63500efafca6bacf547876546d1bdba451590
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Sat Mar 14 23:33:59 2015 +0800

    source-hash-c5ed52b1cd6f22787c94bec035ceecf9e1da3271
    
    commit c5ed52b1cd6f22787c94bec035ceecf9e1da3271
    Author:     Luboš Luňák <l.lunak@collabora.com>
    AuthorDate: Mon Jul 21 10:56:52 2014 +0200
    Commit:     Luboš Luňák <l.lunak@collabora.com>
    CommitDate: Mon Jul 21 11:02:04 2014 +0200
    
        ww8import create a pagedesc if continuous section changes margins (bnc#875383)
    
        This is similar to what writerfilter does. MSWord can have one page with several
        different margins, which are saved using continuous sections, which causes all
        kinds of trouble, because either we treat them as Writer sections, which means
        we lose some of the data, or we treat them as Writer page styles, which causes
        spurious page breaks if in the wrong place. Either option has its problems, but
        here it seems slightly better to go for keeping the data and hoping the page
        break will be in a place where a break will be anyway.
    
        Change-Id: I8f52aa820750da6788ea04180a15ac334f6bf87b
Comment 5 Xisco Faulí 2016-09-24 14:52:48 UTC

*** This bug has been marked as a duplicate of bug 87764 ***
Comment 6 Timur 2016-09-26 16:40:32 UTC
Same commit as my earlier Bug 86468, so maybe a duplicate of that one. 
Please see https://bugs.documentfoundation.org/show_bug.cgi?id=86468#c21.