Bug Hunting Session
Bug 95091 - Editable input fields in protected section: no delete or backspace possible
Summary: Editable input fields in protected section: no delete or backspace possible
Status: RESOLVED DUPLICATE of bug 64432
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:5.0.4
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-15 16:53 UTC by Oliver Specht (CIB)
Modified: 2016-10-25 19:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
input field in protected section (9.53 KB, application/vnd.oasis.opendocument.text)
2015-10-15 16:53 UTC, Oliver Specht (CIB)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Specht (CIB) 2015-10-15 16:53:30 UTC
Created attachment 119644 [details]
input field in protected section

- Load budoc
-> The writeable edit field can be modified by inserting characters or RETURN but DEL or BACKSPACE bring up the message box "Write-protected content cannot be changed"
Comment 1 Cor Nouws 2015-10-15 20:41:57 UTC
Hi Olivier,

Indeed, Known as bug 64432.
Ciao - Cor

*** This bug has been marked as a duplicate of bug 64432 ***
Comment 2 Commit Notification 2015-10-16 05:13:58 UTC
Oliver Specht committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ac427caf1069ff66b4893bb2e937c2408d7c37b3

tdf#95091: enable delete and backspace in editable elements within protections

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2015-10-20 11:07:04 UTC
Oliver Specht committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2b766197bdf195789ac126899e1b117bc759b72a&h=libreoffice-5-0

tdf#95091: enable delete and backspace in editable elements within protections

It will be available in 5.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.