Bug Hunting Session
Bug 95097 - Substitution and missing font management
Summary: Substitution and missing font management
Status: RESOLVED DUPLICATE of bug 94327
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-15 20:43 UTC by Shunesburg69
Modified: 2015-10-15 21:02 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shunesburg69 2015-10-15 20:43:33 UTC
Hi,
it will be good to made a system for alternative fonts,
I have often documents made by other with fonts not in my OS,
and I'm not alone, {{tdf|88438}}, {{tdf|94327}}, {{tdf|68880}}, {{tdf|56076}}...
I made a proposition in the "Crazy Ideas" (https://wiki.documentfoundation.org/Development/Crazy_Ideas#Missing_Font_Manager), can you fix the problem or made a system like I propose?
But the big problem are the alternative fonts, because there are not exactly the same proportion are form, I know it's impossible to made exactly the same but there is sometimes big differences for some letters are spacings.
Comment 1 Julien Nabet 2015-10-15 20:59:16 UTC
Enhancement then...

Also, if you want to reference some bugtrackers, do it like this:
"tdf#68880" (without the quotes of course) or use "See Also" field.
Comment 2 Tomaz Vajngerl 2015-10-15 21:02:35 UTC
What's the point in adding another bug when you already know there are other bugs with the same request. More bugs doesn't mean this will be implemented faster or at all.

Also "Crazy Ideas" wiki is for CRAZY IDEAS - stuff that will by definition most probably never be implemented. Do you really think this belongs there?

Also we already have a way to substitute fonts, what we don't have is a functionality that looks into what fonts are used in a document and warns the user (on document load) that some fonts are not available and if he wishes to substitute them (and with what fonts).

*** This bug has been marked as a duplicate of bug 94327 ***