Download it now!
Bug 95139 - Saving document overrides hiding "show changes"
Summary: Saving document overrides hiding "show changes"
Status: RESOLVED DUPLICATE of bug 97103
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-10-17 11:27 UTC by Andrew Wetmore
Modified: 2017-04-25 05:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Wetmore 2015-10-17 11:27:54 UTC
I am editing a document. I turn on "track changes" and I turn off "show changes" so I can make sure the spacing and other matters are appropriate.

Every time I save the document, Writer activates "show changes" again so I have to turn it off again. This is very annoying, and new behavior with version 5.
Comment 1 raal 2015-10-17 16:44:30 UTC
I can not confirm with Version: 5.1.0.0.alpha1+
Build ID: 2511a21841dd9dec735a53add8174e47d24deb88
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-13_23:26:46
Comment 2 Andrew Wetmore 2015-10-17 16:57:59 UTC
Would you like to see a video of it happening?

Possibly it is because you are not testing with the same version I am using. My version information:

Version: 5.0.2.2
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: en-CA (en_CA)
Comment 3 Andrew Wetmore 2015-10-17 16:58:52 UTC
I should note that there is no option on the form to choose the version I am using, so I chose the latest version I could see. Sorry for any confusion this caused.
Comment 4 Andrew Wetmore 2015-10-17 17:32:50 UTC
Sorry: found the version now. Will update the bug info
Comment 5 raal 2015-10-17 18:34:49 UTC
I can not confirm with version 5.0.2.2 (x64) too. Win7.
For the test, could you rename your LibreOffice directory profile (see https://wiki.documentfoundation.org/UserProfile) and give it a new try? Thank you
Comment 6 Andrew Wetmore 2015-10-19 12:22:18 UTC
I cannot save the edited file although I am the only user of this computer and I have changed the directory's settings to allow edits. I keep getting a message that I need admin permissions, which I have.

I am going to try uninstalling Libre Office, blowing away any remaining directories, and installing again.
Comment 7 Andrew Wetmore 2015-10-19 12:23:45 UTC
Here, by the way, is the bootstrap file contents. It seems to be pointing to version 4 as my UserInstallation location. I had 4 installed and upgraded to 5.

[ErrorReport]
ErrorReportPort=80
ErrorReportServer=report.libreoffice.org
[Bootstrap]
InstallMode=<installmode>
ProductKey=LibreOffice 5.0
UserInstallation=$SYSUSERCONFIG/LibreOffice/4
Comment 8 Andrew Wetmore 2015-10-19 13:20:07 UTC
Uninstalled Libre Office. Blew away v. 4 directory. Reinstalled v. 5. Same error. bootstrap file still points to a location in v. 4 (which does not now exist, of course), and I still cannot edit it. Getting the same bad behavior as initially reported.
Comment 9 Buovjaga 2015-10-20 18:00:56 UTC
Are you saving as docx? If yes, set as resolved duplicate of bug 89991
Comment 10 Andrew Wetmore 2015-10-20 18:05:04 UTC

*** This bug has been marked as a duplicate of bug 89991 ***
Comment 11 Justin L 2017-04-25 05:58:06 UTC
This bug was fixed in 5.3 master (documented in bug 97103), and backported to 5.2.0.

Thanks to author Michael Stahl 2016-06-08 10:31:06 (GMT)
commit: a59c4e26abbdd0720d24d3ddc0d6a05a67a31aaf
tdf#97103 sw: fix restoring of SetRedlineMode on DOCX/RTF export

*** This bug has been marked as a duplicate of bug 97103 ***