Bug Hunting Session
Bug 95183 - Check for Updates dialog does not show up in x86 Windows XP
Summary: Check for Updates dialog does not show up in x86 Windows XP
Status: RESOLVED DUPLICATE of bug 100295
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
5.0.0.3 rc
Hardware: x86 (IA32) Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 94482 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-10-19 17:08 UTC by Pedro
Modified: 2016-07-08 15:17 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2015-10-19 17:08:23 UTC
Using menu option Help > Check for Updates does not show any dialog under Windows x86 (tested with version 5.0.1.2 and 5.0.3.1 under Windows XP Pro x86 SP3)

The same function works as expected with the both LibreOffice versions under Windows 7 Pro x64 SP1
Comment 1 Dennis Roczek 2015-10-21 15:54:25 UTC
Version: 5.0.1.2
Build-ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Gebietsschema: de-DE (de_DE)

CONFIRMED

(win xp sp3 x86)
Comment 2 V Stuart Foote 2015-11-09 14:56:01 UTC
Confirming regression on Windows XP Pro SP3, 32-bit en-US with
Version: 5.0.2.2
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: en-US (en_US)

was fine for the 4.4 releases.
Comment 3 Pedro 2015-11-09 15:21:25 UTC
To add to the complexity, when LO 5.0.3.2 x86 is installed on a Windows x64 system (tested with Win7 Pro x64 SP1) the Check for Updates windows shows up.

Therefore this is a Win XP only problem OR a LibreOffice x86 under Win x86 only problem. Can someone with Win7 (or newer) x86 check this?
Comment 4 V Stuart Foote 2015-11-09 20:52:50 UTC
@Pedro, *

(In reply to Pedro from comment #3)
> To add to the complexity, when LO 5.0.3.2 x86 is installed on a Windows x64
> system (tested with Win7 Pro x64 SP1) the Check for Updates windows shows up.
> 
> Therefore this is a Win XP only problem OR a LibreOffice x86 under Win x86
> only problem. Can someone with Win7 (or newer) x86 check this?

Testing as you requested and looks to be 32-bit XP only...

On Windows 7 sp1 Enterprise 32-bit with
Version: 5.0.2.1
Build ID: 9a18d52abbdfbdc2ac9acebec2b92e7859eb73b7-GL
Locale: en-US (en_US)

On Windows 8.1 Enterprise 32-bit with
Version: 5.0.2.2
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe-GL
Locale: en-US (en_US)

Issue here of no update dialog is not present with either currently support MS 32-bit flavor of Windows. Nor does the issue of bug 95184 where Tools -> Options: "Online Update" is not present, manifest on either of these 32-bit builds.

Did you want me to test on 32-bit Vista as well?

Sorry, but it is all limited to the unsupported 32-bit Windows XP SP3 users.
Comment 5 Pedro 2015-11-10 11:28:39 UTC
@Stuart

> Issue here of no update dialog is not present with either currently support
> MS 32-bit flavor of Windows. Nor does the issue of bug 95184 where Tools ->
> Options: "Online Update" is not present, manifest on either of these 32-bit
> builds.
> 
> Did you want me to test on 32-bit Vista as well?

Thank you for the extensive testing. If you do have a Vista x86 machine to test that would be great.

Can you please add a comment to bug #95184 after testing with Vista?

Thanks!
Comment 6 V Stuart Foote 2015-11-10 12:05:06 UTC
*** Bug 94482 has been marked as a duplicate of this bug. ***
Comment 7 V Stuart Foote 2015-11-10 13:22:12 UTC
@cloph, @Robinson -- seems like this, and related bug 95184 (missing GUI elements), are a pretty serious regression at 5.0 for the 32-bit Windows XP SP3 user community. 

You might want to mention at the ESC--I don't know if this is boost related issue, or a VS build environment issue--over my head.

But, with both these warts showing in usage on 32-bit Windows XP, makes one wonder what other issues have not yet appeared.  Maybe a candidate for a "highest", at least to figure what has broken.
Comment 8 V Stuart Foote 2015-11-10 18:58:03 UTC
(In reply to Pedro from comment #5)
> > 
> > Did you want me to test on 32-bit Vista as well?
> 
> Thank you for the extensive testing. If you do have a Vista x86 machine to
> test that would be great.
> 
> Can you please add a comment to bug #95184 after testing with Vista?
> 

Sorry, had to scrounge a bit to locate install media, but I also could install a Vista SP2 x86 en-US system setup for testing.

So, it is interesting.  I performed my usual LibreOffice custom installation of 5.0.2.2, and deselected the Optional Components -> Online Update

Install completed, no issues.  Launch LO 5 and open Tools -> Options...

Hey, no "Online Update" entry! 

And on the main menu Help... Hey, no "Check for Updates..." entry!

That's weird. So from an Appwiz.cpl launch, I did a "Change" to LO, and from the LO Program Maintenance selected the "Modify" radio button.  In the Optional Components I selected active the "Online Update" item and completed the dialog.

On launch, Tools -> Options shows an "Online Update" entry, its check now button launches the update dialog. Also, the menu -> Help "Check for Updates..." is present, and it launches the update check.

=-=-=

So, back over to the Windows XP SP3 32-bit system. Performed the same Appwiz.cpl launch and "Change" to the LO install. Selected the Modify radio buton, and checked on the "Online Update" optional component and completed.

Sure enough -- the Windows XP SP3 32-bit system did the same thing and now has the entries in the Tools -> Options, and the Help menu. And both launch the update dialog.

=-=-=

Setting this to Needinfo -- please check if this workaround of a Change install and Modify of the "Online Update" optional component clears your issue as well?

To me it looks like it does, and also clears bug 95184.
Comment 9 Pedro 2015-11-11 10:08:09 UTC
(In reply to V Stuart Foote from comment #8)
> (In reply to Pedro from comment #5)

> Setting this to Needinfo -- please check if this workaround of a Change
> install and Modify of the "Online Update" optional component clears your
> issue as well?
> 
> To me it looks like it does, and also clears bug 95184.

Unfortunately that was not the problem. I also do a Custom Install but I leave the Online Update checked (because I want the component to be installed).

I even tried running Appwiz.cpl, unchecking the Online Update, running LibreOffice and then running Appwiz.cpl again and checking the Online Update option hoping that this would force an install of the module. Unfortunately there was no change.

I believe the priority on this bug should be raised.
Comment 10 V Stuart Foote 2015-11-13 18:53:58 UTC
OK, sorry for the noise. Please scratch what I said about working on XP with a Modify install... /me brain fart, and was really back into a Win7 32bit VM at that point.

There *is* a definite issue between 5.0.0.2 and 5.0.0.3 builds, 2015-06-28 -> 2015-07-12.

Got WinDbg set up on XP sp3, unfortunately LO does not crash for this, so can't pull a stack trace (still set up anyone want something specific?). 

However WinDbg *consistently* catches the following exception--C0000139 [entry point not found]--with the 5.0.0.3 build onward: 

ModLoad: 0c2d0000 0c326000   C:\Program Files\LibreOffice 5\program\updchklo.dll
ModLoad: 771b0000 7725a000   C:\WINDOWS\system32\WININET.dll
ModLoad: 0c330000 0c379000   C:\Program Files\LibreOffice 5\program\libcurl.dll
ModLoad: 76f60000 76f8c000   C:\WINDOWS\system32\WLDAP32.dll
ModLoad: 4d4f0000 4d549000   C:\WINDOWS\system32\WINHTTP.dll
(1dc.814): Unknown exception - code c0000139 (first chance)
(1dc.814): C++ EH exception - code e06d7363 (first chance)

Dependency walker shows noting really telling for our deployed libcurl.dll (just MSJAVA.DLL and MPR.DLL errors that supposedly can be ignored).

=-=-=

We updated cURL to 7.43 between 5.0.0.2 and 5.0.0.3 with
https://gerrit.libreoffice.org/#/c/16726/

Believe this note from the 7.44 cURL build is germane (and may suggest a work around).
https://fossies.org/diffs/curl/7.43.0_vs_7.44.0/winbuild/BUILD.WINDOWS.txt-diff.html

Also, mot clear why it would, but suspect this is also affecting the update menu item missing from GUI issue of bug 95184, which also appears between 5.0.0.2 and 5.0.0.3  It also affect just Windows XP sp3 installs. 

Finally, neither issue affects 32-bit Vista onward installs--"final answer" =)
Comment 11 Pedro 2015-11-13 19:19:12 UTC
(In reply to V Stuart Foote from comment #10)
> OK, sorry for the noise. Please scratch what I said about working on XP with
> a Modify install... /me brain fart, and was really back into a Win7 32bit VM
> at that point.
<snip>
> Finally, neither issue affects 32-bit Vista onward installs--"final answer"
> =)

Thank you for the extensive testing! It was really puzzling me that it worked for you under Windows XP!

So now it's up to TDF to decide. Either fix the regression or discontinue support for Windows XP.
Comment 12 zahra 2016-06-25 06:30:17 UTC Comment hidden (me-too)
Comment 13 V Stuart Foote 2016-07-07 03:00:49 UTC
With Markus's patch for XP libcurl
http://cgit.freedesktop.org/libreoffice/core/commit/?id=8562b1068328e16a629d2397f00af2a3e7998081&h=libreoffice-5-2

tdf#100295 force curl to build for XP

Testing with Windows XP sp3 Pro 32-bit en-US with
Version: 5.2.0.1.0+
Build ID: a2ab810b268ea3555a3931196ab17a0a0de8ba0b
CPU Threads: 2; OS Version: Windows 5.1; UI Render: default; 
Locale: en-US (en_US)

Attempt running Check for Update, but get an unknown exception when the patched libcurl runs.  Below stack trace from two attempts, and a manual break.
 
0:007> g
ModLoad: 0c730000 0c78b000   C:\Program Files\LibreOfficeDev 5\program\updchklo.dll
ModLoad: 3d930000 3da17000   C:\WINDOWS\system32\WININET.dll
ModLoad: 0c7a0000 0c7a9000   C:\WINDOWS\system32\Normaliz.dll
ModLoad: 78130000 78264000   C:\WINDOWS\system32\urlmon.dll
ModLoad: 3dfd0000 3e1bc000   C:\WINDOWS\system32\iertutil.dll
ModLoad: 0c7b0000 0c7f9000   C:\Program Files\LibreOfficeDev 5\program\libcurl.dll
ModLoad: 76f60000 76f8c000   C:\WINDOWS\system32\WLDAP32.dll
ModLoad: 4d4f0000 4d549000   C:\WINDOWS\system32\WINHTTP.dll
(43c.74c): Unknown exception - code c0000139 (first chance)
ModLoad: 0c730000 0c78b000   C:\Program Files\LibreOfficeDev 5\program\updchklo.dll
ModLoad: 3d930000 3da17000   C:\WINDOWS\system32\WININET.dll
ModLoad: 0c7a0000 0c7a9000   C:\WINDOWS\system32\Normaliz.dll
ModLoad: 78130000 78264000   C:\WINDOWS\system32\urlmon.dll
ModLoad: 3dfd0000 3e1bc000   C:\WINDOWS\system32\iertutil.dll
ModLoad: 0c7b0000 0c7f9000   C:\Program Files\LibreOfficeDev 5\program\libcurl.dll
ModLoad: 76f60000 76f8c000   C:\WINDOWS\system32\WLDAP32.dll
ModLoad: 4d4f0000 4d549000   C:\WINDOWS\system32\WINHTTP.dll
(43c.74c): Unknown exception - code c0000139 (first chance)
(43c.74c): C++ EH exception - code e06d7363 (first chance)
(43c.4dc): Break instruction exception - code 80000003 (first chance)
Comment 14 Markus Mohrhard 2016-07-08 14:34:47 UTC
Should be fixed now.
Comment 15 Christian Lohmaier 2016-07-08 15:17:06 UTC
setting as duplicate, the root cause was the same, just the way it was triggered was different..

*** This bug has been marked as a duplicate of bug 100295 ***