Bug Hunting Session
Bug 95201 - Crash when trying to save
Summary: Crash when trying to save
Status: RESOLVED DUPLICATE of bug 94936
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-20 16:52 UTC by francesco9999
Modified: 2015-10-20 19:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description francesco9999 2015-10-20 16:52:27 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build Identifier: Versione: 5.0.2.2 Build ID: 5.0.2.2 Arch Linux build-3 Versione locale: it-IT (it_IT.UTF-8)

Every time I add one o more formulas in LibreOffice Writer using Formula Editor and I try to save the document, the software crashes.
It happens even if I try Formula Editor (on my computer called LibreOffice Math) by itself. 
It crashes when I click on the Save Button or Save menus on both the softwares.
I need to use the Formula Editor as student, and i lost my work after an hour of work.

Reproducible: Always

Steps to Reproduce:
1.Add a formula in Writer (Or in Formula Editor)
2.Go to save the document (by the buttons or the menu)
3.The software ask for use the ODF format instead text format 
4.Choose ODF format
5.Crash
(step 3 and 4 only in LibreOffice Writer)
Actual Results:  
It crashes

Expected Results:  
Save the document

[Information automatically included from LibreOffice]
Locale: it
Module: TextDocument
[Information guessed from browser]
OS: Linux PC-Lab 4.2.3-1-ARCH #1 SMP PREEMPT Sat Oct 3 18:52:50 CEST 2015 x86_64 GNU/Linux
OS is 64bit: yes


Reset User Profile?Yes
Comment 1 Julien Nabet 2015-10-20 18:03:36 UTC
On pc Debian x86-64 with LO Debian package 5.0.2.2, I don't reproduce this.

Do you reproduce this with a brand new file?

For the test, could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#GNU.2FLinux) and give a new try?
Comment 2 francesco9999 2015-10-20 18:54:04 UTC
I thought it was a Formula Editor bug because LibreOffice never gave me this kind of bug ad this was the first time I was working on Formula Editor.

So the real problem is: LibreOffice crashes always when you try to save whatever.

I found that this bug is made by the update to GNOME 3.18

I've found this workaround https://forum.antergos.com/topic/3089/libreoffice-crashing-on-save/5 that says:
from the libreoffice menu go to tools/options/general and mark “use libreoffice dialogs”

It works and LibreOffice never crash anymore.
Comment 3 Maxim Monastirsky 2015-10-20 19:08:20 UTC
It's our bug actually, and it's already fixed towards 5.0.4. In the meantime there is a better workaround: Just add export SAL_USE_VCLPLUGIN=gtk to your .bash_profile, or uncomment this line in /etc/profile.d/libreoffice-fresh.sh. You'll need to logout-login for the change to take effect.

*** This bug has been marked as a duplicate of bug 94936 ***