Download it now!
Bug 95231 - Colors are not displayed in cells only after save as XLSX
Summary: Colors are not displayed in cells only after save as XLSX
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
: 100988 (view as bug list)
Depends on:
Blocks: XLSX
  Show dependency treegraph
 
Reported: 2015-10-21 17:36 UTC by Andrei Cristian Petcu
Modified: 2019-02-28 09:47 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
The broken file (15.12 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2015-10-21 17:36 UTC, Andrei Cristian Petcu
Details
Print screen from LO Calc before save (looks good) (80.75 KB, image/png)
2015-10-21 17:37 UTC, Andrei Cristian Petcu
Details
Print screen from LO Calc after save (Looks bad) (80.78 KB, image/png)
2015-10-21 17:38 UTC, Andrei Cristian Petcu
Details
Print screen from MS Excel after save (looks good) (107.41 KB, image/png)
2015-10-21 17:39 UTC, Andrei Cristian Petcu
Details
Minimal .xlsx file created by MS Excel 2010 on which it is possible to reproduce bu (14.00 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2016-08-02 23:15 UTC, Bartosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Cristian Petcu 2015-10-21 17:36:58 UTC
Created attachment 119838 [details]
The broken file

Steps to reporduce:
1) Open colours.xlsx in Libre Office Calc the colors in the first column are ok, they look like in colours_save_in_lo.png
2) Save file to disk as colours.xlsx and close LO Calc
3) Open the file again with LO Calc and some of the colours are gone. It looks like in colours_save_in_lo.png

If I save in ods format, it looks ok but not in xlsx.
You can see a print screen from MS Office in colours_save_in_mso.png, but you don't need MS Office to reporduce the bug.
Comment 1 Andrei Cristian Petcu 2015-10-21 17:37:50 UTC
Created attachment 119839 [details]
Print screen from LO Calc before save (looks good)
Comment 2 Andrei Cristian Petcu 2015-10-21 17:38:29 UTC
Created attachment 119840 [details]
Print screen from LO Calc after save (Looks bad)
Comment 3 Andrei Cristian Petcu 2015-10-21 17:39:09 UTC
Created attachment 119841 [details]
Print screen from MS Excel after save (looks good)
Comment 4 Joel Madero 2015-10-21 22:50:02 UTC
Ubuntu 15.04 x64
LibreOffice 5.0.4.0 (master)

Confirmed

New:
Major - loss of data;
High - default seems appropriate

Would be great to know if this is a regression - if possible please test older versions of LibreOffice and report back: http://downloadarchive.documentfoundation.org/libreoffice/old/
Comment 5 MM 2015-10-22 18:33:53 UTC
Tested with v3.3.4 under windows 7 x64.
Looks like no regression, colours are missing when saving too.
But when changing the colors and save to xlsx, the colors are there next time you load the file. So it looks like there are some excel colors which aren't handled properly.
Comment 6 Alex Thurgood 2016-07-21 07:16:15 UTC
*** Bug 100988 has been marked as a duplicate of this bug. ***
Comment 7 Alex Thurgood 2016-07-21 07:23:15 UTC
Seems like this is actually a DUP of bug 59346.
Comment 8 Bartosz 2016-08-02 23:15:49 UTC
Created attachment 126530 [details]
Minimal .xlsx file created by MS Excel 2010 on which it is possible to reproduce bu
Comment 9 Bartosz 2017-01-21 09:46:19 UTC
The problem is only related to .xlsx, after saving to .xls the problem doesn't exist
Comment 10 QA Administrators 2018-06-20 02:48:34 UTC Comment hidden (obsolete)
Comment 11 MM 2018-08-27 21:25:57 UTC
Confirmed on windows 7 x64 with Version: 6.0.6.2 (x64)
Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU threads: 3; OS: Windows 6.1; UI render: default
Comment 12 Chen-Ku 2018-11-29 09:52:42 UTC
no reproducible
版本:6.1.3.2 (x64)
組建 ID:86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU 執行緒:12; OS:Windows 10.0; UI 算繪:GL; 
語言地區:zh-TW (zh_TW); Calc: CL
i open the file again with LO Calc ,the color still remains
Comment 13 Roman Kuznetsov 2019-02-28 09:47:01 UTC
don't repro in

Version: 6.3.0.0.alpha0+
Build ID: c57dc7d41bd62f933cffab6131edb7252606382d
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

Status->WFM