Bug 95297 - Picture in table is not cut but pasted - picture appear twice..
Summary: Picture in table is not cut but pasted - picture appear twice..
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected
Depends on:
Blocks: Cut-Copy
  Show dependency treegraph
 
Reported: 2015-10-24 12:22 UTC by Marc Kaulisch
Modified: 2021-03-29 17:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
New test document a table with a few rows and pictures (54.78 KB, application/3dr)
2015-10-26 10:18 UTC, Marc Kaulisch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Kaulisch 2015-10-24 12:22:30 UTC
User-Agent:       Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:42.0) Gecko/20100101 Firefox/42.0
Build Identifier: LibreOffice 5.0.3.1

I do have a seven col table with the col 7 holding pictures (the rest holds text). Now I want to move the content of a row up or down. Pictures are rested at paragraph. I mark all col of the respective row and cut the content and paste it into another row. The picture of the row appears twice. In the original row and in the row in which the pictures is pasted.

Reproducible: Always

Actual Results:  
Picture is not cut from row and appears twice in table.

Expected Results:  
Picture is cut and appears only in

[Information automatically included from LibreOffice]
Locale: de
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: yes

Writer is 64bit as well


Reset User Profile?No
Comment 1 Buovjaga 2015-10-25 18:35:34 UTC
Could you attach a test document that is in the state before the cut & paste step?

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 2 Marc Kaulisch 2015-10-26 10:18:35 UTC
Created attachment 119963 [details]
New test document a table with a few rows and pictures

So I created a new document and I can reproduce it.

Cut a row, the picture cut is left in the row.
Comment 3 Marc Kaulisch 2015-10-26 10:21:32 UTC Comment hidden (obsolete)
Comment 4 Marc Kaulisch 2015-10-26 10:23:52 UTC
It is not a Windows 10 problem because I tested it with Word 2016 and it works as expected... In Word row is cut entirely...
Comment 5 Buovjaga 2015-10-28 17:30:42 UTC
Reproduced also from scratch.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)

Version: 5.1.0.0.alpha1+
Build ID: fcc2415ade6ae93710bbbda9f7e163045e323105
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-21_16:55:13
Locale: fi-FI (fi_FI)

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 6 QA Administrators 2016-11-08 12:05:12 UTC Comment hidden (obsolete)
Comment 7 Marc Kaulisch 2016-11-09 19:51:39 UTC
strange that this problem is not marked as duplicate anywhere
so I still have this problem.
tested with: Version: 5.2.3.2 (x64)
Build-ID: c019706a50de7fcb07d0d528b09b46a887562beb
CPU-Threads: 4; BS-Version: Windows 6.19; UI-Render: GL; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 8 Telesto 2016-12-27 14:31:11 UTC
Also found in:
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 9 QA Administrators 2018-06-30 02:41:00 UTC Comment hidden (obsolete)
Comment 10 QA Administrators 2020-06-30 03:41:39 UTC Comment hidden (obsolete)
Comment 11 Timur 2021-03-29 16:59:57 UTC
Fixed.

Bibisect Linux 6.4:
commit 27599bf6c17450ee8a5139987bbb4b42ddaf77c0
Date:   Tue Jun 16 15:57:54 2020 +0200
    source 89dc2b547b4cc307f7d69715a5e1ed4a27691755
    prev source 8718d243edc9400b0e0131b096702af8d33df327ΒΈ
tdf#133957 sw: SelectAll should select fly in empty section