Download it now!
Bug 95303 - FILEOPEN PPTX Incorrect rendering of SmartArt from older MS Office (OK if resaved in MSO 2016)
Summary: FILEOPEN PPTX Incorrect rendering of SmartArt from older MS Office (OK if res...
Status: RESOLVED DUPLICATE of bug 48948
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pptx
Depends on:
Blocks: OOXML-SmartArt PPTX
  Show dependency treegraph
 
Reported: 2015-10-24 17:17 UTC by beldmit
Modified: 2019-10-01 09:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Buggy file (583.20 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2015-10-24 17:17 UTC, beldmit
Details
Comparison between MS PP 2016 and LO 6.3 (101.61 KB, image/png)
2019-03-29 19:33 UTC, Roman Kuznetsov
Details
Buggy file compared MSO LO (157.02 KB, image/png)
2019-10-01 08:41 UTC, Timur
Details
PPTX file page 16 saved in MSO (104.86 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-10-01 08:42 UTC, Timur
Details
PPTX file page 16 compared MSO LO (223.08 KB, image/png)
2019-10-01 08:44 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description beldmit 2015-10-24 17:17:27 UTC
Created attachment 119929 [details]
Buggy file

The text on slide 16 is invisible in LibreOffice.
Comment 1 Buovjaga 2015-10-24 17:21:27 UTC
Confirmed.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)
Comment 2 QA Administrators 2016-11-08 11:23:15 UTC Comment hidden (obsolete)
Comment 3 Xisco Faulí 2016-11-08 11:27:36 UTC
Still present in

Version: 5.3.0.0.alpha1+
Build ID: 8a2a3f1032b4e60f7607e3ecb1ff99a6bb9af7f9
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and 

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 4 vihsa 2017-06-01 06:51:51 UTC
reproducible with lo viewer version: 5.5.0.0.alpha0+ / build id : ec79f34 / android 5.1
Comment 5 QA Administrators 2018-06-02 03:10:36 UTC Comment hidden (obsolete)
Comment 6 Roman Kuznetsov 2019-03-29 19:33:58 UTC
Created attachment 150407 [details]
Comparison between MS PP 2016 and LO 6.3

IN 6.3 I see all text on the 16 slide and it's correct text

But I see some different in shapes and it's another bug about SmartArt in general

Xisco, Buovjaga, close it as WFM or just change bug name to "Wrong render of SmartArt on slide 16"?
Comment 7 Xisco Faulí 2019-03-30 16:08:30 UTC
(In reply to Roman Kuznetsov from comment #6)
> Created attachment 150407 [details]
> Comparison between MS PP 2016 and LO 6.3
> 
> IN 6.3 I see all text on the 16 slide and it's correct text
> 
> But I see some different in shapes and it's another bug about SmartArt in
> general
> 
> Xisco, Buovjaga, close it as WFM or just change bug name to "Wrong render of
> SmartArt on slide 16"?

If the original bug is fixed, then I'd prefer to close this one as WFM and report a follow-up bug...
Comment 8 Timur 2019-10-01 08:41:25 UTC
Created attachment 154666 [details]
Buggy file compared MSO LO

As can be seen in screenshot, this wasn't resolved. Regardless that some content appeared, file is still not opened correctly. So I set back to New.

But, as will be shown in the next attachment, it's only because of this older SmartArt version. LO gives proper warning "Could not load all SmartArts. Saving in MS Office 2010 or later would avoid this issue."
This file was saved in MS Office 14, but maybe with compatibility option. 
I set this bug as minor.
Comment 9 Timur 2019-10-01 08:42:39 UTC
Created attachment 154667 [details]
PPTX file page 16 saved in MSO

This is minimized sample, just page 16, resaved in MSO without compatibility option.
Comment 10 Timur 2019-10-01 08:44:35 UTC
Created attachment 154668 [details]
PPTX file page 16 compared MSO LO

As can be seen, file with SmartArt resaved in newer MSO opens fine in LO.
So this bug is just for older SmartArt versions.
Comment 11 Timur 2019-10-01 09:08:00 UTC
....which all makes it a good candidate for a duplicate.

Moral: good triage decreased a number of bugs :)

*** This bug has been marked as a duplicate of bug 48948 ***