Download it now!
Bug 95367 - Header/footer lost (in specific file) on subsequent pages caused by page break (new page style crated)
Summary: Header/footer lost (in specific file) on subsequent pages caused by page brea...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard: target:5.3.0
Keywords: filter:docx
Depends on:
Blocks:
 
Reported: 2015-10-27 17:44 UTC by mcjarod
Modified: 2017-05-18 19:16 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
File with 5 page and headers (919.38 KB, application/x-download)
2015-10-27 17:44 UTC, mcjarod
Details
screenshots as I see in MS Word. (208.39 KB, image/jpeg)
2015-10-27 17:46 UTC, mcjarod
Details
printscreen (283.33 KB, image/png)
2015-10-29 20:12 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mcjarod 2015-10-27 17:44:19 UTC
Created attachment 120011 [details]
File with 5 page and headers

I have a problem with a file the header fails to pages 4 and 5
Comment 1 mcjarod 2015-10-27 17:46:15 UTC
Created attachment 120012 [details]
screenshots as I see in MS Word.
Comment 2 raal 2015-10-29 20:12:22 UTC
Created attachment 120082 [details]
printscreen

Works OK after delete page break
Comment 3 A (Andy) 2015-11-07 16:00:29 UTC
Reproducible with LO 5.0.3.2, Win 8.1.

The header is not visible on page 4 and 5.  But as raal wrote after deleting the page break it is visible.  
But because in WORD this problems seems not to appear I mark it as NEW, because in this case it has to be investigated and resolved, because manually deleting page breaks is of course no solution.  But of course, I don't know if this is really only a LO bug or has maybe also something to do with WORD, because theoretically it could also be a WORD problem.
Comment 4 Cor Nouws 2015-12-02 15:18:48 UTC
Same problem in 3.3.0 on Linux, so never worked
Comment 5 Justin L 2016-07-04 15:21:34 UTC
suggested fix: gerrit.libreoffice.org/26911
Comment 6 Commit Notification 2016-07-07 07:18:27 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1127bed4d943036473dbbda6bcfae1ec0a23ed2e

tdf#95367 inherit page style if no new one imported

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2016-10-10 06:30:23 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7060c7b642fdc0a369505e430652ee44205e7eed

tdf#95367 DOCX: allow r-t of changed first/follow sections

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.