Bug 95372 - OOXML sectPr: image is on the wrong side of the section break
Summary: OOXML sectPr: image is on the wrong side of the section break
Status: RESOLVED DUPLICATE of bug 118701
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Section
  Show dependency treegraph
 
Reported: 2015-10-27 20:15 UTC by Matthew Holloway
Modified: 2022-07-13 21:58 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example document (795.95 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-10-27 20:15 UTC, Matthew Holloway
Details
LibreOffice rendering (29.16 KB, image/png)
2015-10-27 20:17 UTC, Matthew Holloway
Details
MSOffice 2013 rendering (74.85 KB, image/png)
2015-10-27 20:19 UTC, Matthew Holloway
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Holloway 2015-10-27 20:15:58 UTC
Created attachment 120014 [details]
Example document

In the attached document on page 2 there's a heading "Appendix B: Draft Pipeline of planned investments" followed by an image.

In Microsoft Office 2013 the following image is shown on the same page as the heading, but in LibreOffice the image is pushed to the following page (page 3).
Comment 1 Matthew Holloway 2015-10-27 20:17:39 UTC
Created attachment 120015 [details]
LibreOffice rendering
Comment 2 Matthew Holloway 2015-10-27 20:19:08 UTC
Created attachment 120016 [details]
MSOffice 2013 rendering
Comment 3 Matthew Holloway 2015-10-27 20:21:14 UTC
In the document.xml within the OOXML if this sectPr is removed it renders the image where it should be:

<w:sectPr w:rsid="006322669"
Comment 4 raal 2015-10-29 16:16:19 UTC
Hello,
is it duplicate of bug 64372?
Comment 5 Buovjaga 2015-11-09 09:29:30 UTC
Set to NEEDINFO.
Change back to UNCONFIRMED or RESOLVED DUPLICATE of bug 64372, per comment 4.
Comment 6 Justin L 2016-06-23 19:38:27 UTC
This is NOT a duplicate of 64372.  There are no continuous page breaks defined in this document.

Confirmed that the image is located on page3 instead of page2 in LO dev 5.3.
Comment 7 QA Administrators 2017-09-01 11:17:59 UTC Comment hidden (obsolete, spam)
Comment 8 Justin L 2018-12-22 16:32:03 UTC
image still visible on page 3 instead of page 2.

The subject line "sectPr causes page break" wasn't helpful because that is exactly what it is supposed to do. There are three sectPr's - all of them without a type which means section_nextPage. So having three pages in total is correct.
Comment 9 QA Administrators 2020-12-22 03:43:15 UTC Comment hidden (obsolete)
Comment 10 Aron Budea 2021-08-21 05:57:01 UTC
Still in LO Version: 7.3.0.0.alpha0+ (c97bdca2d7abf30a99c45192b8f49c5bf76ca035) / Ubuntu.
It wasn't fine in older versions, either.
Comment 11 Gabor Kelemen (allotropia) 2022-07-13 21:58:10 UTC
This seems to be fixed since

https://git.libreoffice.org/core/+/b216fc5b583050cfb1cdf9bd82ec3c1bd2e09d70

author	Bakos Attila <bakos.attilakaroly@nisz.hu>	Tue Jun 30 15:03:31 2020 +0200
committer	László Németh <nemeth@numbertext.org>	Fri Jul 10 14:44:50 2020 +0200

tdf#118701 DOCX import: fix image position on page break

*** This bug has been marked as a duplicate of bug 118701 ***