Download it now!
Bug 95379 - Auto-correct Options - Word Completion Crashes Writer, Simplified Chinese (zh_CN) UI
Summary: Auto-correct Options - Word Completion Crashes Writer, Simplified Chinese (zh...
Status: RESOLVED DUPLICATE of bug 95068
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.3.1 rc
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: CJK
  Show dependency treegraph
 
Reported: 2015-10-28 06:30 UTC by Kevin Suo
Modified: 2015-10-30 09:31 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
stack_call.txt (4.04 KB, text/plain)
2015-10-30 05:45 UTC, Kevin Suo
Details
WinDbg bracktrace (22.01 KB, text/plain)
2015-10-30 06:26 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2015-10-28 06:30:53 UTC
Writer crashes when click the Word Completion tab within Auto-correction Options, in Simplified Chinese UI.

Steps to Reproduce:
1. Switch to Simplified Chinese UI.
2. Go to 工具(Tools) -> 自动更正选项(Auto-correct Options) -> 字词补全(Word Completion) tab.
--> Crash.

Below are some important notes:

* In version 5.0.3.1, no error message is show. In vesion 5.1.0.0.alpha1, the crash does not occur when click on the Word Completion tab. However, the crash does occur when click on the "Cancel" button, and after the crash a error window will appear showing "LibreOfficeDev5.1 - Fatal Error: SHE Exception: ACCESS VIOLATION.")

* Do not crash with Tranditional Chinese UI
  Do not crash with en_US UI.
  Do not crash with version 5.

Version: 5.0.3.1
Build ID: fd8cfc22f7f58033351fcb8a83b92acbadb0749e
Locale: zh-CN (zh_CN)
Comment 1 Kevin Suo 2015-10-28 06:31:40 UTC
Sorry, please ignore the sentence “Do not crash with version 5.” above.
Comment 2 baffclan 2015-10-29 10:25:21 UTC
dup/related to bug 95068?
Comment 3 Kevin Suo 2015-10-30 05:45:50 UTC
Created attachment 120090 [details]
stack_call.txt

I tried to get a backtrace using the debug function in Visual Studio 2015, but don't know how, only able to get the attached "stack call". Hope this is helpfull.
Comment 4 Kevin Suo 2015-10-30 06:26:05 UTC
Created attachment 120092 [details]
WinDbg bracktrace

Well, here is the WinDbg backtrace.
Comment 5 Jacques Guilleron 2015-10-30 07:34:36 UTC
Hi Kevin,

I confirm the crash with UI switched to Simplified Chinese in 
LO 5.0.3.1 Build ID: fd8cfc22f7f58033351fcb8a83b92acbadb0749e
under Windows 7 Home.
No crash with French UI.
This is not the same bug than bug 95068. Here, only selecting Word Completion tab
is enough to cause the crash.
Comment 6 Jacques Guilleron 2015-10-30 09:31:51 UTC
Sorry for the mistake (not awake), but this is a Duplicate of 95068, and issue begins with the same LO 5.0.2.1.

*** This bug has been marked as a duplicate of bug 95068 ***