Bug 95387 - UI: "Custom Animation" probably should be called just "Animation"
Summary: UI: "Custom Animation" probably should be called just "Animation"
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: filippo
URL:
Whiteboard: target:5.3.0
Keywords: difficultyBeginner, easyHack
Depends on:
Blocks:
 
Reported: 2015-10-28 09:36 UTC by Tor Lillqvist
Modified: 2017-02-14 08:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tor Lillqvist 2015-10-28 09:36:25 UTC
When I see "Custom Animation" my first thought is "oh, so there must be some plain, vanilla, built-in, non-custom animations too". But are there?
Comment 1 tommy27 2015-11-02 07:58:01 UTC
I agree with Tor. 
let's see what the UX-team thinks about.
if approved this should be an easy hack.
Comment 2 Tor Lillqvist 2015-11-02 09:03:56 UTC
(And the most misleading thing about "Custom" Animation is that they are built-in, non-optional, always present, so really nothing custom about them. At least the way I understand the word.)
Comment 3 tommy27 2015-11-02 12:15:05 UTC
just checked OOo 3.3.0 and I see that "Custom Animation" string has always been like that from OOo era.
version -> inherited from OOo
Comment 4 Heiko Tietze 2016-04-29 12:35:35 UTC
Design team agreed on removing "custom" from the animation.
Comment 5 Samuel Mehrbrodt (CIB) 2016-04-29 12:45:48 UTC
This is an EasyHack. Please change only the user-visible strings.

http://opengrok.libreoffice.org/search?q=%22Custom+animation%22&project=core&defs=&refs=&path=&hist=
Comment 6 filippo 2016-10-08 11:32:25 UTC
Hi I'm Filippo, a student of Perugia university.This is my first easy hack.I work on it
Comment 7 filippo 2016-10-11 10:50:46 UTC
hi to everyone,I change "custom animation" from menu entry at the top, but i can 't change the sidebar deck.
I think the problem is in core/officecfg/registry/data/org/openoffice/Office/UI/Sidebar.xcu. I try to make the full-build but nothing.

Is it the right file to modify?
Is there another setting file .xcu?
sorry for my english , thx.
Comment 8 Samuel Mehrbrodt (CIB) 2016-10-11 12:43:00 UTC
(In reply to filippo from comment #7)
> hi to everyone,I change "custom animation" from menu entry at the top, but i
> can 't change the sidebar deck.
> I think the problem is in
> core/officecfg/registry/data/org/openoffice/Office/UI/Sidebar.xcu. I try to
> make the full-build but nothing.
> 
> Is it the right file to modify?
> Is there another setting file .xcu?
> sorry for my english , thx.

Should be the right file. Please submit the patch you have to gerrit, will test then.
Comment 9 Commit Notification 2016-10-14 06:51:23 UTC
giacco committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b97eb74619bade81d1f14da9545f374806cfa284

tdf#95387 - UI: "Custom Animation" probably should be called just "Animation"

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 jani 2016-10-16 12:52:40 UTC
Seems solved.
Comment 11 Samuel Mehrbrodt (CIB) 2016-10-17 06:36:19 UTC
There are still a few instances, filippo, would you change them also please? http://opengrok.libreoffice.org/search?q=%22Custom+Animation%22&project=core&defs=&refs=&path=&hist=
Comment 12 Commit Notification 2016-10-20 12:08:57 UTC
giacco committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=35a48ceb1d92021aa9ce1d17509cd72acc84c718

tdf#95387 UI: "Custom Animation" probably should be called just "Animation"

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 jani 2016-10-21 05:31:06 UTC
There are still plenty of work to do here:

http://opengrok.libreoffice.org/search?q=%22Custom+Animation%22&project=core&defs=&refs=&path=&hist=
Comment 14 Commit Notification 2016-10-21 20:06:16 UTC
giacco committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=184e0d10902ee6dc32ab82aec25bcb8e2d1596a5

tdf#95387 UI: "Custom Animation" probably should be called just "Animation"

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 jani 2016-10-22 18:23:02 UTC
No more work to do, thanks for the patches.