Bug Hunting Session
Bug 95421 - Cannot move object by dragging its anchor icon.
Summary: Cannot move object by dragging its anchor icon.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0 target:5.1.3 target:5.0.6
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2015-10-29 18:12 UTC by Regina Henschel
Modified: 2016-10-25 19:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Drag the anchor to move the object (25.82 KB, application/vnd.oasis.opendocument.text)
2015-10-29 18:12 UTC, Regina Henschel
Details
What to drag (103.25 KB, image/png)
2015-12-13 20:55 UTC, Regina Henschel
Details
Tweaked file to replace the original one (3.78 KB, image/png)
2016-03-16 22:51 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2015-10-29 18:12:50 UTC
Created attachment 120081 [details]
Drag the anchor to move the object

Open the attached document. Click on the frame border to activate it. You now see the anchor of the frame as icon. Drag this anchor to another paragraph.
Zoom out so that you have two pages side-by-side. Click on the picture. Drag its anchor to the other page.

Expected behavior: The frame follows to the new paragraph. The picture moves to the other page.

Seen behavior: It is not possible to drag the anchor.

This feature is needed, when an object has a position other than "from left". If you drag the frame or picture itself, then the position is changed to "from left" and you need to restore the position settings. There is not other way to change to which paragraph or to which page an object is anchored than dragging the anchor.

It works here with Version 4.1.0.0.alpha0+ (Build ID: 74f74aa5470fe631c7827897742c0ccbddcf6ad)
TinderBox: Win-x86@6, Branch:master, Time: 2013-02-23_23:21:01

and fails at least since
Version: 4.2.5.2
Build ID: 6ff819b65674ae6c83f3cbab9e4a4c2b292a7a94
Comment 1 Cor Nouws 2015-10-29 19:54:48 UTC
works fine for me in 4.2.8.2, 4.4.3.2
but not in 5.0.3.1 .. all on 32 bits Linux

so my test result is different, but I confirm that it's not OK in 5.0.3.1
Comment 2 Joel Madero 2015-12-13 19:54:05 UTC
Hi Regina,

Can you re-test this with current master? I just tested and was able to move without a problem.

Bodhi Moksha
Version: 5.2.0.0.alpha0+
Build ID: 5df326438fd3a5613a52b4de1935426911ff1301
Comment 3 Regina Henschel 2015-12-13 20:55:33 UTC
Created attachment 121276 [details]
What to drag

I see the problem still in Version: 5.2.0.0.alpha0+
Build ID: c910e229aa19edd0502aa05dffedc91dd727da6f
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-12_23:53:45
Locale: de-DE (de_DE)

I'm not sure, whether my description is clear. I've attached a screenshot where I have marked what you have to drag.
Comment 4 Joel Madero 2015-12-14 00:40:50 UTC
Yeah I dragged from the anchor to the second page and the frame moved to the 2nd page....very weird. Will try on Windows.
Comment 5 Robinson Tryon (qubit) 2015-12-14 05:32:35 UTC Comment hidden (obsolete)
Comment 6 Joel Madero 2015-12-19 16:42:24 UTC
Hi Regina -

Really strange that you're still seeing this.

I see the problem with:
Version: 5.0.2.2
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe


I do not see the problem with:
Version: 5.2.0.0.alpha0+
Build ID: 5df326438fd3a5613a52b4de1935426911ff1301



@Cor - can you test with latest master and see if you can still repro?
Comment 7 Regina Henschel 2016-03-16 18:52:33 UTC
I have come a lot closer to the reason: The anchor cannot be dragged, if the icon-theme is set to "Galaxy". When you test it, you might need to restart LibreOffice after changing the icon-theme. The setting is in Tools > Options > LibreOffice > View > Icon style.

Last tested with
Version: 5.2.0.0.alpha0+
Build ID: 7055a93318e18853184235753abe247f93a3b085
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: de-DE (de_DE)
Comment 8 Regina Henschel 2016-03-16 22:51:54 UTC
Created attachment 123639 [details]
Tweaked file to replace the original one

There exists a workaround: The anchor-markers are contained in the file markers.png in image-galaxy.zip in svx/res. I have replaced the original ones with those from the 'tango' icon-theme, and with changed markers dragging works. The other markers inside this file are still the large ones from the Galaxy theme.

I consider this only a workaround, because it is not clear, what code changes has produced the error, that the galaxy anchor-markers cannot be dragged. And it is unclear what property in the galaxy anchor-markers is the reason for the failure. Therefore I do not make a patch to exchange the file in the source. But the file might be useful for others who have the same problem. You only need to open the image-galaxy.zip file in the folder 'share' in your installation and exchange the original file with the attached one.
Comment 9 Regina Henschel 2016-03-17 18:51:47 UTC
I have looked closer, what makes the Galaxy anchor markers differ from the other markers, so that they do not work like the others. I found, that they are rounded rectangles and that the corners have no color. If I add color there, the Galaxy anchor markers work same as those from the other icon-themes.

That still does not solve, why the code cannot use those images. But the change solves this dragging problem immediately, and it does not harm in case the reason in the code is found. Therefore I will provide a patch for altering the Galaxy marker file.

The final change is different from the attached one and contains only filling the empty corners.
Comment 10 Commit Notification 2016-03-18 07:25:30 UTC
Regina Henschel committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=243f8abf829323877733612c311019ec63956d82

tdf#95421 Galaxy anchor markers can be dragged again

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2016-03-18 07:41:59 UTC
Regina Henschel committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4bbde386439510e8e0ad066e17706438930f0e12&h=libreoffice-5-1

tdf#95421 Galaxy anchor markers can be dragged again

It will be available in 5.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2016-03-18 07:49:29 UTC
Regina Henschel committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e7e1720e5751e5ff8b6af4e1324f01a74b28a4a8&h=libreoffice-5-0

tdf#95421 Galaxy anchor markers can be dragged again

It will be available in 5.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Marco Filippozzi 2016-06-16 09:10:20 UTC
Works for me on:

Version: 5.0.6.3
Build ID: 490fc03b25318460cfc54456516ea2519c11d1aa
Locale: it-IT (it_IT.UTF-8)
OS: openSUSE Leap 42.1 (x86_64)

Version: 5.1.3.2
Build ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
CPU Threads: 2; OS Version: Linux 4.1; UI Render: default;
Locale: it-IT (it_IT.UTF-8)
OS: openSUSE Leap 42.1 (x86_64)

Version: 5.2.0.0.beta2
Build ID: ae12e6f168ba39f137fc110174a37c482ce68fa4
CPU Threads: 2; OS Version: Linux 4.1; UI Render: default;
Locale: it-IT (it_IT.UTF-8)
OS: openSUSE Leap 42.1 (x86_64)

Version: 5.3.0.0.alpha0+
Build ID: a8bd44573b75d1399257d6f5d052611439607189
CPU Threads: 2; OS Version: Linux 4.1; UI Render: default;
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 
2016-06-13_23:46:49
Locale: it-IT (it_IT.UTF-8)
OS: openSUSE Leap 42.1 (x86_64)

STATUS: NEW -> RESOLVED, WORKSFORME