Bug 95425 - Number format of data labels reset when format of data series is changed
Summary: Number format of data labels reset when format of data series is changed
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Balázs Varga
URL:
Whiteboard: target:7.0.0
Keywords: bibisected, bisected, regression
: 98346 108712 114489 (view as bug list)
Depends on:
Blocks: Chart-Labels
  Show dependency treegraph
 
Reported: 2015-10-29 22:49 UTC by jtagoe
Modified: 2020-05-26 16:09 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample dataset with two charts showing the issue (22.63 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-10-29 22:49 UTC, jtagoe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jtagoe 2015-10-29 22:49:55 UTC
Created attachment 120085 [details]
Sample dataset with two charts showing the issue

The number format of data labels is reset when the format such as the color of the data series is changed.

Please see the attached sample file with initially two identical charts. In the right hand side chart only the colour of the data series was changes, however, the number format is reset unintentionally.
Comment 1 raal 2015-10-31 22:25:21 UTC
It's even worse, format is  reset when open dialog Format data series and close dialog.
Version: 5.1.0.0.alpha1+
Build ID: 9a85743766e8a063d20d5f93ee88758e243397f4
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-10-23_00:56:39
and
LibreOffice 3.5.0 
Build ID: d6cde02
Comment 2 Andreas 2016-03-09 17:56:18 UTC
This seems to be the same bug as described in Bug 98346.

I can confirm this bug for Version: 5.0.4.2, Build ID: 00m0(Build:2).
Comment 3 Buovjaga 2016-03-09 19:03:01 UTC
*** Bug 98346 has been marked as a duplicate of this bug. ***
Comment 4 QA Administrators 2017-05-22 13:19:11 UTC Comment hidden (obsolete, spam)
Comment 5 Jacques Guilleron 2017-06-23 11:01:01 UTC
Bug still there with
LO 6.0.0.0.alpha0+ Build ID: 9e4502f0e393d2bc2810488b3ebb0a5c23038436
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-06-16_08:52:00
Locale: fr-FR (fr_FR); Calc: CL
Comment 6 Xisco Faulí 2017-06-23 11:42:33 UTC
*** Bug 108712 has been marked as a duplicate of this bug. ***
Comment 7 Obitanz 2017-06-26 07:48:33 UTC
I'm working on this bug.
Comment 8 Regina Henschel 2017-08-21 08:56:27 UTC
*** Bug 111936 has been marked as a duplicate of this bug. ***
Comment 9 Andreas 2017-10-24 15:34:44 UTC
Concerns: Version: 5.0.6.3 Build ID: 00m0(Build:3)

This bug also occurs when the data table of the chart is opened and a value is deleted from the chart.

This bug is very old already and it is very annoying since it is not possible to set the formats (as well as fonts etc.) for all series in one step.

So I strongly hope there will be a solution soon. Maybe this information is redundant, maybe it helps, so good luck in fixing!
Comment 10 Xisco Faulí 2018-01-23 09:06:44 UTC
Dear Dimitri Bouron,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.
Comment 11 QA Administrators 2019-01-24 03:50:58 UTC Comment hidden (obsolete)
Comment 12 jtagoe 2019-01-26 21:57:47 UTC
The bug is still present in
Version: 6.1.4.2
Build-ID: 1:6.1.4-0ubuntu0.16.04.1~lo2
CPU-Threads: 4; BS: Linux 4.15; UI-Render: Standard; VCL: gtk2;
Comment 13 NISZ LibreOffice Team 2019-12-05 14:19:20 UTC
Bibisected with bibisect-win32-4.3 to:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=22cd19eeeb476c40b68bb1ff040fce6103fdeba4

author	Kohei Yoshida <kohei.yoshida@collabora.com>	2014-06-13 11:12:50 -0400
committer	Markus Mohrhard <markus.mohrhard@googlemail.com>	2014-06-23 15:02:14 +0000
commit	22cd19eeeb476c40b68bb1ff040fce6103fdeba4 (patch)
tree	c4550dfcfbc10ebb75e3b6130ca44d44a28484ec
parent	a28256553dcc29d67c530b29727bfbf3ba6aa81a (diff)
fdo#71076, fdo#71767: Preserve number formats when charts are copied.

which is the same commit that was bibisected as cause for bug #123722
Comment 15 Xisco Faulí 2019-12-16 14:36:50 UTC
(In reply to Luke from comment #14)
> Fixed by
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=e57d90cd4e51a1353eafc87bb29cfe6076704a7c

Indeed. Verified in

Version: 6.5.0.0.alpha0+
Build ID: 3e33a11d8a553a99bd5f23940a65c301924198fb
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 16 Commit Notification 2020-03-24 10:22:04 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9bf40c635c41c6b3b072b7c61fea67a20ba4342b

tdf#95425 follow-up: enable "Source format" checkbox of data label

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2020-03-24 15:11:48 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7de7512718ac192fcad441d5500d056316f72d72

Revert "tdf#95425 follow-up: enable "Source format" checkbox of data label"

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2020-04-09 08:26:24 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e4a087876da2584b772480d4fe8fc58081dfe0b8

tdf#95425 follow-up: enable "Source format" checkbox of data label

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 NISZ LibreOffice Team 2020-05-26 16:09:00 UTC
*** Bug 114489 has been marked as a duplicate of this bug. ***