Bug Hunting Session
Bug 95431 - Insert big image get black box
Summary: Insert big image get black box
Status: RESOLVED DUPLICATE of bug 75788
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Writer-Images
  Show dependency treegraph
 
Reported: 2015-10-30 05:44 UTC by omvsj
Modified: 2016-12-23 11:39 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Image 4160 x 2340 inserted as black box (2.61 MB, image/jpeg)
2015-10-30 05:44 UTC, omvsj
Details

Note You need to log in before you can comment on or make changes to this bug.
Description omvsj 2015-10-30 05:44:26 UTC
Created attachment 120089 [details]
Sample Image 4160 x 2340 inserted as black box

Tested in:
Linux Mint 17.2 up-to-date
LibO 4.4.3~rc2-0ubuntu1~trusty1 (rafaela) from official Mint repository 
LibO 5.0.2.2 from ppa:libreoffice/ppa
Diferent Images: 4160 x 2340
Components: Writer, Calc, Impress, Draw

1. Open new document
2. Menu Insert -> Image -> Select image -> Open
3. Black box
4. Save file
5. Unzip the file
6. Under Pictures there's a file "10000000000010400000092402422B09D57D5491.jpg" with 49.2 kb and only the first 10 rows of original pixels

Scaling down the image (2080 x 1170) imports correctly.
Comment 1 MM 2015-10-30 13:46:02 UTC
Confirmed with v4.4.6.3 under windows 7 x64.
Confirmed with v5.0.3.2 under mint 17.2 x64.
Confirmed with v4.2.6.3 under mint 17.2 x64.
Unconfirmed with v3.3.4 under windows 7 x64.

Set as regression.
Comment 2 Chris Sherlock 2016-03-06 01:48:16 UTC
Definitely not showing the image, but not a "black" image either.
Comment 3 Xisco Faulí 2016-09-12 12:28:10 UTC
Adding keyword 'bibisectRequest'.
Comment 4 Aron Budea 2016-09-25 05:12:22 UTC
LO 4.0.0.3 / Ubuntu 16.04 already shows black box, adjusting earliest version.
Comment 5 Telesto 2016-12-23 11:05:56 UTC
Still reproducible with:
Version: 5.4.0.0.alpha0+
Build ID: 9cfb2f2f03b5ec086487fd483298466db0b09010
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-20_23:58:02
Locale: nl-NL (nl_NL); Calc: CL
Comment 6 Telesto 2016-12-23 11:39:17 UTC

*** This bug has been marked as a duplicate of bug 75788 ***