Bug Hunting Session
Bug 95551 - Crash changing icon themes when image has imagemap
Summary: Crash changing icon themes when image has imagemap
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:5.0.4
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2015-11-03 21:13 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-10-25 19:20 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
backtrace (34.46 KB, text/plain)
2015-11-03 21:13 UTC, Yousuf Philips (jay) (retired)
Details
bt with debug symbols (15.21 KB, text/plain)
2015-11-04 22:00 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-11-03 21:13:16 UTC
Created attachment 120243 [details]
backtrace

Steps:
1) Open Writer
2) Insert an image
3) Add an image map (Edit > ImageMap)
4) Change icon themes (Tools > Options > LibreOffice > General)
5) Crash

Version: 5.1.0.0.alpha1+
Build ID: 7a40c137e480329d9cf2b7946c2d83d9e52e8d29
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-10-31_23:29:52
Locale: en-US (en_US.UTF-8)
Comment 1 Julien Nabet 2015-11-04 22:00:00 UTC
Created attachment 120274 [details]
bt with debug symbols

On pc Debian x86-64 with master sources (without enable-mergelibs) updated today, I could reproduce this.

I attached a bt with symbols.
Comment 2 raal 2015-11-06 12:14:27 UTC
(In reply to Julien Nabet from comment #1)
> Created attachment 120274 [details]
> bt with debug symbols
> 
> On pc Debian x86-64 with master sources (without enable-mergelibs) updated
> today, I could reproduce this.
> 
> I attached a bt with symbols.

Setting as new
Comment 3 Michael Meeks 2015-11-12 17:24:02 UTC
Pushed a fix to master, and to gerrit for -5-0; looks like a long standing bug though.
Comment 4 Commit Notification 2015-11-12 17:24:54 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=51af0ef35b5a7ed0d1468f11cca73ba0158e8be4

tdf#95551 - fix image map crash.

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2015-11-13 15:26:16 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=45c6d948fbac77a8a6926f56579a4ceba981288f&h=libreoffice-5-0

tdf#95551 - fix image map crash.

It will be available in 5.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.