Bug 95552 - Imagemap links do not work, if the image is selected
Summary: Imagemap links do not work, if the image is selected
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Images
  Show dependency treegraph
 
Reported: 2015-11-03 21:32 UTC by Yousuf Philips (jay) (retired)
Modified: 2021-02-10 04:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test file (114.15 KB, application/vnd.oasis.opendocument.text)
2015-11-06 12:22 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-11-03 21:32:17 UTC
Steps:
1) Open Writer
2) Insert an image
3) Add an imagemap (Edit > ImageMap) with a square area and link it libreoffice.org
4) Move the mouse over the image until the link tooltip appears
5) Pressing Ctrl doesnt turn the drag hand mouse pointer into the click mouse pointer and Ctrl and mouse click doesnt launch the link

Version: 5.1.0.0.alpha1+
Build ID: 7a40c137e480329d9cf2b7946c2d83d9e52e8d29
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-10-31_23:29:52
Locale: en-US (en_US.UTF-8)
Comment 1 raal 2015-11-06 12:22:20 UTC
Created attachment 120323 [details]
test file

Works for me in LO 5.0.2.2, win7
Check option “LibreOffice > Security > Options... > Ctrl-click required to follow hyperlinks“
Comment 2 Yousuf Philips (jay) (retired) 2015-11-07 20:12:27 UTC
(In reply to raal from comment #1)
> Works for me in LO 5.0.2.2, win7
> Check option “LibreOffice > Security > Options... > Ctrl-click required to
> follow hyperlinks“

Already checked. This issue doesnt happen with opened documents, it happens with newly created documents.
Comment 3 raal 2015-11-08 07:23:13 UTC
I can not confirm with Version: 5.1.0.0.alpha1+
Build ID: c5fefe46fc9dca3942b2fc33ffd1f7e041d450e6
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-11-04_07:04:49

newly created document.
Comment 4 Buovjaga 2015-11-11 12:31:31 UTC
No repro. Pressing ctrl and hovering turns the pointer into hand and I am able to click.

Win 7 Pro 64-bit, Version: 5.0.3.2 (x64)
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale: fi-FI (fi_FI)

Version: 5.1.0.0.alpha1+
Build ID: 6da681442b17c723f9408a806e8d2367441ad65a
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-07_23:13:46
Locale: fi-FI (fi_FI)

Ubuntu 15.10 64-bit 
Version: 5.1.0.0.alpha1+
Build ID: a148fe149c7af1995fd2aaab0a6e52242509b993
TinderBox: Linux-rpm_deb-x86_64@70-TDF-dbg, Branch:master, Time: 2015-11-08_23:54:51
Locale: en-US (en_US.UTF-8)
Comment 5 Yousuf Philips (jay) (retired) 2015-11-11 22:39:50 UTC
Tested master on a different machine (Linux Mint 17.2 Mate) then the one i opened the bug with (Linux Mint 17.1 XFCE) and it also shows the same result.
Comment 6 Aron Budea 2016-11-20 04:36:09 UTC
Isn't the difference that Jay you tried when the image was selected, and the others tried when it wasn't selected?

I can reproduce this if the image is selected with 5.2.3.3 & 5.3 daily build / Windows 7, even with the attached document. If the image is selected, cursor turns into a four-headed arrow (the equivalent of a drag hand), and Ctrl-clicking the image does nothing.

Not entirely sure if it should, but then in that case the tooltip shouldn't be displayed if the image is selected. What do you guys think?

Btw, the tooltip is refreshed rather badly with lots of flickering/disappearance if OpenGL is enabled.
Comment 7 Buovjaga 2016-11-21 19:56:02 UTC
Good catch. Indeed, when the image is selected, the tooltip appears, but ctrl-clicking leads nowhere.

It is a good philosophical question whether we need to remove the tooltip or allow ctrl-clicking to work.

Arch Linux 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha1+
Build ID: 76683829204103446476443b099492c402929004
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; Layout Engine: new; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on November 21st 2016
Comment 8 QA Administrators 2017-11-22 15:41:19 UTC Comment hidden (obsolete)
Comment 9 ace_dent 2018-02-09 21:43:53 UTC
Version: 5.4.1.2
Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
Locale: en-GB (en_GB.UTF-8); Calc: group

As a first time user of ImageMap (but 12yrs+ using OOo & LO!), this behaviour was not surprising to me- although it could be improved. Suggest considering this as an Enhancement request and considering the UX further. 

Perhaps remove tooltip when selected for editing... but then there is *no* indication the ImageMap operation was successful (which is helpful).
Comment 10 QA Administrators 2019-02-10 03:44:21 UTC Comment hidden (obsolete)
Comment 11 QA Administrators 2021-02-10 04:11:40 UTC
Dear Yousuf Philips (jay) (retired),

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug