Bug 95739 - Start Center: allow different view modes for recent files list
Summary: Start Center: allow different view modes for recent files list
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 99484 114515 (view as bug list)
Depends on:
Blocks: Start-Center
  Show dependency treegraph
 
Reported: 2015-11-11 03:45 UTC by Ian Croft
Modified: 2017-12-18 01:32 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Croft 2015-11-11 03:45:14 UTC
It would help if the view is selectable ie size of the icon, or to use file details or list view.

In Win10, the recent files can be selected by right-click on the app icon in the task bar ..... this is very useful.
Comment 1 tommy27 2015-11-11 05:32:48 UTC
the Start Center currently shows recent files as big thumbnails.
the user asks to have different view modes like in any file manager (i.e. small thumbs, list view, details view)

probably not so easy to implement but a valuable enhancement request
status NEW. edited summary notes for clarity
Comment 2 V Stuart Foote 2015-11-11 16:09:30 UTC
Not without merit, but when issues like this have been discussed consensus has been that we don't intend for the StartCenter to become a replacement for the OS Desktop provided file management.  Showing, or not showing, the thumbnail views of the MRU menu list is bug 74834, resizing the thumbnails is bug 73197, filtering StartCenter thumbnails by LO module is bug 80934.


Displaying the MRU items in forms other than thumbnails is really getting into the realm of work better done by the users OS/DE
Comment 3 Samuel Mehrbrodt (CIB) 2016-06-16 16:54:47 UTC
As Stuart said, this is by design.
Closing this as wontfix.
Comment 4 Jan Holesovsky 2016-06-16 20:07:09 UTC
I think the reporter actually meant something different - the Windows 10 jump lists; ie. something like:

http://www.windowscentral.com/sites/wpcentral.com/files/styles/larger/public/field/image/2015/10/win32-jump-list.png?itok=-tB-sZTO

So it is more a missing Windows 10 integration thing; but I don't see anybody working on this in the near future, so WONTFIX is probably the correct resolution for the moment - sorry about that.
Comment 5 Samuel Mehrbrodt (CIB) 2016-06-17 06:08:16 UTC
(In reply to Jan Holesovsky from comment #4)
> I think the reporter actually meant something different - the Windows 10
> jump lists; ie. something like:
> 
> http://www.windowscentral.com/sites/wpcentral.com/files/styles/larger/public/
> field/image/2015/10/win32-jump-list.png?itok=-tB-sZTO
> 
> So it is more a missing Windows 10 integration thing; but I don't see
> anybody working on this in the near future, so WONTFIX is probably the
> correct resolution for the moment - sorry about that.

Hm I think we already have this. At least on Windows 7 I see the jump list of recent documents when I right click on the Writer icon in the task bar.
Comment 6 V Stuart Foote 2017-07-08 12:33:56 UTC
*** Bug 99484 has been marked as a duplicate of this bug. ***
Comment 7 V Stuart Foote 2017-12-18 01:30:47 UTC
*** Bug 114515 has been marked as a duplicate of this bug. ***