Bug 95797 - Current display of the document moves away (jumps) when saving or when autorecovery information is saved
Summary: Current display of the document moves away (jumps) when saving or when autore...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: Other All
: medium minor
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:5.3.0 target:5.2.0.1
Keywords: bibisected, bisected, regression
: 78644 93574 100625 100667 101928 106769 109089 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-11-13 14:16 UTC by Antonio Martins
Modified: 2017-07-13 02:25 UTC (History)
16 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antonio Martins 2015-11-13 14:16:11 UTC
When you have a multiple page document, and you move the display away from the cursor location to a different page, when it triggers an auto-save, it moves back the display to the page where the cursor was.

The correct behavior would be to auto-save and let the display in the exact same position.

To replicate the supposedly problem you just have to:
- Make sure auto-save is enabled
- Crete a document with 3 or more pages
- Leave the cursor in the first page
- Move the scrollbar to page 3
- Wait for the auto-save to kick-in

After the save, it will move back to page 1, when you were actually reading page 3.
Comment 1 V Stuart Foote 2015-11-14 13:40:49 UTC
(In reply to Antonio Martins from comment #0)
> The correct behavior would be to auto-save and let the display in the exact
> same position.

That is a matter of personal preference, the current behavior is equally correct in that the view shifts on save/autosave to current edit cursor position. However this issue is already open as bug 41063.

*** This bug has been marked as a duplicate of bug 41063 ***
Comment 2 Buovjaga 2016-05-09 10:12:55 UTC
A user in bug 41063 noted that the older report was about being inside a table, while this newer problem happened after 4.4.7 and does not require being inside a table.

I tested it and 4.4 does not show the problem, while 5.0.2 shows it.

Thus I am setting this to NEW.

I tested on Win 7
Versio: 5.0.2.2 (x64)
Käännöksen ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Maa-asetus: fi-FI (fi_FI)
Comment 3 V Stuart Foote 2016-05-09 16:15:56 UTC
comments on bug 41603 -- nothing to do with table v. paragraphs
always has been there in that there is not method of tracking review position of the canvas--and all positioning of updates to the canvas are linked to the edit cursor position.

otherwise add dupes
bug 78644
bug 92864
bug 93265
bug 93440
bug 93574
bug 94463
bug 97730
bug 97780
Comment 4 V Stuart Foote 2016-05-09 16:46:52 UTC
(In reply to V Stuart Foote from comment #3)

Whoops make those dupes
bug 78644
bug 92365
bug 92864
bug 93440
bug 93574
bug 94663
bug 97730
bug 97780

need better glasses again...
Comment 5 Buovjaga 2016-05-10 08:55:07 UTC
*** Bug 93574 has been marked as a duplicate of this bug. ***
Comment 6 Buovjaga 2016-05-10 08:55:49 UTC
*** Bug 78644 has been marked as a duplicate of this bug. ***
Comment 7 Buovjaga 2016-05-10 09:16:07 UTC
(In reply to V Stuart Foote from comment #3)
> comments on bug 41603 -- nothing to do with table v. paragraphs
> always has been there in that there is not method of tracking review
> position of the canvas--and all positioning of updates to the canvas are
> linked to the edit cursor position.

This is not true. The view does not jump with paragraphs in my tests with 3.5, 4.3 and 4.4.
Comment 8 raal 2016-06-08 21:18:07 UTC
This seems to have begun at the below commit.
Adding Cc: to Bjoern Michaelsen; Could you possibly take a look at this one? Thanks

ceea390d4b1631bc64f6fb1064ff685bebbdfa48 is the first bad commit
commit ceea390d4b1631bc64f6fb1064ff685bebbdfa48
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Wed May 20 06:21:31 2015 -0500

    source sha:07c7c88bc2d9d860ea92ab562ea0431ec1949b29

author	Bjoern Michaelsen <bjoern.michaelsen@canonical.com>	2015-01-23 21:58:39 (GMT)
committer	Bjoern Michaelsen <bjoern.michaelsen@canonical.com>	2015-01-23 22:15:15 (GMT)
commit	07c7c88bc2d9d860ea92ab562ea0431ec1949b29 (patch)
tree	d9cf50a4af0b3b1909bfa9c8d1c99adfbbb37f69
parent	0717643f4b061b8fd6bd59dcbdbbaf8c98c4a4dd (diff)
do not use manual iteration
Comment 9 sebalis 2016-06-10 00:13:03 UTC Comment hidden (no-value)
Comment 10 Commit Notification 2016-06-20 08:18:32 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2d67042dc2f0672d1aca4784e61eb2a5d0e91e08

tdf#95797: Don't jump to the cursor position after auto-save.

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2016-06-20 08:19:54 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4fabfb654bc65a564da1162f10f441efce167706&h=libreoffice-5-2

tdf#95797: Don't jump to the cursor position after auto-save.

It will be available in 5.2.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Jan Holesovsky 2016-06-20 08:20:10 UTC
raal: Big thanks for the bisect, fixed it now :-)
Comment 13 sebalis 2016-06-20 08:36:39 UTC Comment hidden (no-value)
Comment 14 V Stuart Foote 2016-06-26 20:07:27 UTC
*** Bug 100625 has been marked as a duplicate of this bug. ***
Comment 15 Aron Budea 2016-06-29 04:45:50 UTC
*** Bug 100667 has been marked as a duplicate of this bug. ***
Comment 16 Buovjaga 2016-09-29 19:20:19 UTC
*** Bug 101928 has been marked as a duplicate of this bug. ***
Comment 17 V Stuart Foote 2017-03-26 04:04:18 UTC
*** Bug 106769 has been marked as a duplicate of this bug. ***
Comment 18 V Stuart Foote 2017-07-13 02:25:45 UTC
*** Bug 109089 has been marked as a duplicate of this bug. ***