Bug Hunting Session
Bug 95840 (Horseradish) - Using French Horseradish invokes French Autocorrect?
Summary: Using French Horseradish invokes French Autocorrect?
Status: RESOLVED NOTABUG
Alias: Horseradish
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-15 19:30 UTC by vermontpoet
Modified: 2015-12-01 13:43 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
ODT document with French Horseradish. (11.26 KB, application/vnd.oasis.opendocument.text)
2015-11-15 19:47 UTC, vermontpoet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vermontpoet 2015-11-15 19:30:33 UTC
Weird bug. Writing in English, threw in a French phrase, and suddenly Libre thinks I'm French? Takes it upon itself to insert non-breaking spaces around colons, semi-colons (even after I've switched off this option in 'Localized Options'). Also, when I try to close quotes, I get this:

. »

Expected is this:

"

Suddenly my keyboard is French and Auto-correct assumes I'm French? I still haven't figured out how to stop this.

Very, very annoying.
Comment 1 vermontpoet 2015-11-15 19:47:16 UTC
Created attachment 120562 [details]
ODT document with French Horseradish.

I've attached a document demonstrating the bug. It's easy to reproduce.  Use horseradish.

“This is a test.”
“Le raifort, oui? »

Once Libre sniffs out the French horseradish, there's no going back. It will turn all of your quotes into the French equivalent, and turning off the autocorrect tables doesn't help. It only seems to affect the paragraph in which the horseradish appears. But you can reproduce (or at least I can) in any document.

I think this should be called the Horseradish Bug.
Comment 2 vermontpoet 2015-11-15 20:07:43 UTC
Okay, I think I know what might be causing the bug. I (lazily) copied and pasted the word from Google translate. I can reproduce the bug with any word from Google Translate:

“This is a test.”
“C'est vrai! »

I haven't tested this with other languages. Interestingly, trying to strip out whatever code is causing this with leafpad (copying & pasting back from leafpad) doesn't work. It's like there's a French virus that makes everything French. How typically French.
Comment 3 Buovjaga 2015-11-16 13:31:01 UTC
Could repro with copy & paste from G. translate. Yet, if I first paste it to Notepad++ and then copy from there, the "French metadata" is not preserved.

Not sure, if bug or feature, but I'll set to NEW just in case.

Win 7 Pro 64-bit, Version: 5.0.3.2 (x64)
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale: fi-FI (fi_FI)

Version: 5.1.0.0.alpha1+
Build ID: b216cc1b8096eb60c27f67e8c27b7cd756c75e38
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-12_00:06:20
Locale: fi-FI (fi_FI)
Comment 4 tommy27 2015-11-29 19:32:18 UTC
hi there,
please take a look at Bug 76964
in that case the english autocorrect kicked in even in non-english languages...
so I wonder if we are seeing another symptom of the same bug...

Bug 76964 has been fixed in LibO 5.0.4 daily builds, so if you wanna see if the current one is still reproducible after that commit, please grab a 5.0.4 daily from here and retest: http://dev-builds.libreoffice.org/daily/libreoffice-5-0/
Comment 5 Buovjaga 2015-11-30 12:15:51 UTC
(In reply to tommy27 from comment #4)
> hi there,
> please take a look at Bug 76964
> in that case the english autocorrect kicked in even in non-english
> languages...
> so I wonder if we are seeing another symptom of the same bug...
> 
> Bug 76964 has been fixed in LibO 5.0.4 daily builds, so if you wanna see if
> the current one is still reproducible after that commit, please grab a 5.0.4
> daily from here and retest:
> http://dev-builds.libreoffice.org/daily/libreoffice-5-0/

Yet I reproduced it in a 5.1 build that should have had the fix.
Comment 6 tommy27 2015-11-30 12:44:56 UTC
ok, thanks 4 testing. this is a different bug then.

anyway I CC Caolan since he know the code and can tell if this is still a related issue..,
Comment 7 Caolán McNamara 2015-12-01 11:39:14 UTC
There's no bug here. The paste from google is in html and the language attribute of the text is correctly imported in. The attributes of text at the insertion point will affect text added after that. So paste in french text from google and type after it and it will have the french language attribute also.

So, you can just click on the bottom of the frame to change the language back to whatever it was before you pasted in to set new text back to e.g english.

you can shift+ctrl+v to paste special and paste as "plain text" to not paste the language attribute along with the text

or you can e.g.press space twice, go back one space, paste there and whack end to go past the last space. And that last space was in your orig language so following text remains in your original language

is the same sort of problem you get with hyperlinks at the insertion point in writer and loads of other apps where the hyperlink is stuck to your cursor and following text appears underlined.
Comment 8 tommy27 2015-12-01 13:43:57 UTC
thank you very much Caolan.
I was sure you were the right man to ping :-)