Bug 95908 - Can't turn off AutoCorrect globally in Impress and Draw
Summary: Can't turn off AutoCorrect globally in Impress and Draw
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval
Depends on:
Blocks:
 
Reported: 2015-11-18 14:10 UTC by 2460acc
Modified: 2019-10-22 15:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Autocorrect while typing (31.05 KB, image/jpeg)
2015-11-19 09:11 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 2460acc 2015-11-18 14:10:47 UTC
User-Agent:       Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
Build Identifier: LibreOffice 5.0.3.2

I cant turn off autocorrect. Its making me crazY.

Reproducible: Always




[Information automatically included from LibreOffice]
Locale: en-US
Module: PresentationDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


Reset User Profile?No
Comment 1 Buovjaga 2015-11-19 06:53:54 UTC
Have you unchecked Format - Autocorrect - While typing?

Set to NEEDINFO.
Change back to UNCONFIRMED, if you had disabled the setting. Change to RESOLVED INVALID, if you had not disabled it yet and the problem went away.
Comment 2 2460acc 2015-11-19 08:48:07 UTC
(In reply to Beluga from comment #1)
> Have you unchecked Format - Autocorrect - While typing?
> 
> Set to NEEDINFO.
> Change back to UNCONFIRMED, if you had disabled the setting. Change to
> RESOLVED INVALID, if you had not disabled it yet and the problem went away.

There is no option to turn off Autocorrect in any of these places:

Format -> Autocorrect
Tools -> Options 
Tools -> Autocorrect options

How am I supposed to turn it off?
Comment 3 Buovjaga 2015-11-19 09:11:14 UTC
Created attachment 120654 [details]
Autocorrect while typing

Screenshot showing the options.

You mean there is no While typing in your menu?
Comment 4 2460acc 2015-11-20 12:05:59 UTC
In Impress there is no option although I can see it in Writer (like yours).

Sorry I can't do a screenshot - the Linux screenshot utility doesn't seem capable of doing it when a menu is open.
Comment 5 Buovjaga 2015-11-20 12:20:22 UTC
Argh, sorry, I didn't notice the component!

Indeed, the only way to disable autocorrect in Impress is to fiddle with the autocorrect options (disable Use replacement table etc.).

Setting this to NEW.
Comment 6 Robinson Tryon (qubit) 2015-12-10 07:26:45 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2017-10-23 14:06:16 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug