Download it now!
Bug 95950 - Fileopen: XLSX has wrong fixed column width in Linux Calc
Summary: Fileopen: XLSX has wrong fixed column width in Linux Calc
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-20 11:59 UTC by Dmitry
Modified: 2017-01-04 14:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Test table (7.09 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2015-11-20 12:00 UTC, Dmitry
Details
Sceershot of Print Preview (44.64 KB, image/png)
2015-11-20 14:45 UTC, tagezi
Details
2 pages ubuntu 14.04 Libre 5 (193.18 KB, image/png)
2015-11-20 19:37 UTC, BATMAH
Details
2 pages ubuntu 14.04 Libre 4 (194.41 KB, image/png)
2015-11-20 20:00 UTC, BATMAH
Details
column width (cm), up on Windows, down on Ubuntu-MATE (25.07 KB, image/jpeg)
2015-11-20 20:24 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry 2015-11-20 11:59:43 UTC
I have created a table with fixed cell width (set it in pt). In different versions of LO Calc in Windows 7 this table printed in one page, but in Ubuntu 14.04 the table is printed: 5 cells in first page and 2 cells in next page.
Comment 1 Dmitry 2015-11-20 12:00:57 UTC
Created attachment 120678 [details]
Test table
Comment 2 Roman Kuznetsov 2015-11-20 12:49:12 UTC
1) if you save a table into the format .ods, bug is reproduced?

xlsx is enemy format of file

2) Set font Liberation Sans for all sheet, save file to xlsx and open it in Windows and Ubuntu? Bug is reproduced?
Comment 3 Dmitry 2015-11-20 13:42:06 UTC
1) I'm using Office Open XML format for saving table.

2) I've tried to save file without any text and use Arial font.
Comment 4 tagezi 2015-11-20 14:45:22 UTC
Created attachment 120679 [details]
Sceershot of Print Preview

Kubuntu 14.04
LibreOffice 5.0.3

The table is displayed in a one page by default. See the attachment sceershot. So I can not confirm this bug.
Comment 5 BATMAH 2015-11-20 19:37:00 UTC
Created attachment 120685 [details]
2 pages ubuntu 14.04 Libre 5
Comment 6 BATMAH 2015-11-20 20:00:28 UTC
Created attachment 120686 [details]
2 pages ubuntu 14.04 Libre 4

I add 2 screenshot with this bug. I first met this problem in version 4 of the Office. I thought that this is a "feature" of render, but after tagezi comments there, I'm sure it was a bug.
Sorry for my English.
Comment 7 Roman Kuznetsov 2015-11-20 20:24:36 UTC
Created attachment 120687 [details]
column width (cm), up on Windows, down on Ubuntu-MATE

column width changes in Ubuntu-MATE 15.10 (LO 5.0.2.2)
Comment 8 Roman Kuznetsov 2015-11-20 20:27:45 UTC
I confirm this bug for

Windows 7 and LO 5.0.3.1

and

Ubuntu-MATE 15.10 and LO 5.0.2.2. 

Set status to NEW
Comment 9 Roman Kuznetsov 2015-11-20 20:54:36 UTC
if table from attach save to format .ods, then it opens in Ubuntu-MATE correctly. all 7 cells on one page
Comment 10 QA Administrators 2017-01-03 19:36:23 UTC Comment hidden (obsolete)
Comment 11 Timur 2017-01-04 14:12:11 UTC
So, XLSX has different fixed column width in Linux and Windows Calc versions.
But, since Windows Calc and MS Excel open it similarly, it's Linux Calc issue.

Reproduced in Ubuntu/Mint with LO 5.1 but not with LO 5.3, so I close as WFM.
Feel free to reopen if tested otherwise.