Bug Hunting Session
Bug 96008 - LibO Writer crashes when an extension is installed
Summary: LibO Writer crashes when an extension is installed
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:5.3.0 target:5.2.0.1 target:5.1.5
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2015-11-23 11:04 UTC by Zsir@f
Modified: 2016-10-25 18:54 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
"soffice --backtrace" output (17.52 KB, text/plain)
2016-01-16 14:43 UTC, Thomas Hackert
Details
zipped trace (709.83 KB, application/zip)
2016-01-16 14:46 UTC, Thomas Hackert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zsir@f 2015-11-23 11:04:33 UTC
When the Magenta Lorem Ipsum Generator is installed via extension manager and after open an exist or new Writer document, all LibreOffice crashes.
Extension link:
http://extensions.libreoffice.org/extension-center/magenta-lorem-ipsum-generator
Comment 1 tommy27 2015-11-23 12:50:17 UTC
please tell your exact Linux distro and version
Comment 2 Zsir@f 2015-11-23 16:00:29 UTC
openSUSE Leap 42.1
Comment 3 Buovjaga 2015-11-26 14:41:52 UTC
You could try getting debug information of the crash: https://wiki.documentfoundation.org/QA/BugReport/Debug_Information
You need to install the debug package first.
Comment 4 Jean-Baptiste Faure 2016-01-09 22:54:54 UTC
No crash for me, even if the extension does not work (its icon is grayed).

Best regards. JBF
Comment 5 Thomas Hackert 2016-01-16 14:40:42 UTC
Hello zsir, *,
I can confirm this bug with LO

Version: 5.1.0.2
Build-ID: ecd3574d51754b043f865cf5bafee286d24db7cc
CPU Threads: 4; OS Version: Linux 4.3; UI Render: default; 
Gebietsschema: de-DE (de_DE.UTF-8)

(parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux) with de-DE lang- as well as helppack on Debian Testing AMD64 ... :( But I cannot reproduce it with

Version: 5.0.4.2
Build-ID: 00m0(Build:2)
Gebietsschema: de-DE (de_DE.UTF-8)

(Debian's own version). I will attach a strace and a gbd log file later, though I have not installed any debug package ... :(
HTH
Thomas.
Comment 6 Thomas Hackert 2016-01-16 14:43:17 UTC
Created attachment 121991 [details]
"soffice --backtrace" output

My backtrack, which I got with "soffice --backtrace"
Comment 7 Thomas Hackert 2016-01-16 14:46:43 UTC
Created attachment 121993 [details]
zipped trace

Started "soffice --strace". As the strace.log file is 6.1MiB in size, I compressed it with ark ...
Comment 8 Caolán McNamara 2016-06-03 11:51:10 UTC
ReadLegacyAddons modifies its vectors of maDecks and maPanels in this case, but a load of things have (c++) references contents of the original so its all mangled
Comment 9 Commit Notification 2016-06-03 13:21:43 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fce299fc64fcfe5280966631613edda7e6031c16

Resolves: tdf#96008 crash when an extension with legacy decks is installed

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2016-06-03 14:41:15 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=89d38b8e0201861edbdad826e28f993aba8786be&h=libreoffice-5-2

Resolves: tdf#96008 crash when an extension with legacy decks is installed

It will be available in 5.2.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2016-06-07 07:20:28 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f5f5ad7fa79f414682f0e6f61b5612ff74ad38c3&h=libreoffice-5-1

Resolves: tdf#96008 crash when an extension with legacy decks is installed

It will be available in 5.1.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.